ATR Update Version Issue

Iam having this issue iam on pc (steam)

My atr is version 1.08 in content manager it says its up to date?

Whats the lates version?

That’s the latest version.

Still on 1.8 on Xbox I have had no notifications about updates.I think new version got pulled because it got realeased to early. Maybe will be today with new beta version

delete all the official atr liveries, then install only the ATR common package, that’s the only way I managed

Dude, thank you so much. I’m about to get stressed with this issue, but your solution worked for me. Thank you.

1 Like

This is currently being investigated again! Thank you for your patience.


I just booted the sim up and my atr started to download itself all on its lonesome so I assume this is now sorted.

It’s working again.

Thank you guys!

Ok… Got an atr back thank you, I will say it’s not the atr I had as its better for some reason; eg. I have numbers on my throttle levers where I didn’t before, my flap lever is white, it was definitely black before, it’s better on the ground, better on approach so… What did i have? I have 1.08.12, did my old one not or ever update? I’m going to buy it a present I think, it wants to go to Jersey egjj so new scenery time, but w t f was I flying…

When I’m waiting to fly back to the mainland from Jersey (irl) there’s usually a couple of them there. It’s what prompted me to buy it in the sim some time ago.
They have a Heron parked up at the airport as well, a guy bought it for £1 a couple of years ago.

Thank you, it is working now. I had deleted the ATR to see if I could download the new patch, but then couldn’t donwload the old version. Now it works!

I used Content Manager, it tried to download and gave me message download failed. Repeated couple times with the same result.
Is there any other way to install the package?
I deleted it on purpose hoping to get latest version.
Thank you!

There is solution approx 6 posts above yours. Search first, then ask :wink: That´s the key :slight_smile:

There is only one problem, I still have version 1.0.8 and I saw users having version 1.0.18 :slight_smile:

Iam also on 1.08 with no updates avaliable?

Do you have the same issue if you follow the OP’s steps to reproduce it?

Exactly the same, ATR update available, but unable to down load, error,

Provide extra information to complete the original description of the issue:

All the times i´ve checked the content manager, ATR aupdate was available, but no matter how many times I´ve always download failed

If relevant, provide additional screenshots/video:

Looks like there is a new 1.020 update for download.

1 Like

Yes, and it downloaded and installed successfully, too.

Do we have a changelog for this update?