Auto rudder after landing?!

Just because you didn’t make changes to the setting or AI assistance, doesn’t mean it doesn’t change… MSFS is notorious for having settings change on its own without you knowing or realising. So it’s easy to think that it’s an issue that’s unrelated to the setting. It’s best to double and triple check the settings to make sure everything is what you expect them to be.

Better yet, do a “refresh” of the setting where you change to a different setting, and you change it back just to make sure the setting is properly saved.

I am new to MSFS and flight sims in general. I have the same issue - rudder works great for take off and in the air, even landing - but as soon as it is time to taxi I lose control of it - it seems to be an auto pilot or AI and I felt like it was either trying to direct me to a gate, or to its own predetermined taxi path, but the last attempt at landing it wanted to take me away from the airport it seemed. Very frustrating. I have seen a few posts about turning all assist off - but being new and trying this with an xbox controller, turning all assist off pushes it past my skill level quickly, and that can’t be a fix, to remove features of the game? I have signed up for the $1 for first month xbox pass to try this game, and don’t want to invest in it or proper controls if this is going to be a long standing issue. I have seen simialr stories across a few forums, but no one who has posted back that it has been solved. Has anyone who is experiencing the issue found a fix?

I certainly wouldn’t be afraid to turn off just the rudder assist.

One big reason is for the issues you’ve mentioned, the other is that as the sim is currently, the rudder isn’t playing as big of a role in turning the aircraft as it would do, so in the air you aren’t going to find it too difficult to operate the aircraft with the triggers on your controller.

You may want to turn down their sensitivity a bit to make it less twitchy.

The other alternative would be to have the rudder assist off whist on the ground and then pop into the options and toggle it back on when you’re in the air, if you’re feeling you need it. Vice versa once you land.

Hope that helps.

I had tried turning off rudder assist and it didn’t seem to make a difference. After reading a few different posts on different forums, I tried this and for my last flight it worked: I set the Assist to True to Life, saved and restarted the game. I then went back in and leaving it on True to Life I customized many of the settings to get me the assist level I wanted, but left rudder assist alone. Previously I was losing rudder control after landing/right as it was time to taxi - I did 2 quick take off, circle back and land, one with just the runway as my destination and the other with a taxi to a gate and experienced no issues, I had full rudder control. My guess is that the Easy setting is doing something more in the background then can be controlled with the rudder assist - but whatever the issue is, this has solved it for me. Thanks to all the replies above and similar troubleshooting on other posts!

1 Like

I had some trouble downloading the latest WU. I never had trouble with that before, but this time, the glitch literally uninstalled the SIM. I had to download and install the whole thing followed by downloading all the World Updates. Now, my rudder works perfectly again. I’d not recommending this method of resolving the taxiway rudder problem, though, unless someone is truly, truly desperate. :wink:

I was able to resolve the issue by turning on autoruder and turning off landing assistant or something like that.

I have same problem. most of the time and with all aircraft as soon as I touch down it will take me off of runway. I have little or no control after landing and taxing. I use yoke and also foot rudders but still cannot control. It is a major problem

What troubleshooting steps that you have done? Basically as long as your assistance are all turned off and you have clearly defined your bindings with no conflicting control bindings across all your hardware, you should have no problems.