Auto rudder after landing?!

Hi,

Experiencing a really annoying error with rudder when I’m on the ground.

Flying is fine but the second I touch down it feels like I’m fighting against the co pilot or AI as the rudder is permanently stuck to one side. Once I break and stop the rudder resets but the same happens again. I’ve checked and the only auto feature turned on is the ATC talk.

Happy to upload a video if that helps! Any ideas?

Thanks

Check your assist settings, make sure they’re all set to Hard/True to Life to turn them all off.

And in real Life, a Airplane points its Nose in to the Wind on the Ground. So if Wind is coming from the Left, the Plane is going to the Left after touching Ground.

1 Like

Hey thanks for the replies. It’s definitely not the plane against the wind, the rudder is hard over. I’ll double check my settings then do a landing and send you a video if it’s still happening!

Hi, that rudder issue has stopped now, might have been the update yesteday. I’ve got another issue but I can’t post a new topic on the forums for some reason… I now want to engage selected altitude and heading but I don’t know how to ‘mid click’ to activate it on xbox. I’m clicking the scroll wheel on it but that’s not activating it. Any idea?

I’ve also experienced this. Sometimes it works and the next time it sticks in one direction. I also have a issue where the rudder doesn’t use the full left or right trigger range. If I fully press the trigger in the rudder returns to centre position, assuming it’s not stuck with the other problem!

This stopped randomly for me. I double checked AI rudder was off so it could be this was switched on for some reason during a flight

I’ve seen this issue before. Unplugging my USB device and plugging it back in will generally solve this

I’m having the exact same problem. With no peripherals plugged in or with controllers it acts the same. With the normal A320, when I have Take off auto-rudder turned OFF, a slight amount of right rudder is added and sticks when TAS reaches 30 and then re-centres as I leave the ground. Same when I land - as I touch down the rudder pulls to the right until I stop causing me to fight with it and swerve down the runway on take off and landing. If I turn turn off auto-rudder ON in the assistance menu then all seems okay… But I don’t want to fly with assistance on where possible.

What type of controls are you using? Keyboard? Xbox controller? joystick with twist axis? rudder pedals?

It does it with just mouse and keyboard plugged in with everything else disconnected, also does it with PS4 controller and thrustmaster t flight x.

As I accelerate past 30 knots it will just randomly kink slightly to the right and if I emergency stop it will realign to centre as it drops back below 30.

Well, did you try to compensate the rudder by pressing Rudder left button on your keyboard?

I think my question before is even though you unplug any other peripherals to test this. What is your main hardware that you would use for flying?

I have stripped it down to just the PC & keyboard with no other peripherals plugged in.

Before we go down the path of compensating the rudder etc I’ll try to explain what happens more clearly as this isn’t a crosswind blowing across the runway.

•The rudder is aligned centrally at stand still on the runway with the aircraft lined up correctly.
•Accelerate up to 29 knots with no issues.
•As the aircraft passes 30 knots the rudder physically moves slightly and holds causing the aircraft to slowly veer to the right.
•If the take off is aborted, as the speed comes down below 30 knots the rudder centralises itself again.

Did some testing tonight…

  • Happens with multiple aircraft when take off auto-rudder assist is switched to OFF so I believe I should have full manual control of the rudder.

  • Happens with no external input on my part, I can load the flight and simply throttle up and at 30 knots the rudder pulls right and stays like that until either off the ground or slowed down below 30 knots.

  • Nothing in community folder. Default aircraft with default livery.

  • No controllers or flight sticks/yokes connected/plugged in.

  • When the rudder moves to the right the pedals don’t move.

I’ll grab a video when I get chance.

Here’s a quick screen grab showing the rudder move to the right as I hit 30 knots and back to centre when it drops below 30.

It could be something else that’s not the take-off auto rudder that’s causing the issue. Have you tried the same thing by setting all assists to Hard/True to Life. so basically no assist in any form at all.

And make sure the assistance menu from the top toolbar is also Off for everything.

And if you are testing with keyboard and mouse only, make sure that your profile does not have any “Rudder Axis” bound to both keyboard and mouse.

Thanks for your suggestions Neo. I have tried switching all assists off and double checked all input bindings but no luck finding any fixes so far… I have just tried unplugging everything apart from my keyboard, setting the throttle and then unplugging the keyboard so there are zero inputs even plugged into my rig and it the rudder still moves to the right once the aircraft hits 30 knots.

but does it really turn after 30 knots, or if it’s just an external animation thing on the rudder? It just doesn’t seem to do anything in your video. I guess the question here is even after turning off all the assists, is the aircraft still uncontrollable for you on take off and landing?

I had a similar issue on landing. My aircraft seemed to turn sideways and skid down and off the runway. See my post

I have a Thrustmaster Flightstick and Thrustmaster rudder pedals.

I didn’t have any assists turned on except for ATC communication. But I did have rudder controls and trim mapped to my keyboard and Flightstick.

I fixed my issue by deleting all control surface mappings and brake mappings from my keyboard assignments. I also deleted brakes from Flightstick. Now only my rudder pedals control my rudder and brakes and I have a much better rollout on landing, and takeoff.

Yeah, it’s a golden rule now, that we shouldn’t have the same command binding coming from multiple keys or multiple hardware. Keep a single flight control coming from one hardware and delete the rest.

Even I had to nuke the entire Keyboard assignments, create a blank profile with only ESC bound to toggle pause, and nothing else.

If you don’t use a specific hardware for your flight, disconnect them. Or assign a blank profile to them so that they don’t give conflicting inputs into the sim.

1 Like