Autopilot not flying level

So I can not get my planes to fly level with autopilot I tried with most of the planes. It will fly to the altitude I have set but not the direction I set the heading but it doesn’t follow it. It just rolls really hard left or right till it crashes it will not fly level what so ever. Is it an issue with the game or am I not doing something right with autopilot?


Did you even put AP on?

Yeah A320 happens often.

Yeah you just got a finagle with it. Use the heading hold button if you have to.

I would turn AP on and I would use heading hold but it wouldn’t fly level

Even just turning in AP using the heading option will took the plane and head straight to 90° up. I’ve had this happen so many times that it is extremely frustrating especially during a 3 hour flight when it happens twenty minutes into flight. If I even attempt to turn in the AP, it Banks and rolls into the ground immediately.

1 Like

Have you found a solution?

I can’t say for sure about the airliners because I just don’t care to fly them, but I’ve got over 280 hours in this sim and I’ve never had even ONE problem with the autopilot in any of the GA planes. (Well, except for when I use Active Pause, but that’s an issue with that feature, not the Autopilot.) Otherwise, I keep trying to reproduce these other issues people keep bringing up, but so far, it always works for me. So weird.

No issue with any GA autopilot I’ve used, everything works as desired, heading, altitude, nav, flc or vs
I flew almost entire Japan trip with AP on, I was watching the amazing landscapes during the flight and did very little navigation myself, just takeoff, landing, and altitude changes due to mountains
Only issue so far is not with the AP, but the AI co-pilot that does not follow the route anymore. Zendesk sent already for this.

Are you sure you’re selecting correct settings? It’s not just a case of engaging the ap as that will often just hold the roll angle that is currently set. Make sure you’ve selected FMS to follow your flight plan or heading to follow your heading bug. Same with altitude. You need to select the altitude you want then either vertical speed or Flight level select to get there.

It happens mid flight while everything is set correctly. Altitude, heading, VS. It’s just random when it decided to Plummet me to earth. Afterwards I cannot use AP, I actually have to restart my PC and it’ll work. Mostly it’s just for the first flight, after that I do expect it to just go haywire. This is in a GA plane.

One other thing you might check is cross contamination in your controller set ups - two throttles allocated, don’t put elevator trim on an axis that may be sensitive. Delete everything you don’t use from your controller set ups (all 3 if you are using joystick, pedals and a throttle). Really clean out your controller settings. That’s what tamed my GA auto pilot woes!!

Its been my experience, that you can make all the settings before you take off. Don’t turn on the AP until you have reached stable flight, then it should work fine. If you turn AP on before you are in the air, every time my plane crashes, gaining back control is almost impossible, and then if you get control, turning AP on again, it just starts wanting to crash again. Try that and see if you have better luck.

I turned off automatic page file in windows and haven’t had an issue at all. Including live players with P2ATC

DrierChimp, assume you put fixed values into the boxes so you have some PF? Think I am going to do it as well. Although aside from not knowing enough about AP settings in the 787, got the G1000/3000 figured out pretty well. But if I can get the Jets figured out wont fly the GA craft anymore.

I’m having the same problems. If I level the plane out; trimmed level, etc. It slowly starts to either roll to the left or to the right until I’m flying in a circle???

I thought it was my mouse or keyboard malfunctioning…another bug I guess?

I just tried turning off my page files and it didn’t work I still fly in circles with autopilot

I had two good stable days, then last night it pitched my TBM upside down. Ugh, I sure hope this gets fixed. Plus I’m also using the TBM mod changes, including the screen brightness mod and the G3000 mod. I just quit since I was 30 minutes into a 3 hour flight and had no intention of trying to fly that by hand.

I’m using a Saitek X-52 HOTAS, no pedals and no extra equipment. Gonna go research and see what I can find, again…

I did a hour long flight last night in the Beechcraft and it held the altitude that I wanted. I let go of the yoke for about 5 minutes and the second I did it banked about 10 degrees and just flew in a circle so I had to keep the plane level the whole flight. I want to do longer flights but I’m not leveling it by hand for long flights

I am sure you know how to fly and all but what I am wondering si what is your airspeed when you are engaging your AP?

The only time I have ever had AP do a rapid climb and turns ending up in a stall or any other crazy stuff is when I have been very close to my Stall speed and when I engage AP and it tries to correct heading and desired altitude but isnt aware that I am going very slow…

Just maybe whats going on I dunno… I fly the Caravan all the time and slow airspeed is the only time my AP has tried to kill me.