Autopilot not working properly in External View

I and several friends also have this problem
Flight plan not followed in external view mode using G3000 or G1000 .I wanders off flight plan.
On returning to cockpit view - flight plan is followed OK.
Affects several planes including TBM930
Is there a solution to this problem?

1 Like

A workaround I found for my SO was to fly in cockpit mode only and only go on external view when you’re on autopilot and in the middle of a long flight plan leg. What I noticed is there seems to be an AI override while you’re on external, as if the “AI Piloting in Cursor Mode” setting on the Flight Assistant toolbar is on (even when it’s actually off). I watched my SO take off on external view mode fighting with the controls because something’s setting the throttle to 0 and deploying flaps on takeoff, and see it miss flight plan turns and drift on course until she goes back to cockpit view by which time the AP reacts to said drifting off course.

If I get a chance to record it I’ll contribute that to the bug thread.

1 Like

A workaround I have found is to open the MFD display as an external window (Alt-GR + click on MFD display).

Having the MFD visible (either from cockpit view or as an external window) seems to cure the AP inability (in 1.33.8.0) to maintain the course (esp when it changes) and VNAV limits.

The External MFD window can be resized (Edit: or minimized) and placed somewhere that is not obtrusive. If you close the external mfd window, the AP issues come back.

6 Likes

Much appreciated. Hope MS fix this asap.

Works brilliantly for us.Thanks for posting this.

That’s an excellent call, will definitely give it a try. Thank you!

New upgrade Yesterday, and issue not fixed…disapionted…

1 Like

edit: SO just tested this workaround, popping the MFD out through alt-gr + click worked even if the window is minimized rather than resized, see result video


Just to verify - would minimizing the window also cause the AP issues to come back or is it enough that the MFD window exists? I can’t test it because I do not experience the problem, but I’d like to know for my SO to try.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes, running in safe mode has the same effect

Which aircraft are you reporting an issue about? (Please also add the proper tag for it)

Boeing 787 (out of the box)

Brief description of the issue: When flying using the External View, the autopilot, whilst remaining engaged, seems to do its own thing with regard to heading particularly. Changing to Cockpit View seems to make it get back on the NAV heading again. It’s also not as accurate with Altitude and will continue to climb past the selected ALT in FLC mode. This seems to be a recent thing. It wasn’t happening a couple of weeks ago.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Same with TBM. Exact same thing. Just started recently

1 Like

It’s already been tagged as a “Bug logged” here:
Autopilot not working properly in External View

Regards

1 Like

Well, add to that now that it’s happening INSIDE as well. Never had either of these things happen until recently (like days ago recently).

Doing a simple TBM IFR flight from Orcas Island to Seattle and midway the plane just drifts off course with nothing that could be done to persuade it to get back on the magenta line on its own.

Thanks for checking - the work-around works for me too, so it’s great there is a relatively simple solution to this.

Tried a simple IFR flight in the TBM from Seattle to Astoria and the plane just ignored the second leg (a simple turn) and just flew straight ahead. At the proper altitude mind you just would not follow the magenta line.

I’ll try the popout “workaround” but really… should be be “working around” MAJOR problems like this that didn’t exist a few weeks ago? Yes MAJOR because like the ATC that always drops out and rarely works properly in that regard, now we (a) can’t use ATC reliably AND (b) can’t use AP reliably.

These major flight items sure are marketed differently than their actual functionality.

This is why many are dubious about 2024 by the way.

It is quite annoying that it worked fine for 2 years and then with the avionics update in May 23 it went south.
Did you mention it was happening when in the cockpit view, as well as when using the external view? That’s a further complication if so, and should be reported.

Well if you want it to work until they push a fix, you have these options:

  • use the workaround, and have it work
  • don’t use the workaround, and have it not work

and a third option:

  • don’t use the simulator at all until a fix is released

Given that they’ve refused to issue hotfixes for other regressions in the AAU2 update so far and said the “white dot” will be fixed in SU13, we probably have to wait until its scheduled release on September 21 for the fix.

They could push a fix sooner, but from what they’ve told us they plan not to.

Agreed that this sort of thing doesn’t give me confidence for bugs getting fixed in MSFS2024, but shrug it’s not open source so there’s nothing else you can do. You can either take what they give you, or not.

1 Like

This is very odd. I never had this problem until today whilst VFR in Turbo mod Bonanza in the Philippines, in VR. Like the OP, whilst in external view not only did the autopilot ignore the course change but also lost or gained up to 500ft before I noticed. Like everybody else reverting to cockpit view kicked the autopilot back into correcting everything.
The only thing I have changed since yesterday was to programme a PTT button on my Logitech yoke to select “1” in the ATC box response section instead of having to use the mouse all the time. There are no other bindings on that button.

Soooooo…

As of this writing and with this new bug, it would appear that the only way this game can reliably fly an airplane without “workarounds” is pure VFR? Not reliable on ATC. Not reliable on AP. They all need “workarounds”. So we can reliably fly the plane using VFR only from point A to point B with no other game interaction but that’s where the reliability ends it seems. That’s pretty sad at this stage of the game.

Great lead up to 2024 :roll_eyes:

Hi Terry, thanks for posting and I’m sorry to hear you have encountered this too. As I said, it can be relatively random - I might have a few hours of perfect flight until that one turn goes wrong. Your button binding change is unrelated as far as I can tell - I have tried an older, simple hotas in place of my normal VKB setup and had the same problem occur regardless.
Do try the ‘pop out and minimise PFD or MFD’ work-around - that seems to do the trick until an official fix is done.

Well… yeah, but I don’t think we need to be entirely negative and see this as a huge downslide.

The AI ATC has never been great from the off - it has changed and sometimes got a little better, sometimes a little worse for some of us, but they have done work on it, and you can hope that lessons have been learned.

The autopilot used to work fine in all scenarios until an unexpected bit of code in AAU2 caused issues in the external view only. The bug has been acknowledged, and they are working on a fix as they have with thousands of others since the start and it will no doubt get resolved, although I do of course get the frustration.

Remember, there are thousands of users out there happily flying around in their tubeliner cockpits and using vatsim or pilot-2-atc or whatever, and they will never have heard of or been bothered by either of these issues. So it isn’t entirely correct to say that the ‘only’ way to reliably fly without using some kind of work-around is in pure VFR, it’s only that way for some people. And if you accept the need to use the simple workarounds, then it’s a pretty minor inconvenience overall but of course it still needs to be addressed.