Autothrottle/IAS disengages on 787 with Bravo Quadrant

Please tag your post with #pc and/or #xbox.
Yes Sir!
Are you on Steam or Microsoft Store version?
Steam
Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
One livery for the 787 making it chrome - this is NOT the cause
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
I am unable to keep the A/T button lit (it flickers), and autothrottle automatically disconnects randomly, forcing me to manually thrust even when LNAV is engaged.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
-Use Bravo Quadrant
-Try to fly the 787 no matter what mod, you will encounter it at one point or another - sometimes after pressing APP, sometimes right after you take off and engage LNAV.

PC specs for those who want to assist (if not entered in your profile)
-ASUS TUF A15 - GPU: GTX 1650, enough VRAM/RAM
Build Version # when you first started experiencing this issue:
Ever since I started flying the 787, which was after the SU5 update.
Are you on the Steam or Microsoft Store version?
Steam. You asked me this already.
Did you submit this to Zendesk? If so, what is your ticket #?
No. Don’t even know what it is.

I really need some help with this one, guys. I am 100% certain that the source of the issue is my Bravo Quadrant - and I have been attempting to debug this issue FOR MONTHS. After finding out that simply unplugging the Bravo allowed the IAS light to stay on, I realized the Bravo Quadrant was responsible, possibly toggling something over and over. So I went into control settings and unmapped literally every button and even knobs except my throttles/speedbreak, thought I had it fixed, then boom, just happened again on my approach to Charlotte from KBUF.

Please - this is the only bug in the 787 ( I am using the NATIVE MSFS 2020 version, no mods, not that the heavy mod ever fixed this), I love this aircraft and want to fly in VATSIM with it, but I cannot have this keep happening. I have been Google searching like crazy to see if anyone else has encountered this “blinking light” or the autothrottle disconnecting out of the blue. Seems I am alone with the light blinking, but people have mentioned the 787 having issues with the Bravo.

I’ve tried it all. I wrote registry scripts for bug fixes for the Bravo, installed their drivers, did not help, made it worse in fact, so I did a complete reinstall of MSFS, but still the same issue. I paid $750 for this quadrant and $100 just for the 787, just to find out my own hardware is the root issue. I have taken so many steps to debug this that it’s not funny, and that’s why I’m here. I’m out of options here and REALLY need to be able to fly my 787 with my Bravo. There has to be someone out there who can provide some educated guesses here to assist me - you guys are very intelligent and I’ve never once been let down in a thread where I have come with a problem, but this time, I fear that nobody will find a fix and I am going to have to abandon my favorite aircraft of all time, for good, which will completely kill my (VERY EXPENSIVE) sim experience.

Please, please, someone help me. There’s people under 18 here that are geniuses, adult experts, please, if you’re reading this I need your help. THANK YOU.

This doesn’t only happen with the Bravo Quadrant. It even happens with simple ‘standard’ joysticks.

Maybe this is a tiny step to help with troubleshooting.

Hmm. Well then that tells me that it’s a broader hardware issue if that is in fact true - I’ve simply done everything short of writing the firmware for this thing and am at a loss. What about the device causes the flickering? Works great in the 747-8, but not 787-10. I’m forced to manually thrust throughout my flight after A/T dies on me/flickers.

If you scroll down in this thread, there’s a youtube video where you can see the joystick.

An obvious (additional) problem is that the hardware throttle affects the virtual thrustlevers despite the A/T ARM switches are in the on position.
This shouldn’t happen. Looks like the A/T is fighting the manual input, hence the flashing.

somebody please help this dude out

1 Like

Thanks Blue! Always can count on you – I wrote LastDitchEffort.reg and I just had a successful flight without A/T flickering, but I’m not celebrating yet. This always happens, I think I fixed it and when I’m finally happy doing a long flight BOOM it disengages/flickers. Doing more test flights.

Edit: Three successful flights thus far, KBUF-KROC-KJFK

Thank you, yes it does work when i plug out my joystick and reconnect back, but the lnav is down after 10 min of takeoff, i have to use autopilot for heading

That is because you need to go to Control Panel → Devices and Printers → Right click on your Logitech control stick → Game Controller Settings and Calibrate. The 787’s LNAV is extremely dependent on the input of your yoke/control stick(I know yours is the stick).

Problem was thought to be solved, it’s not. The A/T button began blinking again 15 flights later while I was Hurricane Hunting Ida.

If someone can’t help me out I’m abandoning this aircraft for the 747-8.

Oh, and this time unplugging my Quadarnt and AP multipanel even both at the same time did not stop the light from blinking. Back to square one. I’m so upset. Watch the SU6 update DO NOTHING but break this aircraft further.

Help, please, someone. I’ve had so many people and MSFS veterans watch my stream/cam and claim how “bizarre” this is.

Hope SU6 could fix this problems

Same issue on Xbox. Running a series X, mouse, keyboard and Thrustmaster HOTAS.

I’m sorry to bump this thread - Actually I’m not. At all. I have been waiting to fly this aircraft(this is my favorite, the only reason I spent $100 for Premium and $750 for my Bravo Quadrant, which is the cause of the issue) for forever it seems. Nobody has an answer except here: Flight Simulator 787 Auto Throttle - Microsoft Community

Which states my exact issue, but the original poster simply stated “All good now! Problem with the Bravo Quadrant programming.” That’s not very helpful. Despite what drivers I install, despite whether my LED’s work or not, this autothrottle keeps disengaging with the blinking A/T (IAS) light.

Someone PLEASE, please, help me. I have so much going on in my life right now and all I ever really wanted was to fly my 787 that I purchased with an extreme pricetag. I am usually the one who is able to help others with hardware bugs, but I am just too exhausted to keep trying to write registry scripts/batch scripts/etc to try and figure out what the root issue is.

The 787 is buggy when it comes to hardware, for example:
A Saitek/Logitech Yoke after rebooting, if not calibrated + LNAV = Death Dive. Fixed.

I fixed the landing gear bug. I fixed the LNAV bug. I’ve fixed this aircraft to the point where the only issue remaining is that out of nowhere the autothrottle will disengage and begin blinking again. I am unable to replicate this bug. I do not want to replace my $750 quadrant with my cheap plastic saitek throttle just to fly this aircraft. This isn’t fair, someone, anyone who is reading this, you aviation guys are extremely intelligent and I’m begging you for assistance.

Thank you. If you find the bug, no matter how petty it is, message me and I will be very grateful, and my gratitude goes very, very, very far.

My life is going very difficult right now and the only thing that roots me and keeps me clean off Heroin(I quit in 2018) is flying my 747-8, but I really need this 787. Please help me - in a strange ironic way the person who can help me determine the issue may actually save my life. Thank you so much.

Obviously it didn’t…I was hoping you were right, hence the long wait and why I am bumping this thread now. Asobo can’t even create a flyable 787 even though they charge so much money for it it’s a joke, even with all these updates, the bug being reported, they have done nothing. There is a solution to this, I just do not know how to replicate it, and I cannot just throw out my $750 quadrant and swap it with a piece of plastic to fly this aircraft.

I’m exhausted, I need peace, I need some help, I’m desperate to fix this aircraft at this point - I have been for some time as you can tell from my original post.

Edit: It’s ironic that as I google this bug, my own thread is the #1 result. With no solution.

I’ve had the quadrant since January and have had my fair share of autopilot bugs but this hasn’t ever been one. Maybe you should RMA your bravo and get a replacement. For me it’s just been certain autopilot functions get messed up after certain updates.

Same issue on xbox series x.
Peripherals in my case: (xbox controller wired + mouse wired + keyboard wired + Thrustmaster Hotas One) through an USB hub to xbox.
A/T flick happens very often, especially sometimes xbox controller start to vibrate to waring stall whilst AP is turned on.
Have tried reset auto thrust switch (upper the A/T button), shutdown/restart engines, flight level change reset, but no luck to finger out the logic.

Solution: Find the solution by going insane for months and writing tons of registry scripts/writing your own firmware to the point where your own antivirus thinks there is a rootkit/malware of somekind - submit to Zendesk and wait for mandatory update and have your own code be downloaded into the update itself - as a Direct3D programmer I did Microsoft’s job.

If you encounter this flickering light(which you will, it still is a bug), do the following:

-If you have Honeycomb Bravo drivers, UNINSTALL THEM. The LED’s are plug-and-play and do not require drivers/firmware/any kind of plugin whatsoever, they’re simply electrical lights powered via USB.
-Assign AXIS ONLY (NOTHING ELSE) to a preset control configuration(No softkeys are to be assigned, clear EVERYTHING except speedbrake/throttles/flaps).
-Gain altitude by whatever means necessary if you are too low (disengage A/T switch and go full throttle if you must)
-Push your yoke DOWN hard quickly to disengage autopilot.
-Re-engage autopilot - IAS light will go solid again.

I’ve been at this for months, I’m writing my own Flight simulator in Direct3D 11 and a bunch of other people are getting paid for my work.

The 787 is now flyable.

1 Like

Nice trick, and it works well on Xbox some how.

Walkthrough:

  • Pause (normal) When A/T flick
  • Unplug HotasOne from USB port (a hub in my case)
  • Plug in HotasOne
  • Unpause
  • Fix up aircraft attitude which leading to crash manually if needed.
  • Engage AP again and done

Do you have to disconnect the Hotas One on every flight? I just got to this post with the same problem as everyone. Not impressed but dissapointed that this problem has been going on unfixed since launch…

Fortunately not on every flight in my case (each day fresh booted Xbox + fresh started over MSFS + fresh plugged in Hotas).
I observed that seems Xbox version A/T has a very high chance to flicker when speed close to stall.

And yes, have to expect the incoming sim updates in flowing 2 or 3 months, hope Asobo won’t forget the Xbox users.