Big stuttering Help

I love flying, but after 4 months I became very discouraged. I don’t know what happened, but since then the game has been unplayable. Today I gave it another chance but it’s even worse, see the video link to YT. I haven’t changed anything or installed anything else and it’s getting worse, I don’t know what to think, help.
This stutters increases during the flight and this is what it looks like just before the approach
I’ve never had this before, but it’s been like this for 4 months which is why I don’t fly at all

Spec: 5800x3D, RTX4070Ti, 32Gb Ram, SSD M2, Windows 10, Nvidia drivers latest
Settings 2560x1440, DX12, FG, High/Ultra
Addons: PMDG, GSX, FSRealistic

reinstall MSFS? what do you think?

Try RTX 3070 upgraded to RTX 4080 SUPER - awful performance 20 fps, no visible difference - #41 by TenPatrol

Also rename community folder and create new empty community folder.

Thanks for the information, I uninstall nvidia drivers in safe mode via DDU, so the cache is always cleared, I have hibernation disabled. But I remembered that there is still rolling cache in MSFS, I removed it completely and did a 30-minute flight test and so far everything is back to normal, it is very smooth without any stutters, I will do longer tests this weekend and see if that solved the problem. Maybe there was a problem here.

  1. Consider clearing the Rolling Cache. Then assign a value of 8 GB.

  2. Please confirm you have nothing in your Community Folder except for the three add-ons that you mentioned.

  3. Set the terrain level of detail, buildings rendering and other sliders to 100. You can keep the rest of the settings to Ultra. Just set all the sliders to 100.

  4. Turn motion blur totally off.

Save settings. Then exit sim. Reload and report back.

  1. Is it necessary to turn it on? Now that I have removed it completely after quick tests, there is a big change and it runs very smoothly

  1. Terrain level of detail, buildings rendering and other sliders I always have it set to 100

  2. I had motion blur on, now I’ve turned it off

I will do longer tests on the weekend, but now after a 30-minute flight it works very smoothly

No, it is not necessary to have rolling cache turned on. I’ve had rolling cache turned off for over a year without any issues and my sim runs great. If you have a good stable reasonably fast internet connection there is really no need for rolling cache.

The additional compute overhead in a tightly mainthread hindered architecture along with the disk I/O that rolling cache injects is just overhead that is not needed with a good internet connection.

1 Like

Thank. I’ll just leave it turned off, I don’t need it, I have a very fast fiber optic internet connection. Terrain and objects load very quickly and well

2 Likes

That is very unusual. How does it run with Data off, to eliminate the internet from the equation. Also, the PC, was it built by you? I suggest going into the BIOS and “loading optimized defaults”. This should eliminate any issues with the CPU configuration. I had the opportunity to try a new GPU awhile back, and I discovered my 3080Ti was not quite seated properly. It ran okay, but not perfectly. After ensuring it was seated correctly, I’m very happy with it. The strangest things sometimes make the difference.

yes, I assembled the computer myself, everything works very well, there was probably a problem with the rolling cache after removal everything returned to normal but I will confirm it tomorrow when I make a longer flight

Looks like it was the Rolling Cache that was causing you the stutter. I have experienced that a couple of years ago for six months, along with very long sim loading times of 45 minutes! I, too, had almost stopped flying. Then, I deleted the Rolling Cache and the world turned conducive again. I am glad you are back in the skies. Enjoy!

2 Likes

Great to see you have managed to resolve the problem! I also have the rolling cache turned off, and even though I don’t have as good an internet connection available as yours, it has not been an issue. I also regularly clear the windows cache and temp folders etc.

If it helps for the future, deleting and reinstalling MSFS is a complete waste of time in 99.9% of cases, and the solution can be found (as you did) in the game settings, pc settings, drivers or hardware. In almost all cases across forums and FB groups, users say things like: “I deleted and reinstalled three times and it didn’t make any difference.” It almost never does.

5 Likes

Exactly tomorrow I will cover the same route as before and I will post a video of this approach, what is the difference

1 Like

I wish you good luck with that. Your success is everyone’s success. We were all in it with you.

GOOD LUCK!

And keep flying.

These are an awesome set of tips. Also found some on completely clearing all cache, registry and other cleanup tools(most I had to add on because I got Windows 11 home) and it made a HUGE difference with micro stutters, even quick views over super congested areas with lots of traffic all went away.

It was a whole host of small stuff from this blog. I didn’t do any sim limiting of performance/fps (7800/4080S) or removing items, just all the little tweaks. The first MSFS forum post above is the bulk of it, some of it is repeated on the blog. You just have to be a little careful with it.

It was always the Rolling cache for me. I disabled it and never experienced this for months.

1 Like

That blog may have some good tips, but these are nonsense:

In Nvidia Control Panel for MSFS, set Max Frame Rate to 30.
In Nvidia Control Panel, for MSFS, set Power Management to NORMAL.
Disable and remove DirectX Shader Cache using NCP and Disk Clean-up.

I also have some questions about this:

In Nvidia Control Panel, for MSFS, set Background Application Max Frame Rate to 30.

Many of the rest of the suggestions neuter the sim’s graphical fidelity in a quest for FPS.

As for the netsh tricks… I’ve found absolutely no benefit from this.

No, do not reinstall. I had the same problem. The solution was to delete and recreate the rolling cache.
Before was the cache 15 GB, now 20 GB

Gentlemen, I’m back as I promised and I’m very happy, the problem was solved in my case, it was the rolling cache, I completely removed it and turned it off, everything went back to normal, it’s very smooth, no stuttering, look at these few shots, it’s amazing. Thank you all very much for your help and I think it will be useful to others in the future! Now I want to fly

The sky is calling!

2 Likes