"Black screen" when starting/installing/re-installing MSFS 2020

When I started MSFS 2020 yesterday I just got a black screen instead of the usual welcome screen. No matter what I tried this problem persisted, so I decided to uninstall and install MSFS from scratch, hoping that would take care of the issue.

But the problem still persists, MSFS will start with just a black screen, there will be a small circle in the bottom right corner for about 2-3 seconds, then the screen will turn completely black and stay like that. I’ve waited for hours, hoping there was some background processing/downloading that would eventually finish, but it’s a no-go. The windows show “Microsoft Flight Simulator - 1.13.16.0” so it should be the latest version. I’ve tried this somewhere between 5-10 times with the same result, just a sad black screen.

I’ve googled the issue and tried every “solution” I found, including:

  • Disabling all my sound devices
  • Deleting (un-pairing) any Bluetooth devices
  • Un-plugging all my USB devices
  • Stopping ALL other apps before starting MSFS
  • Updating my Nvidia graphics drivers, played around with different versions just in case
  • Starting MSFS through the Xbox app
  • Starting MSFS as Administrator
  • Logging out from my MS account, both in “Microsoft Store” and the “Xbox app”
  • Disabling antivirus software
  • Disabling Windows Firewall (it did ask for permission for MSFS the first time I started it after re-installing, and I can see the rule for it in the Windows Firewall config)
  • Installing on drive C, I normally install MSFS on my drive E, which makes no difference with regards to the “black window”

Nothing works, the MSFS window remains as black as the darkest night.

My copy of MSFS 2020 is bought through the “Microsoft Store” about three months ago, and I’ve not had any issues like this in the past.

The “community” folder does not even exist at this point as the “black screen hang” happens after the initial install of the app, and before downloading of the rest of the content start. So this is not a case of an “incompatible addon”. All my addons are installed in a different folder anyhow, and I use “MSFS Addon Manager” to enable them (create symlinks in the “community” folder). But at this point, the “community” folder does not exist.

I’m using Windows 10 Pro version 20H2 build 19042.804 (the latest - with all service packs installed)

Some of my hardware:

  • AMD Ryzen 9 3900X
  • Nvidia RTX 2070 Super (graphics driver version 461.40 - currently the latest)
  • 64MB RAM
  • 3 * SSD NVME drives

According to Windows Task Manager, the “FlightSimulator.exe” process sits there using between 9-11% CPU, memory consumption does not change over time, and there seems to be zero network or disk activity.

Digging a bit further I checked if I could see what the process “flightsimulator.exe” were doing by using “Process Monitor” (from www.sysineternals.com) but I didn’t see anything that gave me a clue of where to look next.

If MSFS at least would give some sort of error message then at least I would get a clue of where to look, but no, nada, nothing.

Does anyone have any idea of how to solve this, or at least how to debug this?

Does anyone know if/where MSFS writes (error)log files?

I did submit a request through ZenDesk re this (Request #93063) but I don’t have any hopes for a quick solution through ZenDesk.

Any help at all would be appreciated at this time!

I’m seeing the same thing, and I’ve done (most of) what you’ve done: nothing helps, and I have just a black screen.

I’ve successfully run MSFS on this exact machine since it was released, but when I tried to start it this morning I got the black screen. I tried uninstalling and starting again, following the instructions on the flightsimulator.zendesk.com site, and when that didn’t work, so many other things.

No joy.

1 Like

Same goes for me, game ran fantastic until last week but now there’s only a black screen. Taskmanager shows it running but nothing happens. :sob::sob:

Yep i have the same problem.

worked through the whole zendesk guide but still the same

A clean install of W10 is looking like only option as M$ still not replied to my Support request (Although its night in USA)

mine was from M$ $tore too :frowning:

Regards
Rick

hopefully someone will find the answer (not sound output as that doesn’t fix it)

Exact same problem here, I’ve done all the troubleshooting steps I could possibly find… nothing helps!

May I suggest that you all post the essential pieces of your hardware and driver versions to see if there’s a pattern?

Exact same problem here. Initially I got a black screen at the Update page(where you download the files)

Now, it’s all black, and a re-install didn’t help either.

Hopelessly waiting for Zendesk to answer the ticket. Until then, my wings are off.

Let us know if they can fix your sim :wink:

Hi,

On Monday 2/15, game played perfectly fine. I had just finished fixing a graphics driver issue which seemed to cause random crashing. Updated to AMD 21.2.2 (optional) driver and all seemed fine after flying over NYC for a while.

Tried to play the game today. It “launches”, but the screen is totally black. The game audio and music is there. I can click on the menu buttons (even though I can’t see them).

I tried the following:

Revert to August 2020 graphics driver
Revert to latest WHQL (20.11.2) graphics driver
Uninstall windows update and security update from 2/14
Disable AMD audio device, switch back to normal USB audio device
Repair and reset options via “app settings”

No change in the behavior. Then I found out that FS had an update on 2/16 to 1.13.16.0, and I figure it is the last remaining option. But, I haven’t seen anyone else report it yet.

By the way, today, I got a Microsoft Store Package Dependency Installer dialog box before the game “launched”, which I never got before. Selecting Yes or No does not change the outcome. Still doesn’t really open.

System:

Xeon E3-1240 v3
12GB DDR3
Radeon RX5500 XT

Thanks.

Seems like I am not alone experiencing this. As I wrote in my initial post I did open a support ticket in Zendesk, and I encourage all that experience this to do the same so they realize that this affects quite a lot of people. Since 6 others replied they see the same problem within a day from I posted this, quite a lot of people must be affected by this since most of those affected will not have seen my post here.

I did get a response from support saying they will look into the matter, but I suspect that is just a standard answer. So if you do experience this then please contribute to a solution by creating a support ticket.

Create your support ticket here: https://flightsimulator.zendesk.com/

1 Like

Have raised another support ticket

but mine downloads the 1.5 gb ish file from Windows store.

then when i click the msfs icon it created on desktop
i get a black window with a white border for 3 seconds
then full black with swirling circle icon bottom right for 3 second then black screen till i close it with Alt F4 (have left it overnight to see if it eventually loaded but no it didn’t.

my sim was fine till World3 update.

i have had not crashing or CTD’s since first release version
nothing, all worked great.

i even went as far as purchasing again but this time from steam

exactly the same issue so got refund.

Regards
Rick

I’m running Windows 10 Pro Insider 21313.
My build is:

Ryzen 7 5800X
32GB RAM
RTX 3080
1TB NVME

I’ve opened a ticket with Zendesk… hopefully they’ll find where the issue is.
I don’t get any music playing or anything, mine is more similar to what @CaptRickSparrow described: the black window with a dark border, then full black with circle icon in the bottom right for a few seconds and the custom mouse pointer, and then the circle disappears.
Going into Task Manager, I see that GPU usage is around 80-85% but no display.

im on same version of windows insider so hope its not that as you can’t reverse

only clean install of windows :frowning:

your description is identical to what i see (you just put it better ) :wink:

Actually should be fairly easy to test, I’ve got a laptop running 21313 with a dGPU that I previously played MSFS 2020 on, so I know it used to work. I’ll try to install it there and see how it goes

Sounds like exactly what I am experiencing. Hopefully they will find a solution for this sooner rather than later.

I’m on version 20H2 build 19042.804 so that points to this having nothing to do with the insider build.

Yep, can confirm it walks flawlessly (albeit at 20fps) on my laptop

I found something! Try launching from the command line with the “-FastLaunch” flag, so literally just open PowerShell and type in “FlightSimulator.exe -FastLaunch”

What happens when you try to start MSFS with the -FastLaunch flag?

In my case MSFS is no longer installed, well it’s installed but only the first 1.5GB from the MS STore is. So when I start it it’s supposed to start downloading and install the rest. I don’t think the -FastLaunch flag is applicable until it’s fully installed.

Anyhow I just get an error message if I try “flightsimulator.exe -FastLaunch”.

But looking at the shortcut for MSFS I see that it is “Microsoft.FlightSimulator_8wekyb3d8bbwe!App”, and when I had it installed this would launch it in fastlaunch mode: “cmd.exe /C start shell:AppsFolder\Microsoft.FlightSimulator_8wekyb3d8bbwe!App -FastLaunch”

However it does not make any difference if I do that now, it starts and hangs at the pitch black window as before.

For those who might not know, the “-FastLaunch” flag is supposed to skip some of the intro videos so MSFS will start up a bit faster. I have mine installed on a superfast NVME SSD so I never bothered with that.

4 Likes

Completely agree, but it seems for me at least the problem has to do with the intro videos since launching with the flag on does make it run normally.

I think an important thing to clarify is mine wouldn’t even get to the installer, I would install the 1.5GB “launcher” from MS Store but then never get to download the full game. Running the command above from PowerShell let’s me access the launcher!

1 Like