Blinking clouds after patch 5

Does anyone know if update # 6 fixed the flickering clouds issue, or will I have to buy PC. :frowning:

1 Like

It did not fix the issue if you have one of the impacted graphics cards unfortunately. I found a used card a guy is selling locally - hopefully he still has it Friday and I can fly again! It is only a GTX 1060 6GB but it will get me going until I can get something better later. Good luck.

1 Like

I consider clouds to be a guaranteed feature of this simulator. This must also apply to 700 series graphics cards. This is how the game was sold! :triumph:


Same here…please fix it Asobo :frowning:

1 Like

But are you able to see clouds at all when it is not flickering? I can make the flicker stop by looking down at my seat and opening and closing the menu until no more clouds are visible (I haven’t tried minimizing the window yet). I Look back out the window, no flickering, but also no clouds. I can see shadows on the ground and haze is still there, but no visible clouds.

Yup. Make the smaller window quite small - half screen size or so to force Windows to redraw it properly. Then maximise and clouds are fine. Have been playing the landings challenges and most have clouds. So there’s nothing wrong with my GTX960M. They introduced a bug somewhere. I also raised a Zendesk ticket. Best is to flood them with the same ticket.

Can you give me a short movie

Oh wow. I have to try this. Does it take away the flicker and show clouds fine for that session?

Unfortunately this doesn’t seem to work for me. Resizing the window causes the clouds to disappear completely, and when I change the weather or go back to full screen, both the clouds and the flickering return. Which driver version are you using?

Your GPU is?

Can only upload small videos of about 1 second so hope these have loaded ok! Is easy to replicate though. These are my settings, sort of a mix to get the best graphics versus FPS, getting close to 15-20 mostly, even windowed, so is playable. V-Sync off made a big difference.

First vid is with flickering clouds in a smaller window - video capture does not show the window border.

Second is with screen maximised, flickering clouds gone - it actually removes the clouds

I raised a ticket with the same heading. Best is to smother Zendesk with tickets for the same issue so that they respond, I know it’s wicked, but it is not a graphics card limitation, is a bug they introduced.

I do enjoy the game. Used to fly small planes in the 90s and being able to fly anywhere in the world is mind blowing. The landing challenges are great as the best part of flying to me was landing and they are so good in the sim.

GPU details:
Operating System: Windows 10 Pro, 64-bit
DirectX version: 12.0
GPU processor: GeForce GTX 960M
Driver version: 457.09

Laptop is Dell Inspiron I7-6700HQ chip so quite old, with 16gb RAM. Game is quite playable though in spite of its massive size. Have to run it from an SSD drive.

1 Like

It actually removes clouds when you resize the window

what did you mean with atmospheric effects? did you mean whether option clear skies?

1 Like

No, you have to go to developer options, and enable “Developer mode”, now you will have a menu bar on the top. Then you have to select the “options” menu, and uncheck “atmospheric effects”

finally they respond to me

Hi amir,

We have recorded the bug you have submitted in our internal bug and issue tracker.

To understand what will happen next, visit the Zendesk Bug Reporting FAQ

Best regards,
Microsoft Flight Simulator Support Team


Ha ok so you game with depelover mod Always on?

Bug report sent, please make the same if you have this problem.

Please please please PLEASE fix this mess. This benefits no one, and ruins the entire product for thousands.
There is no way for many of us to upgrade, especially not at this time. How about holding off on such a DRASTIC change until some other time? Not 3 months after launch?

The whole thing was perfectly smooth two weeks ago, I was running volumetric clouds on ULTRA for gods sake.

Come on guys. Completely game-breaking. This is the most significant bug in the entire game right now.


Any of you other “beta testers” made any progress on finding a fix other than clear skies?

Create a Zendesk report, and vote the thread I’m linking below. According to support, our chances of getting a timely fix depends directly on the amount of people that report this issue.