Blue screen and reboot downloading Japan then stuck on checking for updates

Hi all

Been using FS 2020 for more than a month with no issues. Added 3070ti 2 weeks ago and been using without issue until now…

Went into marketplace and installed some free add ons, Japan update, A32nx and a few others. I just clicked on them and let them download in the background.

Suddenly I got a blue screen encountered an error and pc rebooted itself. After that whenever I tried to run FS again it would get stuck on Checking for updates

After trying many things to get it working I ended up un-installing and re-installing and that seemed to work but I had to download over 80gb again…

OK so after that the game loads and I went into marketplace again to try and download the add ons one by one… first did A32nx again… no problem

Tried to do Japan and about halfway through same issue! Blue screen, restart and now again stuck again on checking for updates whenever I launch

Nothing in my community folder… obviously the failed download is causing issues I guess why it gets stuck on checking for updates but this is now doing my head in! Cant imagine why it keeps getting a blue screen. Going to be hard to diagnose… brand new PC… everything an no issues until now!

Guess I am going to have to uninstall and reinstall again but this is not a solution! I should be able to download add ons!

Samsung 1TB 980 PRO M.2 NVMe SSD
AMD Ryzen 5 5600X
G.Skill 32GB (2x16GB) F4-3600C16D-32GTZNC Trident Z Neo C 3600MHz AMD RGB DDR4 RAM -9
Asus ROG Strix X570-E Gaming AM4 ATX Motherboard
Asus TUF 3070ti

latest drivers everything latest version of FS how do I go about diagnosing and find logs please what causes the issue?


Maybe try to send this problem to zendesk? Or hopefully someone on here can give you a solution.

in each case create a ZenDesk ticket :slight_smile:

The issue starts within installing these A32nx , or ?

With a bit luck we have a log message within the Windows Event Viewer. Can you check ?

Generally is BSOD not normal and often caused by hardware or a driver, or may be the RAM. But as allways, hard to say.

Thanks guys so I ram a memtest last night it passed with flying colours

My nvme SSD which it’s installing the packages too checked out ok

I need to turn on hardware monitoring next and check the temps etc. I do have xmp profile turned on so I will try turning that off

I’m pleased to report I was able get the Sim loaded past the checking for updated screen by deleting all the Japan folders which is the update that failed.

I tried to install USA 2 and it did the same and blue screened but when I restarted FS it didn’t get stuck on the checking for updated screen this time and it actually says this update is installed fine

Have tried twice now to install the UK update but Blue screen again :

This is so weird why this is blue screening just downloading and installing updates. You would think a hardware failure would happen when actually running the game

What’s more when I did the reinstall and it downloaded 80gb of data it went through without a hitch. But now suddenly trying to download a 1.69 GB Japan update and it blue screens!

So I’ve tried disabling xmp, increase page file size, a bunch of other stuff and still getting freezes and reboots, no blue screens though

I managed to download Japan this time it went through without issue but still try to download something larger like UK and it freezes and reboots in random place

I see that when I’m on the screen downloading the updates the GPU is sitting at 100% load and 85% memory utilisation. Surely this can’t be right! I’m not gaming! I’m just on a static screen downloading content! I’ve got a 3070ti btw

So I’ve noted that everytime it falls I get in the event viewer event id 161 volmgr2 followed by the event id 41 with bugcode 292

The event id 161 under details tells me dump file creation failed due to error during dump creation

The details for this event is against the SSD does that mean the SSD could be causing the fault or it’s just because the SSD is the boot/windows drive and is where the dumpfile would be created

I’m well over this now it seems it’s either the nvme SSD or the PSU? All diagnostics tell me the SSD is fine how do I check for faulty PSU?

Unfortunately it is… there are some threads, but also unfortunately in meanwhile hidden in “wish list” and no longer as “an issue”. I assume since a while that the high load in main menu and or while loading, cause some trouble because users system runs in full load and in case the system is not bullet-proof stable ( mainly heat ), we see then bsod, reboots etc.

Errors about “volumes” must not necessarly mean your “hardware drive”, but hard to say :).
​There are also drivers for ahci, nvme, etc. You get BSOD/reboots only or also “simple” game crash’s ?

Also error while dump creation can be normal in case of bsod ( its followed by kernel power and so it wasnt enough time to write the dump ). It should not happen for a normal game crash.

In case you have running applications in parallel , stop them… eg. also tools like Afterburner.
Also run a sfc /scannow or dism …

which PSU is currenlty build in ?

Thanks the PSU is a Corsair gold 850w rm850x brand new

I did some testing I changed the GPU tweak from oc mode to gaming and it was able to get through the France Belgium update 5gb no worries

But then BSOD again on the UK one. I did some isolation testing and download the updates from content manager and downloaded the UK points of interest. 3 gb or so. The whole file downloaed fine but as soon as it got to decompressing boom! BSOD again :frowning:

Now I’m thinking its the GPU which is going to suck if it is trying to get a replacement :frowning:

Going to try and remove drivers using DDU and stress test the GPU

First I’m going to try and limit the GPU to 30fps so it doesn’t work as hard decompressing Ive seen this suggestion elsewhere. If the GPU is BSOD under stress like that something is seriously wrong. Initial temp monitoring doesn’t show any abnormal temps on the GPU


So yeah I think it’s the GPU. I have done a bunch of stuff and don’t know what’s worked but will slowly add things back in but basically:

I turned my case fans up to full
I limited the GPU to 30 FPS and 1080 and low settings and windowed mode and made it small
I bumped up the GPU fan to full

Now the the GPU is sitting around 33 degrees, and no 100% utilised and everything seems ok

Still this is not a solution I’m going to have to stress test the GPU now and find out if it’s faulty or if my case fans is inadequate. My case is also new with two 140mm fans, nzxt h710i which is supposed to be good for cooling

in hard summer days, around 30degree in my room, I have my pc-case open :slight_smile:

May be… because “while decompressing” , it can also be the CPU or another component which get indirect the heat from GPU…

Logged a Zendesk ticket on this

The issue seems better but not resolved

Was able to download 2 world updates in a row without issue. Japan and UK I think but when I didn’t the third, Nordic 5.15gb it blue screened

So that’s a lot better than the initial issue when everytime I downloaded one world update it would Blue screen so something I have done has fixed the problem a little bit

Did a gpu stress test with occt for 1 hour. No errors

Tried using hwinfo64 to log all the stats but there doesn’t appear to be a log entry when the Blue screen occurred or if there is, there are anomalies reported with voltages or temps. I set the polling to 50ms even. So maybe the blue screen causes hwinfo to crash and not report

Currently running a CPU test with occt for the past 36 minutes with no errors…

Also I uninstalled Asus GPU tweak and that didn’t help either

I think I may have found the cause lies with a 24 pin extension cable I was using as I removed this was able to get no blue screens for 3 runs of downloading and decompressing files from the marketplace

Still strange if this extension was causing an issue in power spikses why did all the stress tests I ran which max out the power run fine without blue screens?

Also when actually playing the game there are no blue screens and no blue screens downloading and decompressing game updates
Only when decompressing marketplace files…

1 Like

Exact same symptoms here. One Blue Screen during update. Tried quiet a few suggestions found on the forums to get rid of the endless “Checking for Updates…” to no avail. Uninstalled and 8 hours into the fresh Install (50%). The last two MSFS SU’s have required a complete new install for me. All was fine before that since last September.

No GPU symptoms prior to the blue screen with me. My 1080 fan comes on pretty quickly and wasn’t on at all during the initial update attempt, nor is on during the re-install…

1 Like

Complete reinstall worked for me (~24 hours). Noticed high GPU fan on downloading USA World Update from Content Manager. Dropped to windowed in options and shrunk the window down and the GPU cooled off.

1 Like

me too. How to fix it?

please… dont’ write tooo many words. There is a risk that if you write more words, we will possible understand what you mean, what’s the situation in your case, whats your system … and that we with this infos possible can give you helpfull hints :wink:


For info, the following thread is still open (and is now the main one) for reporting/discussing this issue further: