Boeing 787 Autopilot Not Tracking

I’m having an issue with the 787 Heavy Division mod not tracking the route correctly. I load the route from sim brief, go through the pre flight including verifying position on the ground. Once I take off and engage AP and LNAV the aircraft tracks close to the routing but doesn’t actually follow the route. It almost seems to parallel the track. I’ve tried manually flying the aircraft back to the route and re-engaging AP but the issue resurfaces. Anyone else having this issue?

I’m a bit unclear with your question. Perhaps a screenshot would be nice.
Is the autopilot not following the path at all (like turning to a different heading, away from the flight path. Or if the path turns, the aircraft doesn’t turn with it)? Or is the aircraft still tracking the flight path, but only the positioning is not directly in the middle of the path?

If it’s the former issue. Try to check a few things in your setting. Like, making sure your flight model is set to Modern, and add some deadzones to your primary flight control axis. Like 5-10% should be enough.

If it’s the latter issue, I think it’s just the GPS inaccuracy and you’re too zoomed in on the ND. Aircraft doesn’t exactly follow the line directly in the center, there’s always a slight offset either because of wind, or simply the GPS accuracy is not 100% ideal. I think as long as it’s still following the flight path and make the right turn in time, you’ll get to your destination just fine. Zooming out to cover more area in your ND will also make the view between the aircraft and the line to go closer together.


Here is a screenshot, I took a video as well but the file was too large. After take off I manually followed the flight plan and lined up with my route. I then engaged auto pilot and the aircraft began a steep turn to the left. I attempted to override that by inputting direct SHALW in the FMS and the aircraft continued the left turn anyways until it rolled level on heading 043.

1 Like

Hmmm… interesting…

787 AP/LNAV even with flight plan via MSFS Flight planner not working correctly these days. No ILS. No Loc & glide slope markers on PFD…

2 Likes

I’m using HD mod in version v0.1.8 B78XH.
Yesterday I flew with him without any problems. :thinking:
Which version are you using?

I’ve had no such problems with GPS or ILS using the Heavy mod. I think you have some other issue

Version 0.1.9

I had problems with this version 0.1.9 when I needed to set the SID and STAR in the aircraft’s FMC. So I went back to the previous version. But version 0.1.9 also followed the route normally.

Same issue, especially enter the STAR procedure.
The plane didn’t follow the route anymore.

Not anymore? So you’re saying it did before?

No, I mean that when the plane fly near the STAR starting waypoint.
Just like your picture, it go straight and will not follow the route anymore.
This issue occurred recently, and happened on other planes, too.

So … it didn’t have this problem before?…. When did it start?

Since the last update.
Hope the issue will be solved in the next update.

i have had the same problem it never followed the flight plan and apparently there is a problem with the 787 not following the flight plan from what i have heard they are working to fix it

Yes, I am having exactly the same problem. It just started with Update 5 and the fix a day or two later. The aircraft gets to the intended destination, but it flies several miles parallel to the GPS red line. If I take it off autopilot and put it on the red line, as soon as I put it back on autopilot, it will turn and go onto the path it was on before, several miles off the GPS red line. It’s disconcerting because it confuses me as to what it’s doing even though it ends up at the right place. It does this with all aircraft.

I think he’s using simbrief?

Mine does that Lnav engaged and the 787 rolls away from flight plan .

1 Like

I load my route from the mfs2020 start up screen and when I engage the autopilot and Lnav it rolls away and I have to try to correct it ,have to have AI to fly it .

I have exactly the same issue with the TBM-930 and the King Air. I never had problems at all until update 5, and the issue still exists after update 6. Once the autopilot is set up and engaged, the aircraft flies in the general direction accurately, but several miles parallel to the magenta NAV line on the screen. I do not have problems with aircraft that have the Garmin G-1000. I have the basic version of MSFS 2020, so I do not have a Boeing 787.