Bonanza G36 autopilot issues with SU6

Are you on Steam or Microsoft Store version?

Xbox Series S

Brief description of the issue:

Since SU6 the G36 Bonanza has serious problems with autopilot. Altitude hold, VS and FLC do not work properly. When pressing ALT the aircraft seems to stay on the current altitude but the G1000 display says 0 ft. Selecting a new altitude with the knob and then engaging either VS or FLC mode to get to it does not work, when the plane reaches the selected altitude it does not capture it and switch to altitude hold, it just keeps going up or down at the rate selected with VS or FLC.

Detail steps to reproduce the issue encountered:

Load up the Bonanza, get to air, and try to use the autopilot altitude modes. I have tried both a cold start and starting from the runway and the issue exists in both cases.

Build Version # when you first started experiencing this issue:

SU6 -

Yup! I noticed the same thing on my very first flight after updating. PC version for me. I detailed my experience here. I was trying to complete the Norway Bush Trip, and just-my-luck that it uses the Bonanza for that trip.

I’m having another issue with the trip legs never recognizing when I land at my destination, but that’s another bug for another time.

Should replace the stock G1000 with NXi…works like a top!

1 Like

Same issue with SU6 Bonanza Autopilot.

Steam version on PC

Installing G1000 NXi from the marketplace is a workaround, based on a quick test flight. ALT/VS/FLC work with that. As a bonus it has an EGT gauge! :+1:

Tried Martketplace NXi. Did not solve the problem for me

The problem with autopilot it happening in all airplanes. I tried to fly A320neo, Boeing 747, Cessna with G1000 and I had problem in all of them.

It’s ridiculous, it supposed to be a SU to fix problems, but just brought more.

Same here. Also tried starting in flight with the same issue.

Same issue w/ Bonanza. No capture of altitude. Seems to work in the C172. Also, what happed to the N number on the side of the plane?

Yep - same here for me too !!!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.