[BUG LOGGED] Consistent CTD when zooming in to the world Map

I have a consistant Crash to Desktop when zooming into the world map. Happens 100% of the time, if i zoom in, and pan around the sound first starts to corrupt and jitter, and then it crashes back to the desktop.

No community addons, no SIMCONNECT apps running, Seems like a bug with Maps
UPDATE
Still happening with the Hotfix (build 1.18.14)
I have used NVidia Screen Recorder to actually record two examples of this happening and done ont he hotfix version, which I have included here. First one occurs pretty rapidly, the second takes a bit longer, but the crash ALLWAYS happens.

Update 2
Still happening with the latest hotfix (1.18.15.0) I am going to try and clean re-install windows and with minimum software then see if the issue still exists.

Update 3
I have completely blanked out my Windows system, and re-installed windows, and with a minimal install of windows (all updates, only steam, firefox, and chrome, and using all default drivers apart from nvidia), then after I re-installed MSFS from steam, and installed ONLY the world updates, no other third party marketplace items, and so far there has been no crashes on the map screen. Note prior to re-installing windows/msfs i had it in a similar state but DID get crashes.

I am going to slowly and carefully re-install my add ons, first via marketplace, and then other addons, as well as othger drivers, by Services for linux, and other applications, and continue my investigations.

I am not marking it as solved, as up until I installed SU5, the sim was remarkably stable, which leads be to believe, either the installation got corrupted during SU5 install (possible, due to the constant issues trying to install the update due to demand), or some marketplace/third party content is causing crashes. As I am seeing an xbox user also seeing similar crashes(see bellow), I will slowing focus on marketplace items.

Do you have a crash when click on Fly too (ex: in the training or discovery flights)?

Lots of people seem to be having these map and Fly issues but still no workaround…

3 Likes

similar to these report ?

1 Like

I have this issue too, it happens if I Zoom in to a area. Doesn’t seem to happen as often when it’s in night mode. But definitely constant. Need to fix this.

2 Likes

Yes 100% I have this same issue

2 Likes

PS: in such a case, don’t forget voting :slight_smile:

1 Like

I can see why it is a nightmare for the Devs to fix a bug that occurs to some people and then never to others. I’ve tried to replicate these issues on my PC many times and nothing happened.

1 Like

Yup same problem at my end. Never had a single CTD all version till this one. Every single time a CTD when zooming in the world map view.

HELPPP :relaxed:

3 Likes

Exactly the same. The game loads fine, but when I click on World Map and either zoom or just wait a few seconds the sound starts to jitter and then it CTDs. It’s every single time and I never had this problem before the new update.
I’ve tried the usual tricks - cleared the community folder, updated the graphics driver etc but it’s completely unplayable.
Btw - I have the Steam version.

3 Likes

I have the ms store version but also with the sounds jitter indeed. Same problem!

Never ever had a problem with msfs2020 before. No CTD’s until now.

System 10900k
Asus z490 Hero motherboard
Samsung 970 m2 1tb
Samsung 970 m2 2tb
64mb ram hyperx
Asus 3090 strix oc
Asus water cooling 360

Windows and gforce drivers up to date

I am so glad to hear others are having the same problem. FYI, my specs, Ryzen 1800x Asus crosshair 6 mb. 48gb ram over 4 slots (2x8 and 2x16), gtx1080 Asus. Samsung nvme 1tb SSD. Win 10. All drivers and updates are done. Rock stable system, use it for work, and development. Not over locked. Water cooled, more than ample power supply. Corsair mouse and keyboard. Thrust master 16000m fcs controls. Nothing unusual.

Steam version.

2 Likes

pc’s are no longer compatible.
the many ctd;s people having is sad yes, i wonder why, i have only had 2 the whole year.

1 Like

Thanks for sharing, logging this issue with the team!

8 Likes

Hi, have you tried changing the “filters” settings to just use the IFR map? I think the main issue is the satellite data loading and unloading causing issues for the map.

1 Like

Hi @Jummivana, Thank you for your reply. If the team needs any further info, please ask. I have already saved the Event Logs for this issue, and they show the same fault offsets/exception codes. I am a fellow experienced developer (though not a windows application dev, mainly server side), so more than happy to try and provide further infomation that may help.

Regards

This happens to me also.

Has anyone tried if clearing the rolling cache has any effect on this?
I have the same issue (CTD when in World Map and zooming/looking around) and was just thinking about trying this when I get home from work.

Yes no impact whatsoever. Even ran it in low graphics and online functionality off. Still have the issue.

1 Like

Thanks. So it has nothing to do with live traffic or any other live functionality either… :confused:

For me there was no impact not sure about others…