[BUG LOGGED] Settings do not stick since SU5

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No, I did the test without any addons. Adding them all back does not change a thing.

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
If I fire up MSFS, I check the menue and my settings are on “ultra”. However, starting a flight quickly shows that the settings are for sure NOT ultra. Switching to “medium”, clicking on “apply & save” and then back to “ultra” with “apply & save” restores “ultra” settings, but with the next start of MSFS, the same issue happens again. “Ultra” settings do simply not stick…

Provide Screenshot(s)/video(s) of the issue encountered:


This is how it looks like (EGNX) when starting MSFS with supposed to be “ultra” settings…


This is how MSFS looks like after going in the menue, switching to “medium” and clicking on “apply & save” and then back to “ultra” with “apply & save”. Note the difference on the buildings and the overall better image now…

Detail steps to reproduce the issue encountered:
None, it is always like this when firing up MSFS after SU5

PC specs for those who want to assist (if not entered in your profile)
i7-8700K, 2x16GB RAM, 1080Ti, Windows 10, MSFS installed on a dedicated 2TB SSD

Build Version # when you first started experiencing this issue:
1.18.14.0

Are you on the Steam or Microsoft Store version?
MS Store

Did you submit this to Zendesk? If so, what is your ticket #?
Not yet, I hope there is an easy fix (or workaround) for this.

Yep, not part of Avsim (where the experiment is being conducted) but I tried at EGNX - Buildings set to Ultra - had the low res buildings on the right.
Did what David asked; set to Med - applied, then back to Ultra - Applied, and hey presto - Proper Ultra buildings…

So indeed, settings appear NOT to be sticking between sim sessions.

I assume you use ultra preset?
Can you try and see what happens if you use custom settings, like everthing on ultra but water low or anything else that doesn’t affect buildings?

I do use custom preset, does not stck…

Ok, what happens if you make sure that everything you want is set to ultra in the UserOpt.cfg, save and close it and set it to write protect?

I do not know which numbers in the useropt.cfg correspond to ultra. Furthermore, the settings are on ultra, at least in the menue, they do not change there, it is just that the sim does not use ultra settings after restarting…

Buildings, texture etc is 3 = ultra.

1 Like

I will try and report back. Hopefully my sim does not crash the moment I set the config on read only…

Ok, also this is a clear negative, setting useropt.cfg does not prevent it

Well done for checking Ank,
Intersting stuff for sure.

Surprised that so little users seem to observe the same issue?

1 Like

Thats ineed strange. This could explain the many „graphics degradation“ rants. Im gonna test this now on my end.

1 Like

It would be great, if more users could confirm if this is a general issue.

1 Like

Can confirm!
Checked useropt.cfg, was on ULTRA, values “3” on everything and NOT write protected. Started sim, Menu shows ULTRA, switched to medium, apply. Switched to ULTRA, apply. Boom, finally the correct ULTRA settings! ■■■■, this is a biggie! And explains the ■■■■■■■■ going on about “degraded graphics”

After sim Start on “ULTRA”:

After switching back and forth:

8 Likes

Testing same procedure on Trees, Clouds, etc.

A little later . . .

Well, the Clouds are questionable. Had them set to Ultra anyway - went in to sim swapped them for Med - Apply, Ultra Apply and they look pretty much the same.

Ultra Clouds 1 - as they were anyway when sim started. . .

Ultra Clouds 2 - after the Medium- Apply, Ultra - Apply “Fix”.

An impartial member of the family said Clouds 2 had more detail but I’m doubtful. Although very close inspection does reveal there is more detail in the furthest away clouds near the horizon - particularly those to the right of the runway.

I also observed the buildings on the right - which were the original subject of the thread experiment have retained their Ultra setting from the previous sim session. I had not restarted Windows for the testing sessions - only the sim.

The only change I have made outside of settings in the sim is to the UserCfg.opt - eye adaption 0 - to get rid of that horrible over-exposed look.

1 Like

As some of us have found out in another forum, it seems that if you have your graphical settings on ULTRA you are actually not on ULTRA but on a lower quality setting. You can test this at EGNX runway 27. If your settings are really on ULTRA you would see windows and other details on the right-side white buildings. If you don’t see these details, you’re not on ULTRA, even when your GUI indicates you are.

There is a temporary workaround. Load a flight, click ESC and go to GENERAL OPTIONS → GRAPHICS. Now choose the Global Rendering LOW-END profile, click Apply. Then choose ULTRA again, click Apply, GOBACK and resume your flight. Now your visuals are indeed on ULTRA and you should see much more details.

Unfortunately, this workaround has to be applied every flight even if you didn’t leave the sim but only went back to WORLD MAP to choose another location/flight.

Please, if someone with better skills can reproduce it, and may also report to ZENDESK.

Cheers, Harry

4 Likes

Yup, it is the case for me. This may be the reason why some people are happy (using medium) and many are not (using ultimate). It’s hard to believe that this got out the door of Asobo. But, it’s good news in a way as the visuals may not have been downgraded as many first thought.

3 Likes

You clearly found a bug! For me the game is in such a bad state it´s barely playable, so I don´t. But ill see if I can replicate what you found/experience…

Exactly! One can hope, would at least solve one problem

Same here, already posted this in the bug section

1 Like