[BUG LOGGED] Settings do not stick since SU5

My workaround has worked. Delete your saved game profile in the MS/XBOX cloud, and remove World Update 3 (UK).

But surely thag would remove UK? And a core patch?

I feel its up to asobo to fix this as its beyond our allowed coding to fix the save files

This totally explains the pixelated “FSX clouds” and dull graphics after SU5.

I can’t reproduce this bug in any other airport at the moment. I’ve tried KSEA and KLAX…both seem fine. Is it perhaps only EGNX or just certain regions impacted by this bug?

I’ve only seen reports of it changing the buildings at EGNX. I don’t know why this is still offered as a solution for the downgraded visuals. It makes no difference.

It would be good to know for certain if EGNX is the only airport impacted ( I doubt it though, there must be others). Also is it only airports or is it also an issue in other locations like city buildings? Anyone have evidence of other area (not airports) impacted by this bug?

EGCC is another airport impacted (there are some screenshots earlier in this thread). Although in my experience this only affects the initial spawn. If I spawn in to an airport like EGNX and it shows the downgraded visuals, then fly away and back to the airport, the proper visuals will be loaded. So I don’t think it is an issue with the settings not being saved, since the sim knows to show the ultra visuals after flying back to the airport. It seems to be an issue with the incorrect quality being displayed when spawned.

This didn’t work for me. I flew out about 20 miles and returned but the Ultra details still not there. Even worse, I “restarted” the mission and the next time it loaded, there were no buildings at all. All 3 screenshots are on ultra. Looks like a messy bug.



I occasionally got the “no buildings” bug too. Kept flying and they came back in all their ultra glory (I think I flew to the first airport south of EGNX and then back. It wasn’t a long flight, maybe like 10nm each way.)

I wonder if this is related to the other bug where people are saying terminal buildings are missing, or only the roofs are showing, floating in the air with no walls.

Also have a look at the building on the west end of runway 27. It looks like the same type of autogen building to me, but it always seems to have the details, even when the building at the east end does not.

Definitely not working right, I just don’t think it is an issue with the settings not being “saved”…

The bug is in the “uk world addon” with SU5 if active some building in uk country will be displayed in low detail, if you delete the addon problem is fixed.

I can confirm the same issue. The fix is to set graphics present to ‘low’ and save. Then set to ‘high’ or ‘ultra’, save and return to flight. Problem with this solution is that if you use ‘custom’ graphics settings then I’m afraid you’re out of luck. You’ll need to set each individual setting again one by one. This is another truly appalling and inexusible bug resulting from SU5. Again… what were the SU5 beta testers actually engaged in doing ahead of public release?

2 Likes

I don’t understand.
If I click “Ultra”, the setting are there.
Are you saying that they are not set to what is displayed?

“Custom” is only displayed if you change any one or more settings.

Click “Ultra” and done.
Does this not work?

If you click ultra you’ll only get a lod of 2, you have to manually edit the cfg file to set it to a higher value, and then set the file to readonly so that the sim doesnt overwrite it.

Okay.
I am confused.
I don’t understand.

I have mine already set to Ultra and Obj and Terrain LODs = 9
and the UserCfg.opt file set to Read Only.

Hope others understand what you are saying.

**
Yes but to kill the bug, op was saying he has to switch from ultra to low and back to ultra. Even with the usercfg set to +R the game will still change the settings for that session. When you quit and start a new game, it will re-read your config and apply those settings. Now if you were to go back into the menus, the game will make the changes you make in there, for that load of the game until you quit and start again. Rinse and Repeat.

Understand? or are we both now confused LOL :stuck_out_tongue:

Nope, still am.

Right now:
I look at my General Settings: all Ultra

I look am at my UserCfg.opt file: OPT and Terrain = 9
UserCfg.opt is set to Read Only

And it is displaying some gorgeous graphics on my 4K display.

But you are saying it is not 4K Ultra?

You see how dense I am…

I just went to Start and clicked Restart.
When the PC came back, Ultra displays and UserCfg.opt has not changed.

My graphics look the same.

Meh, don’t blame the beta testers who test for free, blame Asobo’s QA, this is their job after all and that’s what they’re being paid for.

2 Likes

Here’s a useful test that others have used. Setup a flight from EGNX runway 27. When the flight loads (that’s if the sim doesn’t CTD after click ‘fly’ :wink:) then look at the building details on the right hand side of the runway. Also make a visual note of the runway centre line resolution. Then press ESC and select the graphics options. Although you might have them preset to ‘high’ or ‘ultra’ the sim is ignoring these settings and using something closer to ‘medium’. To fix choose a preset below ‘medium’, apply & save. Then select the preset you actually want, apply & save. Now resume the flight and look again at the building details on the right and of the runway centre line. They should now appear correct for the graphics setting you’ve chosen. You’ll need to do this every time you restart the app from cold.

It is not about all the settings, just some, especially the buildings. And they do not “switch” in the way you think, in the menue and in the useropt.cfg everything stays on “ultra”, but the visuals are clearly not (just check some screenshots above). It seems that it is somehow tied to WU3, as some have reported that the issue only comes into the sim when installing the WU3 package. Honestly, after some flying around the world, it seems to me that the issue is not very prominent, in most cases I can not see any difference when doing the switch. For EGNX however, it stays and no solution so far except switching presets.