[BUG LOGGED] Settings do not stick since SU5

Does your usercfg.opt say Custom or Ultra here?

{Graphics
Version 1.1.0
Preset Custom

Who are you asking?

I’ve looked a bit at what bytes get changed in memory and some bytes are only changed outside of the normal settings if preset settings are used. (Ultra, Low-end etc.)

Ultra for Buildings or Lod values for buildings are changing as they need to (3 for Ultra - 0 for low) But that never triggers the one setting that needs to change to see the last building lod/texture pop as shown in this picture:

It will only trigger with a Preset change of (Low-end to Ultra)

So the problem seems to be a hardcoded thing that can’t be changed by the usercfg.opt.

1 Like

@ frulx241

Thought I hit the reply but can’t see those icons anymore. I just checked the message itself and it shows a reply to. No idea why it doesn’t in the forum message itself…

Annoying bug this is. Or WU America has seriously been downgraded after SU5 but I’m switching from Low to Ultra and hardly any difference. For example, I’m flying from Spokane to Seattle and the scenery is just awful. Can’t remember the quality being this low in that area.

This is not tied to XBOX settings! I don’t have an XBOX and I still have this bug, just test this myself!

You don’t have to have an XBOX for MSFS to be saving your options to the cloud. Sadly there’s no way of deleting your cloud saved options/profile without access to an XBOX, as Microsoft haven’t provided any way to delete your cloud saved options/profile.

1 Like

This happens to me as well on Xbox Series X

Hmm - we don’t have any presets in VR, we can only change them individually - I wonder if this could explain some of the visual issues we have in VR now

Yes, it´s safe! It will create a new one once you start the sim again…

1 Like

I usually fly in VR. But replay recorded flights in 2d. My custom VR settings seem to stick, but in 2d/ultra I have the exact same problem.

It is not, if I delete the file useropt.cfg, the sim wants to download all full 100+ GB again…

You can test if the xbox pad on pc now vibrates by resetting the cloud saves. From the SU5 version that my pad no longer vibrates even when setting in the options.

It wont! you just need to browse and select your MSFS folder (where you installed the sim)
Do you have steam or store version?

Example: I have store version and installed it on a seperate drive (F:). But when optfile is deleted it wants to install 100+ again, but in the C: drive, so I have to press browse and choose my F: drive and MSFS folder. Then it will “install” but nothing is actually downloaded and sim will start

1 Like

With mine, do not have to change for future flights. Just future sign-ons.

I did some tests and even if i can’t delete the data from the cloud with windows 10 i bypassed creating a new account. The problem is not of the data but of the world update uk if you activate the problem it returns. Deleting the data you forgot to install the world update uk that’s why it seems to work. At the end of the it’s a world update uk bug with SU5.Sorry for my english i use a translator.

Ok, this worked, but had no effect on the phenomenon. Deleted useropt.cfg, started in the sim, ultra is set in my case as default, I did not change anything and went over to EGNX, bang, same effect. Again only switching preset to “low” and back to “ultra” made those buildings not look like on “low”. I am lost, obviously there is no workaround for me other than switching presets…

Ignored on Zendesk for over 2 weeks, graphics not sticking- you have to change your settings every flight loaded in from ultra ( which they are not in) to medium and back to ultra to save.

there are no workarounds at present, tried CFG files , all set to non read only, tried read only after saving but it wont save on the CFG file, it isnt writing.

Wont save Last airports - Complete messed up- you think your getting +20FPS, well thats because youre really set to medium settings but its showing ULTRA until you re save it…

POOR

1 Like

Do your little change as above and then without closing the game tab out find the file usercfg.opt, and set that to read only. The game will no longer be able to reset your config since the file is readonly.

File should be under appdefault/roaming/microsoftflightsimulator.

I think you did not understand the issue here: neither the useropt.cfg nor the settings in the game do actually change, it is simply that when you fire up your sim, you do not get “ultra” settings although both in the config and in the graphics menue “ultra” is selected. Making useropt.cfg read only does not help at all, at least not in my case…

1 Like