[BUG LOGGED] XBOX Series X: Thrustmaster T.Flight HOTAS One - button assignment works incorrectly

Mod Edit: For those who, like me, don’t speak English, this below is Thrustmaster’s answer to my question about the known problem:
Thank you for choosing our Thrustmaster porducts.

You would like to update the native mapping of our T.Flight Hotas One to the Xbox Series X|S version of Microsoft Flight Simulator.

Unfortunately, it’s not easy to do this at the moment when using the game’s mapping interface. The developer of the game is aware of this problem and is currently studying a solution.

At this time, we advise all our users of T.Flight Hotas One and T.Flight Full Kit X to stick to the native plug-and-play commands.

Below you will find mappings detailing the functions associated with each of our buttons:

Per quelli che, come me, non parlano inglese, questa di seguito è la risposta di Thrustmaster alla mia domanda circa il noto problema:
Grazie per aver scelto i nsotri pordotti Thrustmaster.

Vorresti aggiornare la mappatura nativa del nostro T.Flight Hotas One sulla versione Xbox Series X|S di Microsoft Flight Simulator.

Sfortunatamente, al momento non è facile farlo quando si utilizza l’interfaccia di mappatura del gioco. Lo sviluppatore del gioco è a conoscenza di questo problema e sta attualmente studiando una soluzione.

In questo momento, consigliamo a tutti i nostri utilizzatori di T.Flight Hotas One e T.Flight Full Kit X di attenersi ai comandi nativi plug-and-play.

Di seguito troverai le mappature che dettagliano le funzioni associate a ciascuno dei nostri pulsanti:

Hopefully more ppl like me register and vote :grinning: for this.
Just get my Hotas tomorow, but sounds anoying.
Maybe some of you could bring a lot of PC players to vote for this :slight_smile:

Any idea if this is even being worked on? Three weeks now???

I bought an Xbox Series X, HotasOne, and MSFS solely to play this. And it is unusable. Is it time to unload all of this and move on?

4 Likes

There seems to be some evidence that the right folks are aware of the issue and are working on a fix. I’ve been muddling through with the default settings. The only function I really wanted that wasn’t mapped to the HOTAS with the default setting was active pause, which I was able to map to the trigger, as I never used the default setting for that button anyway. Every other attempt I’ve made to remap ended badly.

3 Likes

do we have an eta on fix for hotas issues?

1 Like

I am very new to this forum, but as far I could read there is some kind of voting system giving priorities to forum reported bugs. (The voters are the readers here, even new ones like me).

And when I read the most recent developer update from August 19th

and also count the 67 votes given this topic, then this issue would need at least two hundred (200) votes more to even appear on that list.
Right after the (invetigated) desktop crashed PC users frequently experience.
And still far of from issues like Horizon lines visible through mountains (ignored).

Furthermore, the roadmap tells us that the next update SU6 will be mid September.
The conclusion is up to you.

I can live with the workarounds so far (but, as I said, I am new here, no real pilot, just manged failing to get a PPC B license in my youth :-I) and I am very happy with the almost realistic view down to my favorite area, the Fraenkische Schweiz near Forchheim (EDQE).

I am playing with Hotas and Keyboard, though, the Hotas alone is definetly insufficient and using the controller as an additional menu control tool is suboptimal.
The Logitech K400+ I use also sports a toucscreen mouse, ideal for the menues.

I’m also very concerned this is not even in the development bug fix priority looking at the last few dev updates.

This is far from an optimal situation. Between this and the CTD issues that keep happening for me my enjoyment has diminished. I’m playing other games for now this this is sorted.

I’m using HOTAS One + keyboard and mouse, I’m managing with the default mapping for now, it’s actually not too bad. I’d just prefer to set my own mapping. What really concerns me is the apparent issue of sensitivity settings not being saved… don’t know what the status is on that issue but last I checked, nothing.

This is really frustrating. Can’t be just 70 people that have and voted for this issue? Is it going to be weeks or months or ever that this gets fixed?

2 Likes

not played the game since I found this issue, until its fixed i cant play it - i tried manually adding in but no luck

I’m having the same problems. The mapping is all over the place. The camera controls absolutely don’t work on the HOTAS One. When I try to manipulate them with the game pad (or just look around the cockpit while in flight) it throws the plane into a dive (since the left gamepad stick also controls the elevators). It doesn’t seem worthwhile to try screwing with anything on the HOTAS One until they hopefully come out with a corrective firmware update…

This has changed my life. Thank you.
Will probably change the camera settings, but a relief the buttons do what they’re supposed to, notwithstanding they still come up as incorrect when searching by input in the controls options.
But now, at least i feel a bit saner - but still - ‘they’ should fix the remaining probs.
Should be able to plug into the front usb port and expect it to work.

Not so fast.
My next flight, the ol’ rudder problem reemerged - and the A & B buttons were back to not doing their job. :man_shrugging:

Thrustmaster has confirmed that this is entirely a MSFS/Xbox issue, a fix is being g worked on but no time line has been estimated. It has been present since the July 27 launch. Completely unacceptable and a waste of so many peoples time who have wasted many hours trying to map. But what else have we come to expect from Microsoft, the company that’s too big to care

2 Likes

The default HOTAS assignments do let you fly the plane ok. It’s just trying to change any bindings or assign some new ones that is the issue (I can live with this bit not working for now), coupled with the lack of retaining sensitivity settings which from my POV is way more problematic as having to redo them every time I relaunch FS2020 is a real pain & this should really have been hotfixed by now for a ‘supported’ product.

Asobo is well aware of this problem, even without Zendesk tickets! Why? Because TM advised them all about the problems before the launch of MSFS and TM still don’t know when there will be a solution from MS/Asobo!

it would be nice to hear that they are aware and a fix is coming, but i have not heard anything from Asobo regards this issue?

1 Like

Since they have never worked on such bugs and glitches, how come Microsoft is advertising for the thrustmaster hotas one as one 3 controllers they suggest for buyers, this is a pure scam. We need the fix ASAP

I have also sent a Twitter private message,so trust me, they are aware of it and have been for a very long time!

The other biggest fear is that the additional flight controllers that are soon being released if they will have the same issues and frustrations around the mapping. And some of those are looking pretty expensive for most getting started.