Buildings not loading, blurry 2d ground

Hello,

so main details

Running FS2020 with the latest update, all world updates have been updated.
I have removed all addons from my community folder
My internet connection is running smoothly, it’s 516Mbit connection
I’ve uninstalled / reinstalled world updates.
I’ve tried using a VPN.
I’ve tried turning on/off online - bing maps / photo geometry.
Tried emptying the roaming cache.

My laptop is:

i7 9750H
16GB 2400Mhz ram
2070 Max Q

It was running fine before I’m not sure what’s changed, I am running Windows 11 however FS2020 was also running fine prior to this issue whilst I was still using Windows 11.

It appears that buildings are not been loaded, sometimes if I stop, the buildings might eventually load but it can take ages, like 5mins, sometimes they never load, I’m unsure why it’s doing this, but the ground is just a 2d blurry image.

Any idea why this is happening?

Same for me on xbox, out of nowhere and for over a week now.

Tried everything, searched for any dev-response or solution everywhere… nothing!

Edit: many community gameplay videos on xbox show exactly the same error… and not a single word from devs till now. I really don’t get it.

I’ve not tried to see if its present on my Series X, If it’s server side error I guess that would be reassuring as I’m worrying it’s something on my side. But either way would love to have it fixed it really destroys the immersion :frowning: