C-172 G1000 turning off mid-flight

I can’t tell if this happened before today’s SU9 because I didn’t try using the glass-cockpit version of the Cessna 172 until after the upgrade.
I set up the G1000 PFD as a popout panel to work within Air Manager. I’m a rank beginner working with the G1000, but I think it works normally through Air Manager until a few minutes after takeoff. After engaging AP and entering the desired altitude and the method of changing altitude, the displays suddenly simply go black, both the PFD and the MFD in the sim’s cockpit view in the main FS window and the popout panel in Air Manager on a separate monitor. I can discover no way to get the displays to turn on again. The plane continues to fly under control but without instruments other than the three analog ones

Air Mgr and its plugin are up to date

Is a bug caused by the sim running out of memory. If you save your flight then restart and load the flight the displays will be back

Please use the Community Support category for questions instead of General Discussion. Your thread has been moved there.

I found it to be true that a restart would bring back the G1000 displays, but I never knew it was a known bug.
What memory was proving insufficient in prior reports, system RAM or video RAM? (I have 64GB and 10GB respectively.)
Do you know if the bug is still common with the current state of MFS? Are there any known remedies?

I have exact same issue! Does anyone have more information for a fix? Has someone done a bug report for a fix? This is no small issue.

I posted the original question on this problem, and for me it was self-limited. I never did a thing to correct it. I haven’t seen a recurrence of it in several months.

I hope this is so. I saw one reply that referred to battery and master switch issues. Since I also appear to have some ATF Switch Panel vs Sim panel switch discrepancies on start I thojght perhaps this may be related. I will flrge on hoping it was a “burp.”

I have the same problem and I do not have air mgr, all the planes with the g 1000 do the same thing, I reinstalled msfs 2020 4 times and the same thing happans.

I’ve been having the same G1000 issue where in mid flight it just powers off. I’ve tried removing the community folder, checked for conflicts between my bravo controls. Very frustrating. Even totally uninstalled and reinstalled. Same issue. Sometimes 10 minutes in flight, othertimes as long as an hour. Even without touching any controls in AP, it just blinks off.

1 Like

If you are using the Thrustmaster quadrant then set the "Engine Norm Mode " as shown in the pic.

1 Like

same thing happened. never got around to see a solution yet.

Try my defect report. This could be you.

1 Like

Did you all ever find a fix to this. My g1000 still seams to be turning off during midflight

You don’t say what you’ve tried. Is it happening only at dusk or night?

Hi there! I just restarted flying the C172 and my G1000 screens are doing the same thing after a few minutes into flight and also on ground. Already tried switching the ground traffic etc. to 0 and it unfortunately didn’t help… Hoping for some updates if there are any fixes around the bug by now?
Thank you very much in advance !

I just had the same problem flying C172 Glass Cockpit from KFLO to KCAE. I have not experienced any CTDs or other issues over the last two years. I have not added anything to my community folder and my FPS is constant at 66-75.

Now while using the Garmin 1000 NXI it has gone black and shut down in flight a number of times.

MY FIX that worked: uninstalled Garmin 1000 NXI update from marketplace and the Problem is FIXED. Seems like there is a bug with WT NXI update and now with SU 13 update I had a problem.

The G1000 that you uninstalled is for third party planes to reference the Working Title G1000 NXi.

The core Working Title G1000 is still installed on your sim.

Check Content Manager and type G1000 in it. You will find a gray background WT G1000 that you cannot uninstall. The error appears to be that you had the Bridge Version installed when you likely did not need it.

Thanks CasualClick. I just checked and was not aware of this. And I had the Bridge Version installed since day one. To show my ignorance I was not aware that it was a bridge for third party planes.

Thanks so much for the info and help.