Can someone explain why I lost rights to 70% of addons - Premium and Premium Deluxe

I really try to be civil. But XBox already has a lot of broken addons due to XBox OS issues that make out addons not functional.

But now I go into the store, and I see products that I have already purchased, that now I don’t have the rights to anymore. I have gone into Comtnent Manager and confirmed they have been removed from me.

All told, I have lost rights to about 70% of my addons. I have $3000 invested in addons. If you are planning on me just taking this lightly, and repurchasing over $2000 worth of addons, I can assure you, that is not going to happen.

9 Likes

Same here. Premium and Deluxe packages say installed, but all missing. Planes, Airports, all gone

Same here, everything I’ve purchased, gone

try relaxing, it’s obviously a temp glitch and not worth frothing at the mouth about…

3 Likes

me as well.

they are trying to sell me 3 of my planes and the RENO pack again

Yep same issue here

Same, just lost a bunch of marketplace content. 787 and virtualcol e170/175 disappeared from content manager. Im sure more but have not noticed others yet.

Also not sure if its related but when I start the sim, an update briefly pops up and disappears. too quick to notice what is trying to update.

1 Like

If I lost everything, I would assume it’s a glitch. I’ve lost 70% of my products. So it’s not like the database is down or something. It is a selective 2 out of every 3 of my purchases gone.

I am experiencing the same issue - namely, I lost the Embraer E110 Bandierante, but most of my other purchases still show up.

I had play with premium deluxe package for more than one year, but suddenly loss my data when start the game today, I start the Microsoft store and found ask me to pay for the package.

2 Likes

Same here. What’s going on??

1 Like

I’m missing purchases from the store as well. Products were updated but they show as not purchased

1 Like

ditto, most my marketplace content is missing (not all) I’ve tried signing out/back into MS Store , XBOX and no joy. Can’t log in via the sim – it says my status is off line and its greyed out but I’ve got a Sign Out button (implying I’m signed in). When I sign out and try to sign in I get a CTD.

I’m guessing it’s a server issue. BTW I’m in the midwest US.

1 Like

@dccp38 same… The greyed out status is because you don’t have multiplayer on. Once you turn that on it wont be greyed out anymore. However, I get the same CTD when trying to sign out in the sim. Also, my content manager is showing an update available for premium and deluxe packages, but wont give me the option to download them. Been waiting a week for free time to fly tonight, and I get this.

same here … lost more of 50% of all

2 Likes

Lost my Junkers and my Optica planes, maby even more dlc
WTH happpend!!
All bought from the Marketplace with credits.
And Steam does not trell wich dlc i bought, onl;y the amount and in game purchase, but not exactly wich dlc!

This needs to be fixed ASAP!

2 Likes

Queue up the Benny Hill music.

8 Likes

Deleted and tried to reinstall premium and deluxe packages and they just show “Error:3” beside them and the download button is inop.

@JAWILSON83 thanks, didn’t know that. (I’m not sure I’ve ever turned multiplayer on) I guess I’m just glad it’s not just me affected as it probably means some sort of server issue and may resolve itself. I was searching through past topics on missing content and read that some have had to reinstall, I’m sure we all want to avoid that.

I lost my Embraer Bandeirante as well as all my Premium Deluxe content, anyone have an idea what’s happening?