Can someone please explain what I am doing wrong? Trying to control planes altitude via autopilot G1000

Youtube vid here: https://www.youtube.com/watch?v=sK5mWybMiaQ

I would really appreciate any guidance on what i am doing wrong any why FLC and VS mode seem to be inoperable.

I have no trouble using NAV, HDG and general AP mode to control the pitch/roll of the plane, i just can’t get it to change altitude.

1 Like

When you use ALT in the G1000 system you have to choose 1 of 2 modes to use alongside with it.

  1. FLC (Flight Level Change) - Then use the Nose Up or Nose Down buttons to change at what speed you want to reach the altitude you dialed in with the ALT knob.
  2. VS (Vertical Speed) - Choose how fast you want to drop (in FPM (feet per minute)) with the Nose Up or Nose Down buttons to reach the altitude you dialed in with the ALT knob.

Here’s a REALLY good video covering every basic function of the G1000 in MSFS (including landing)!

10 Likes

This is what I believe I am doing.
Hello,

Thank you for posting and trying to help me.

Viewing this video is what led me to create this post in the first place and my subsequent video. My aircraft is not behaving like the aircraft in his video.

When I hit FLC and nose up/nose down buttons, there is no change in the aircraft. When I hit VS and nose up/nose down, the aircraft does not respond to the FPM I set.

Please check the youtube link I posted, you can see what modes I have the aircraft in.

Thank you!

You also need to add power to climb and decrease to descend.

Hm, just watched the video a couple of times and that seems to be bugged.

Assuming @boddie007’s suggestion doesn’t work, you may want to file a bug report if you can consistently reproduce that.

Hi boddie,

this doesnt match with how I understand FLC to work. If you set FLC mode to a certain speed, shouldn’t the AP lift or drop the nose in order to gain/lose speed? If you watch the video, FLC mode has almost no effect on the aircrafts function.

What speed should i change the plane to, in order to climb?

Please, if you haven’t, check out the youtube link I posted.

FLC tries to maintain speed while climbing to the set altitude. If the AP raises the nose to climb, the plane will slow down. You need to add power to compensate. The 172 does not have auto throttle so you have to do it yourself. The amount of power will control the rate of climb but the air speed will be constant.

If you check the video you will see that I set the altitude 4k higher, turned on FLC at a speed of 105 knots and set the climb speed to 95 knots. The plane did not attempt to climb or do anything. I am trying to understand if I am pressing the buttons wrong or missing a step. I understand the theory of how it works.

One word of caution with the G1000 atm. If you have set AP on , Set an Alt and Set a Vertical Speed and then you happen to stall just a little in your climb. ( Say you set your VS to high ) The plane/GPS can bug and set your elevators to max trim.
So even if you dis-engage the AP the trim will still be set at MAX
This is a bug I have seen a few times. I will report this tomorrow , late atm

edit: Hold right Alt and click to get any of the G1000 windows to pop-out.

2 Likes

Thanks SirDanFlyBoy, i’ll do another takeoff and see if I think this could be effecting things.

So far, I don’t think I’ve ever managed to get the plane to actually response to a vertical speed command :confused:

Faster it’s late for me but if you want I could stream how to set it really quick in discord , if you want.

SirDanFlyBoy, that wont be necessary. I have seen videos of it and I feel 99% confident that I am already doing it correctly, I was hoping someone could look at the video and see the settings I have the plane in and point out what I am doing wrong.

I don’t want to say “its a problem with the game, NOT ME” so i am trying to do everything i can to learn the process. A youtube demonstration has already been posted in this thread showing how to set FLC or VS modes.

You’re not doing anything wrong. The AP is seemingly not responding to your inputs.

I would make sure none of your controllers are somehow overriding elevator input by the AP. Restart the sim without the yoke / joystick and check if the AP is still not working. If the AP is working then it could either be a funky controller binding or a defective controller. If the AP still doesn’t work properly then I would reinstall.

1 Like

Machete3181, THANK YOU!! I really appreciate your feedback and suggestion, I will go and check for elevator inputs on my yoke now. I use the honeycomb alpha.

Much appreciated.

1 Like

The AP can seem really hit and miss when it comes to vertical movement. I find turning AP on, setting my desired ALT, then adjusting the VS works. I picked up a nasty habit of toggling the FD from an old bugged module I used to fly back in the FSX days and do this all the time with my AP.

I’d be very surprised to see this issue come back after all these years, but try toggling the FD on and off? Hey at this point I’m willing to say “Press everything” XD

Thanks for your suggestions LP. I have tried toggling the FD on and off many times. No matter what, the AP only seems to follow commands relating to pitch and roll, altitude commands are ignored. :frowning:

Disconnecting the yoke didn’t do anything. Only other elevator input was keyboard. Attempted flight with yoke disconnect and keyboard only and vice versa and no bueno.

Attempting reinstall of FS2020.

FasterRanger533

You only have to push 2 buttons…
First you push VS, and then hit the button + or - to change the speed of descent or climbing.
How could it be more easy?

And of course you have turned that little knob to change what altitude you want to go…

Reinstalling doesn’t help you. It usually doesn’t work for anything.

I don’t think this is required? Seems like a massive overkill solution :slight_smile:

2 Likes

Don’t reinstall the game if its working on different airplanes , just delete the airplane from the hangar , exit the game, the installer will download again the airplane.