Can‘t change time / weather on Xbox series X

When trying to change time and weather in the game on Xbox series X (manually or live weather) it always switches back to 07/27/2021, 09:21PM (perhaps the time I started MSFS on Xbox for the first time) after a few seconds.
Even changing the settings (live, manual, multiplayer, solo etc.) doesn‘t solve the problem. The only thing that helps is turning off the online functionality in the settings.
Internet connection is working (e.g. addons can be downloaded without any problem).
Anyone with the same problems? Any solutions?
Thanks…

8 Likes

same here its getting really annoying

1 Like

Thanks for your replay. At least I‘m not alone with this problem…

1 Like

Not on Xbox but I know on PC if your data settings are set to live and you enable live multiplayer then the time and weather is stuck to live in-game. If you drop down multiplayer to all players the settings should be able to be adjusted in-game.

I think there was a fix for this problem. But now only live time is possible. Even when turning off multiplayer (switch to „all players“) options and switch the other options to „adjust“ („angepasst“ in german) it switches automatically to live time.
So when online functions are turnend on I can only fly in real time (not just on 07/21/2021).
Better than before, but not perfect.

I had the same problem. I went into network settings on my console (not the game settings) and then went offline. Gave it a few seconds and then went back online. Since then I’ve had no problems with it.

I’ve read that due to the massive draw of data by the game, it can cause these settings to bug out. By resetting the internet on the console it seems to reset the game settings.

I hope this works

1 Like

Thanks, this kind of helped me. I can play “offline” and change the weather and time. But when I turn the services back on my time gets stuck on 11:20am UTC and weather gets stuck on clear skies

Yep same here. Maddening. What I can say is that it works fine for other users on the same xbox, but my account fails.

same here hopefully there’s a fix soon they didn’t even mention this bug in the latest patch notes

This helped me the way that I now have the „real“ live time (no longer the 27/07/21).
But changing time with online functions turned on still doesn‘t work.

I am having the same issue. Yesterday it was fine, today it doesn’t work. It is very annoying knowing this feature doesn’t work!

Is there a link, where bugs may be reported to MS?
Because I never read about this bug on other official and inofficial websites.

https://flightsimulator.zendesk.com/hc/en-us
This is the link for bug reporting/ contacting support. I have the same real time/weather reset issue. About to report the bug now. Been trying to find info on this since launch. Thought I was just missing some procedure or setting.

Having the same problem on Xbox Series X since yesterday. Time in Sim keeps resetting back to 9:05 UTC. Multiplayer keeps resetting to “All” and AI to “Live”. If I change the time or any of the previous settings they just reset again after a few seconds.

I haven’t tried to duplicated this on PC yet. I am going to fire it up and try that this afternoon.

Edit: Just tried the PC version. Getting the same problem. So it’s not specific to my device. It’s server side - or something in my synced save data.

FWIW, I logged a ticket with Zendesk for this issue and received an email a couple days later saying they logged a bug… but then saw that my ticket was marked resolved without any additional info.

1 Like

Think I might have fixed it. At least on PC.

In the PC version I switched off all the online functionality. The weather, AI, multiplayer etc. in the main menu - not the world map. I gave it a few moments to save. Then quite the sim.

When I loaded it up again I enabled these features in the main menu. And the sim was no longer locked to a particular time and I could fly live, have live multiplayer etc.

I don’t know if this has fixed the Xbox version for me when the save game syncs. Or whether I could try the same fix in the console itself. Am going to try in a little while.

1 Like

Perhaps the group play really is part of the problem. On release day I started playing in a group with two friends. I didn‘t quit the group actively when quitting the game. Next start it seemed I was not grouped anymore (friends were offline, no group was shown, the „2 player“ symbol was grey) but I had the problem changing time and weather.
After reading that the group may be the problem, we build a group again yesterday and then I quit by clicking „leave group“.
After that I could change time, weather etc. without any problem for this evening.
I‘ll have a look if it still works later.

5 Likes

This was my theory too, but I haven’t been able to test it yet. I was all good in a group with my bro. Everything working great, but then I didn’t actively quit. Next startup and every time since then it hasn’t worked. Driving me nuts. I’m gonna reform a group and then quit to test. Will advise if this resolves it.

Here is the fix. The issue is with forming groups, and you never leave the group when you all are done playing. What you need to do is invite anyone to a group on your friends list through the game menu and leave that group. It fixed the issue for me. The person does not need to join the group, just invite and leave the group.

7 Likes

indeed, this fixed the issue for my son. Thanks all! it was driving him nuts.

1 Like