Can’t install Flight Simulator 2020 Anymore

Hello! Hope somebody can help me to reinstall Flight Simulator 2020 since it seems impossible.
I recently bought a new SSD drive because the huge and continuous mandatory updates made my C disk full. I tried to move the game from C to H with the Microsoft Tool but the game stopped working. I tried then to uninstall the game and make a full clean reinstall but neither Ms Store nor XBox are able to reinstall it. The download doesn’t even start and an error comes out. Tried updating Windows, used the powershell, uninstalled Microsoft Store and XBox App, stopped the firewall and the antivirus, stopped them and restored, logged out and re-entered the app, there is no chance I can reinstall the game.
Any idea on how to do it before giving up? I start to believe I wasted more than 500 euros for a 16GB Videocard, the game and a new SSD.

At any time, did you install the Google map enhancement mod?
If so delete this file “C:\Windows\System32\drivers\etc\hosts”.

If that isn’t the cause, unplug any controllers except for mouse and keyboard and try again.

Also, disable any overclocks that may be on your PC.

One other thing is to ensure the date and time are correct in your PC settings.

Good luck, let us know how you make out.

Done it, nothing works.
Keep giving 0x803fb107 error and game is impossible to install.
Tried everything, wsreset, powershell, windows update, synchronizing time and weather, updating directx…simply I cannot install a game I paid to play.

If you haven’t seen this here is a link that may be some help:

Let us know !

Sorry, solution doesn’t work. Error keeps appearing and game is impossible to install.
I tried everything, seems I can’t play a regularly paid and licensed game.

I don’t use the Google Enhancer Mod. I just used Saitek Peripherals and No Mod. Did all of this, Xbox installer doesn’t work and keeps giving me the error.

Error given by Microsoft Store. Really Annoying

Have you tried with all the controllers unplugged, except the mouse and keyboard?

Yes. Done it.
I think the problem has something to do with the Digital Ownership.
I bought the Premium Deluxe Version of Flight Simulator. When I try to install the Digital Ownership, Msstore tries to install the base version of the game. It gives the 0x800FFFF error
If I stop the installation then and in Xbox ask to install the Premium Deluxe Version I own (the base costs 69 euros), there is no download and the other error pops up.
I am definitely going crazy

1 Like

According to MS, the error code is a Windows Update error.
MSFS needs Windows to be updated to work properly.
The error code 0x8000ffff means your Windows 10 is having update issues . This error usually appears after Windows updates and locks the Windows Store. Besides, it can crop up after your performing the system restore or when you try to install a newly downloaded app.


Thanks for your time. I followed your fix and now the error changed from 0x803fb107 to 0x00000001. A first step seems done but the game still doesn’t install.

Hello @Sydbarrett81 ,

in that case try to check for updates and restart your pc. If that does not help, maybe look at this?
How To FIX XBOX App Error Code 0x00000001 In Windows 10 | Can't Download or Install Xbox App Games - YouTube .

1 Like

Just tried, download doesn’t starts and the error 0x0000001 pops out.
Anyway I noticed something strange this evening. Xbox App said the Microsoft Store account was different from the one used in Xbox.
Logged in with same account in both apps but no download and error 0x0000001 is still there.
I think I have to give up

Sorry to hear.
Unfortunately I don’t have any ideas what to try next, maybe someone else does.
Last thing I would suggest is opening a ticket with Zendesk.
The MSFS support team may be able to troubleshoot further.

Had a chat some days ago with Microsoft Support. They had problems too in installing Flight Simulator 2020 on my computer. They even tried in remote but with no luck.
However, for those interested with this issue, please notice that changing the unit where the game was once installed can cause a corruption in the installation manager.
The only way to solve is formatting the computer and do a clean installation of Windows, choose the unit where Windows is installed and voila, the game is installed!
Thanks for the replies! Happy flying


Same here, 2 days trying to re-install with the same error.

Other windows store apps installed without any problem, just msfs 2020.

Exactly same issued, tried everything.

The only way to make it work again is to perform a full clean installation of Windows and install the game in the same unit of the OS.
After installing windows, open Msstore and do the updates, install Xbox App and voilà, Msfs starts to download

That seems to be a common solution, a lot of users have to do this.
I have noticed that unless the window’s reset is done, just reinstalling the sim won’t help.

I had the same issue – and this is how I solved it. It is an extremely radical approach but after spending a lot of money on a new high-end gaming rig prior to the release of MSFS only to find that it does not work was, to put it succinctly, very disappointing.

I followed a lot of “tips and tricks” to get MSFS working again, but everything failed. I mean, EVERYTHING! Then I wrote to the MSFS support team. Turns out they were probably responding using a “CSR Script” that they were instructed to use; a progressive response for each response that you give them. Which, obviously, was useless.

My OS is Win11.

  • First, I took a backup of everything important: my files, account IDs, product/activation keys for all the major softwares that I own, a few application settings pages (screenshots) that I thought I might never remember to recreate – you get the gist. A lot of that stuff had to be moved to the cloud – about 500G worth. (I have an O365 subscription, which helps!!!)
  • The radical step I was referring to is this – I reset my PC using the “delete everything” option – the other option allows you to keep your files. I tried retaining my files and resetting my PC, but that failed also.
  • Went through the start-up process.
  • Do not install ANYTHING other than MSFS. Your PC should be as clean as possible when the install of MSFS starts.
  • Installed XBOX and then installed MSFS – this install of MSFS failed (error code 0x803fb107). You can’t imagine how mad that made me. Anyway, an important note about the installation drive. From my numerous attempts I am convinced that it has to be C: otherwise it seems to fail.

Then, I found a powershell script to be executed in Admin mode. (Last attempt at salvaging MSFS before ditching it!)

  • Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

  • Go back and installed MSFS in XBOX. It worked. The important thing is once the install starts, leave the PC alone – do absolutely nothing on it. Either you will see the progress starting or the install erroring out. That should do it; a lifetime later (uh… 45mins) you will see that it has installed. Wait for all of it to install – digital, MSFS, MSFS Premium, et. al.

  • IF it errors out now, I am out of my depths here and I can only assume that there are additional issues with your PC.