Cannot refuel during bush trips

I’m doing a realism bush trip flight and have done a few successful legs already. When I saw that I was running low on fuel I landed on a larger airfield along the way and pulled up to the pumps. There is no option visible to refuel. I can’t even ask ATC for refueling as it’s disabled in the menus.
How am I supposed to refuel during the VFR bush trip?

1 Like

Simply pull down the fuel menu and ‘add’ fuel, as if you were at a gas pump.

Well that’s not fun. Jokes aside it would add to realism on the ‘most real’ setting if you couldn’t just menu fill up and need to find an airport with service or a pump.

There is no Fuel menu for me while doing the Bush trips. It is also disabled in the “custom” menu. How do I add fuel? I managed to call the truck with Shift+F, but no fuel window pops up. I’m stuck in the balkans.

3 Likes

I think in fsx you had to put on your parking brake to refuel.

You need to manage your fuel. Not every airfield has been set to provide fuel. Check each one.

I’"m in Tirana, in a rather okayish airfield, literally next to a fuel station. The truck even comes up when I press shift+f, but there is no popup. I tried to park next to the pump and into a proper spot, but nothing.

3 Likes

I landed at KBIH to refuel. They definitely have fuel. I still have 30% left so I can fly a bit more, but the next few airports are abandoned dirt airfields.

Ignore my previous comment, I thought you managed to reful. I’m at a rather large airport, but I’m still unable to refuel.

2 Likes

Yep, having this same problem. I landed at an airport which as fuel trucks, I requested one with shift+F, the truck comes close (not very close, it stays behind) and nothing else happens. No menu shows up, nothing… I have two legs to finish but just 25% of fuel left. It will not make it…

1 Like

did you put on your parking brake?

Is there a way to save where you leave off on these little hops? I tried to save a flight but it save the flightplan that I just flew and not the location/status of where I currently am.

Any advice?

Just started my first bush flight adventure, chose the Savage Cub in CA/NV.

After a few legs, I am down to 14pct fuel, and am now on a municipal airport. Before taking off, I taxied to a parking spot, shut down, park brake on and called for a fuel truck.

It pulls up, but then just sits there and nothing happens! I am not even halfway I think and am basically out of fuel, how do I refuel during bush flight missions?

4 Likes

I have found a not so nice workaround until this is fixed. Turn on Developer mode, go into the aircraft selector menu, load in any other aircraft, now load back the C172 G1000, and you’ll have a “new” aircraft with 50% fuel.

Guys, I found it!!
There’s a key bind in the controls called Repair and Refuel. It’s unbinded.
Bind it to whatever you like, keyboard or joystick. Boom! instant refuel!
No need to be at a terminal with fuel trucks.
Also, while flying I had a fuel failure (left tank got faulty). This also repaired it.

31 Likes

Thanks!!! That worked for me. I’d totally be into the realism aspect of getting fuel at the right spots but nothing has worked for me (top menu, shift-f, park near fuel station, etc.) so I’d rather at least be able to continue. Frustrating because that stuff works in free flight.

1 Like

Thanks a million!

Binding the “Repair and refuel” works for me too!
Fore those looking for it.

  • Go from main menu to options > controls
  • Default filter is on “Assigned”, so change to “All”
  • Search for “Repair”

Just bind it (I used “” as that was not in use), load into the bush trip leg and hit the assigned button/key.

9 Likes

Just to be clear for those that don’t know, there are actual fuel pumps that you pull up to and a menu should automatically pop up to refuel, not at every airfield but at many, so keep your eyes peeled.

1 Like

I am halfway through the nevada bush pilot adventure and need to refuel. There is no option to refuel or contact ground for service. Anybody know how to refuel?

2 Likes

You can bind the repair and refuel to a keybinding and that has worked for me.

6 Likes