Cannot start flights after graphics card upgrade

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No developer mode

Brief description of the issue:

After upgrading the graphics card from a 1080Ti to a 2080Ti, the game is no longer able to start flights.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

  • start the game
  • go to world map
  • select an airport and a parking spot
  • use any aircraft. Doesn’t matter which
  • press the yellow fly button
  • wait.
  • wait
  • wait
    The progress bar gets stuck forever (as in you can wait an hour, it doesn’t matter). One CPU core is permanently maxed out. Annoying “music” continues. No response to keyboard or mouse (that’s normal while loading).

The flight never loads.

The only way out is to kill the process externally.

This is 100% reproducible. In normal mode or safe mode. With stuff in the community folder or without.

PC specs and/or peripheral set up if relevant:

Works with the old 1080Ti. Freezes at flight loading with the 3080Ti. NVidia game ready driver 5165.40 (latest versions as of this writing)

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Just a thought, but did you clear graphics shaders in windows before starting MSFS?

Did you reinstall drivers for the new card or are you just using the drivers for your 1080ti. If so reinstall drivers. You can also get a copy of DDU and uninstall your video drivers and start fresh.

Thanks. Never knew about that. Will try it (although this is before it tries to actually render anything - but worth trying regardless)

The 3080 and the 1080 use the same driver. And I installed the latest driver before upgrading, but I’ll try this suggestion as well just to be sure.

Tried both suggestions (from @TingedTundra94 and @BubbaBlitz7348 ) - unfortunately I have the same result. Game stuck. Not usable.

Next step would be send me your new card, and let me try it out here HA! Okay really second step is to take the card out, and then put it back in, to make sure it seated well. Also and this has happened here make sure all the power connectors on the top on the card are plugged in. And if you can plug each plug into a different lead from the power supply…

Yea. That’s the first thing I did @BubbaBlitz7348
It’s only MSFS that’s having problems. Other games run just fine (Cliffs of Dover, X-Plane, etc.). As usual, it’s the super-0buggy Asobo code that’s broken

rename your usercfg.opt file and then restart the sim and try it at those settings and see what happens?


Where is that file?

the folder is in appdata/roaming/microsoft flight simulator. Rename the file dont delete it just incase the sim doesnt want to rewrite the file for you.

You could also go into settings, and just turn everything down to low, and see what affect that has as well.

If you have any addons? move them out of community folder as well.

Use DDU to completely clean out your old drivers and start fresh with new. You will start your computer in Safe Mode to run DDU but it does the job good when installing new drivers or a new video card.

1 Like

Also after deleting your user.cfg delete the content xml file and SceneryIndexs folder. The sim will make new ones. This will usually fix your issue. Also re install video driver. Reboot.

Wow. Now I get a 98GB download. I guess I’ll have to wait for late at night before i can do the next experiment. It just boggles the mind how buggy this game is. They just don’t care. I do more debugging then playing with this thing.

You dont need to download the whole thing, when you deleted usercfg.opt, the launcher no longer knows were the sim is installed. Relaunch the sim, and when the popup to reinstall comes up, click on the field and a dialog box will popup, find where the sim is installed Microsoftflightsim*.exe and point it there, the press continue, then press continue again and the sim will then just install the the missing usercfg file. Sorry, I forgot that it does this. You wont have to download everything again.

Just very quickly glanced at this thread so apologies if i’ve missed anything obvious.

Just a thought though. Is MSFS2020 possibly defaulting to an integrated GPU rather than your new 2080ti GPU?

I think the issue that causes the re-download is with clearing the content.xml and SceneryIndexes.
Mind you, I don’t see why any of this should matter. I would expect all these things to cause problems with rendering. At the stage that the game is stuck it doesn’t render anything besides the progress bar. Usually what it does there is compile the aircraft stuff, not doing anything with sceneries or anything related to rendering. Although the ■■■■ thing is so opaque and lacks any user accessible monitoring or logging that you’re always in the dark trying to figure out the way out of their infinite number of infuriating bugs. I haven’t seen a game so buggy in decades. FSX was more stable. Heck - Windows95 was more stable. Even Windows 3.1 was more stable.

@BubbaBlitz7348 thanks for the tip. That really helps. At least I can skip an infinite download…

@Kayembee370 I am not sure what you mean. Where would I see evidence that’s it’s defaulting to something other than the GPU?

@Sonny3621 I can try your suggestion later. But again, I don’t think the driver has anything to do with it - as I stated, other games work with no problem so I think the driver is just fine. It’s something with MSFS itself. And it gives absolutely no indication of what’s going on.

Asobo: is there anyone from your company looking at the forums? How many times do we need to ask for a logging facility? It’s always guesswork to figure out what is going on when you hit one of your numerous bugs