Can't get Quest 2 to connect to MSFS

Hi Folks,

Having a problem getting my new Q2 to connect to the sim (I’m using airlink). It connects fine to DCS (albeit wtih some pretty horrible frame rates). I go into the VR tab in options but when I click on the “Go VR” (or whatever the exact text is) button, nothing happens. I’m connected via airlink to my desktop and can see the sim but no VR. Also tried the connecting in-game using ctrl-tab but still no luck.

In reading some of the pinned topics, I see reference to setting up OpenVR. I’m always hesitant about going in and editing my registry, I’ve got a brand new Alienware PC, is this step still necessary?

Any help is most appreciated.

Read through this forum:

AND insure your Oculus Diagnostic Tool is open in Admin mode, or you can use the Oculus Tray Tool (after market).

1 Like

Thank you, I’ll give it a read. Where would I find the Diagnostic Tool? In the PC app or while in VR?

You’ll have to search for it, it should be in your Oculus folder…. Sorry not at my computer right now…. I’ve read run the tool from that folder directly and not as a shortcut.

I have left the setting at defaul except:

FOV which is set to 0.8;0.7 (you’ll see when you open it)…. If no one reply’s to this, I’ll post pictures of my settings later…

1 Like

Thank you very much for the help. I went through the thread you linked and there is some good info. One thing I’m still not clear on, (since there was some contradictory advice) was the need to install Open XR. Is this mandatory for all Q2 users to get connected to MSFS? The last post in that thread was nearly a year ago and I just want to make sure nothing has changed since then with updated files in the Oculus App / firmware that’s loaded onto the device itself. If it matters, I am not going through Steam.

For the Q2 the oculus software is all you need.

Also if using windows 11 there the oculus software is not yet compatible. I reverted to windows 10 for now.

1 Like

Yes indeed, I get good results with Quest 2 without using the debug tool or OTT - I stopped using them after changing from CV1 to Quest 2 and haven’t found a need for either. I’ve used Sidequest to make alterations to the settings I want to and had no problems requiring anything else.

You can try using Virtual Desktop to fly FS as well, if you haven’t already. It is payware, but worth every penny. Use it to start up SteamVR, then run FS and when you switch to VR, it should come up in the Quest.

Many people slate SteamVR, but over the past year I have found it doesn’t affect my VR performance - rather the opposite as it has plenty of easily adjustable options that I can tweak ‘on the fly’. I also stopped using OpenVR (think it might be called something else now) many months ago. No need for it now.

edit: btw - I had no issues with the sim using Air Link.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.