Can't install FS 2020 anymore, Code 0x80070424

I hope somebody can halp me. I have tried so many things so far, but nothing has helped. I am very frustrated.
This update 5 has ruined everything for me. First it made an update of 40GB. Then something about 120GB or so. And after that the FS2020 was gone. Everything deleted, nothing left. All addons (even paid ones) are gone. And now I can’t even install the FS2020. In the MS Store I have this message:
An unexpected problem has occurred: Code 0x80070424
I don’t know what to do, everything I found on the internet doesn’t help.

my guess is you still have corrupted files not yet deleted … what installation did you install, was it Steam or Microsoft store ?

It sounds catastrophic and probably will need a complete install … unless you can roll back windows prier to sim update.

I install it from Microsoft store.

When i try to install it, there comes an error message from Digital Ownership

sorry I have Steam, completely different
you could try here . he fixed his problem

sorry I can not help you further, i’m sure someone else will jump in soon with a resolve, good luck.

Thanks! i hope so!

I’ve had this issue recently as well when the game was improperly moved from an SSD to my main games drive. Due to not all files having been moved, the game refused to start.
After a bunch of testing and trying out, going as far as to reinstall windows I concluded the only way to fix it is to format the drive you are trying to install the game to.
If you have it on C: you’ll then need to reinstall Windows ofc, if it’s on any other drive and stored within a “WindowsApps” folder, the drive needs to be formatted as you can’t delete that folder.

System settings > apps > gaming services > advanced options.


Scroll down and click 1 Terminate > 2 repair > 3 reset.

Restart PC.

System settings > update & security > windows update > check for updates and install updates if available.
// also check optional updates

After that > run microsoft store and update all apps.

additional info:

( Search results for '0x80070424' - Microsoft Flight Simulator Forums )

Thanks for your answers. It looks like I made it.
I made the following:

  1. System settings > apps > gaming services > advanced options.
    Scroll down and click 1 Terminate > 2 repair > 3 reset.
  2. Restart PC
  3. Check for Windows Update = None available.
  4. Search for “wsreset” in Windows Toolbar and Enter (Reset the MS Store)
  5. Restart PC
    6.Try to reinstalled th FS2020, then I got the 0x80070424 error which is the accumulation of two 0x803fb107 errors (one for the Digital Ownership and the second for the game).
  6. Deleted the downloads again in MS Store.
  7. Then I followed another post by :

start powershell as administrator, then type
Get-AppxPackage windowsstore | Remove-AppxPackage

Get-AppxPackage xboxapp | Remove-AppxPackage

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}
7. Restart PC
8. Restart the Game-Download again.
9. Then Error 0x8007001F appears.
10. Deleted the downloads again in MS Store.
11. After that I read in a forum that maybe the anti virus firewall could be a problem with downloads in the MS Store. So I turned off the firewall.
12. Restart the Game-Download again.
And then, what a miracle, it worked! The FS2020 is now reinstalled and working.

Thank God they don’t do software updates of real aircraft :slight_smile:

1 Like

try this, great tip from user. solved my problem with installing from ms store. this is a complete joke of a process by the way. I’m sick of it.

you should better use links instead screenshots of user posts :wink:

The FAQ mentioned these steps:

Ps: Unable to update for months - Download Looping - #113 by Cmarq24

Hi Guys…I faced a similar situation same error code…couldnt dowload my previous purchased MSFS
I searched my whole PC with all the files “Flightsimulator” and deleted every file.

And it worked …after that download was possible