Can't start Reno Air Races

Today there was an update for Reno. I downloaded it and enter into Reno Air Races with A NEW HOPE!
But, nothing changed. I can’t still start any race yet.

Some Chinese players say it is a unicode problem
They pointed out that the system language area must be set to an English-speaking country to operate normally
But I don’t know if it’s really effective
You can try it. I will also find time to test it

Hi Friends,
I shifted the Win10 to the US system and then tried the US time zone as well, and reinstalled the Reno Air Race Expansion Pack. However, it didn’t work for me. Apparently, Microsoft didn’t well test the expansion pack around the world. I will ask for a refund if they’re not going to fix it. SMH.

My friend… I think I really found a solution this time…
It’s really a unicode problem…
Please try to tick the item “Beta: Use unicode UTF-8…” under the region…
After applying, restart the system and you can enter the flight race normally.
I have no problem with the actual test…
QQ截图20211204202124

1 Like

Hi asirpan21
You’re absolutely right! After activating Beta Unicode UTF-8, I can enter the air race correctly. That’s fantastic! Microsoft should create a patch or an update to solve this issue.
Thank you very much! You’re a hero! :grinning: :+1: :pray:


This is where the Unicode UTF-8 option should be activated in English according to asirpan21.

2 Likes

Great! It’s working. THANKYOU.

Holy… I’ll submit this discovery to the zendesk so that they can refer to it when making a patch.

Although changing UNICODE setting could avoid this issue, problem is still there. We can not regard this as a solution because we should alter locale of the system just for this issue.

So i have a similar problem except i click race and it brings up a never ending load screen. I tried this trick and same result. I really want to race but i camt. :cry:

The Unicode thing did not work for me. I purchased the full Reno package and the “Race” tile is grayed out. The other ones work. But cannot race…

1 Like

I have this same exact issue. I bought and installed the Reno Air Races bundle for 59.99, but the option to Race is greyed out (even though I appear to have access to all the Reno planes in other flight modes):

Sim Update 9 is out, and it’s still not solved yet! What are they doing? I paid a lot of my money for this expansion! It’s been over 6 months!
Tweaking system locale is NOT a ultimate solution.

So for clarity, if i buy one aircraft for example a L-39 i don’t get access to Reno racing at all?