CH Pro Pedals Issues

The only way I can get my CH Pro Pedals to work is if I start the program, set up a flight, and then after pushing the “FLY” button and take control of the plane to then switch USB ports for the pedals. After changing USB ports the rudder pedals become active where prior to that action there is no response. Has anyone else experience this same issue?

No. But when I got my CH setup for X-Plane they stuttered bad. One solution was a powered USB hub. That worked for me.

I read they draw near max current for USB and some motherboards struggled to put out enough.

My CH Pro Pedals were working fine a couple days ago. Now they aren’t being recognized, even though I hear the Windows alert after I plug them in. I wonder if the latest MSFS update is causing this.
UPDATE: After a reboot of my system, the pedals are recognized again. Must have been a USB glitch.

1 Like

Just a suggestion but what I did was prior to taking off I set my camera so I can do a visual inspection of the exterior of the plane to make sure all my primary controls work. I that point if the rudder pedals do not respond I switch the USB cord to a different USB port and then at that point the computer recognizes them and I have use of the rudder pedals.
Hope that helps. I did this last evening after downloading the MS Flight sim update.
Good Luck!

1 Like

Question… I’m having issues with my Pro Pedals when taxing… the rudder goes whacko and I can’t turn left or right. I Calibrated the pedals with CH Control Manager and everything worked great. The next day my Rudder went crazy again. Do you need to recalibrate everytime before entering FS, or do I have other issues?

Just to add some of my own experience to this. I have my CH Pro Pedals plugged into the USB port in the rear of my system. I have a CH Throttle plugged into t a powered USB Hub, and I switch between a Logitech ExtremePro3D joystick and a CH Pro Yoke plugged into the same USB Hub.

I have never once had an issue with the CH Pro Pedals being recognized by MSFS (you really don’t want to use a hub for these things, even powered, if you don’t have to). My response of my pedals in MSFS has been smooth and have never had any issue.

Interestingly, I just fired up FSX:Steam recently, and I’m having all kinds of trouble with the Pro Pedals in FSX. Most times they are jumpy and don’t control the rudder at all. If I pick them up and move them by hand, I can get them to react smoothly, but that soon goes away again. I have zero idea what’s going on, I never had a problem with them with boxed FSX on a different computer (I installed FSX Steam on this box). I don’t know what the difference is.

I have never had an issue with the Logitech Joy Stick being recognized.

I do, however, have issues with the Throttle being recognized. About every so often, not too frequent, but more than a few times a month, it isn’t recognized. To fix it, I unplug it and plug it back into the same outlet. No problem after that.

I’ve had the same issue with the Yoke; again, unplug it, plug it back in and away I go.

As a fiinal point, FSX has no issue if I have the Joystick and Yoke plugged in together. MSFS on the other hand, sometimes gets crazy if I have them both plugged in together. But, since they’re easily accessible, I just swap between them with no issue.

I have to admit, I’m kind of bummed I can’t use the pedals with FSX, that’s new and I assume associated with Steam? I’d love to have a fix for it because I will occasonally go back to it since my library of planes there is so huge, and sometimes I get a hankering… Doesn’t last long, but…

I consistently check all controls from the rear view - “Ins” key - during warmup. The rudders are rarely recognized until after I unplug, replug them. The initial USB port doesn’t matter.

Are they plugged into the direct ports, or a hub? Typically, the ports on the front of a computer are actually a hub, and not even a powered hub.

Have tried both front and back. No difference or improvement.

Sounds like an issue with your computer then. With the pedals connected directly to the rear of my computer, I have never had a connection issue between my pedals and MSFS once. With a powered hub, I do have connection issues with other CH Products products.

But I do have an issue with FSX reading my pedal appropriately, which is weird. Perhaps I have a driver issue with FSX. I did try to calibrate them, it didn’t change.

Ooh, I might have just figured out the issue, I’ll have to test it. I forgot I had my Logitech Joystick connected, and it’s got a twist axis. I turned it off in MSFS, maybe I need to do that in FSX, to!

My PC is 3 months old, but my rudders are at least 20 years old - most likely first release. If USB didn’t carry forward support from version to version - now at least 3.0 - they’d have been dead long ago.

I did play with disconnecting them before starting FS, and seem to recall that that did reconnect them, so am reasonably convinced it isn’t specific to FS2020. Need to verify this.

1 Like

Truth…Yeah, I’ve read lots of articles on the chaos of USB support…

I managed to make my CH Pro Pedals work with my Steam Controller in the Steam version of MSFS with the following steps: 1. In Steam general settings, in Settings/In-Game, check both Enable the Steam Overlay and Use Big Picture overlay. 2. Right click MSFS in the Steam Library. In Properties/General, set the drop down box for Steam Input Per-Game Setting to Forced Off, and the Use BPM Overlay setting to Forced On. 3. Be sure the Steam Controller is turned off (or unplugged), and then launch MSFS. 4 In Options/Controllers you should see keyboard, mouse and the CH Pro Pedals. Now turn on the Steam Controller, and it should pop up in 15 seconds or so in the Controllers window along with the other entries. I need to be sure the Steam Controller is off each time I launch MSFS.

I have been using my trio of CH products since MSFS release and subsequent updates, without the slightest problem.
A note to everyone with CH controllers is - you MUST use the CH control manager. Do not manage them from the windows game controllers cpl, you are in for endless problems, and you lose lots of calibration and sensitivity config capabilities.

1 Like

Here’s another approach; I have the CH Eclipse Yoke and always used the CH control manage in FSX; however, I’m using it without problems in MSFS without the control manager. I suggest you go the the device manager and make sure all USB connections and USB hubs are configured to NOT ALLOW power management on the hubs or connections. I use the Pro Pedals and the Eclipse Yoke without problems.

Same thing for me a few restarts and a reboot and my CH Pedals are back

Very good point about USB power management.

You should also consider enabling “ultimate performance” power scheme.

Look at the What to Do if You Don’t See the Ultimate Performance Plan

If you have CH Pro Pedals and another controller with twist axis both assigned to control the rudder, you will have problems. It will seem jerky, and won’t always control the rudder. It’ll work sometimes, and other times it won’t work at all.

Be ABSOLUTELY POSITIVE, the CH Pro Pedals are the ONLY axis controlling the rudder axis. Go through all your other controllers you have connected to your computer (X-box controller, Joystick with twist, etc.) and disable/delete the rudder assignment in all of them.

My CH Pro Pedals work, somewhat, with FS 2020, but the simulated aircraft’s rudder does not return to neutral when the CH Pro Pedals return to the neutral via their spring-loading. To move the sim’s rudder somewhere towards neutral I have to kick some opposite rudder. That does return the sim’s rudder to somewhere towards the neutral position, but the rudder might make it back to neutral or it may overshoot and deflect some in the opposite direction.

The funny thing is that initially the simulation worked with the CH Pro Pedals as expected. That is, kicking the rudder and returning the pedals to neutral via the pedal’s spring loading briefly deflected the sim’s rudder and then returned the sim’s rudder to its neutral.

So did something in FS 2020 change and, if so, how do I get the simulation and pedals to work again as expected. Needless to say, my current situation makes for some wild takeoffs and frequent crashes.

I have adjusted the sim’s sensitivity settings to the point that the rudder behaves per my experiences with flying actual small civilian aviation aircraft.

Does anyone else have this experience and/or know how to get the expected behavior of the simulation with the pedals back?

Since the pedals are around fourteen-plus years old, maybe they are wearing out and it is time to replace them.