Ch Pro Pedals not working after Sim Update 5

I just got a set of ch pro pedals from a friend last week. I checked to see if they worked last week before I bought them and they did. Now after the update the brakes dont work. rudder works fine. Te brake axis registers in the calibration menu in game but will not register in the controls menu. I even tried to rebind them and it will read them but the do not work.

Mine work, at least so far. I am encountering many other bugs tho. I wish I could help but my ch pro pedals are still working as they always have, fyi.

I’m having the same problems, they show up in the calibration but not in the control menu. Are you using CH Control Manager or windows to calibrate them outside the game? I’m using CH’s

Every few weeks I run into issues, I go into Device Manager, Uninstall the CH Pedals Driver, right click the devices and Scan for Hardware Changes. Let the driver reinstall.
Should sort it out.

Removing the CH Control Manager and calibrating through windows worked for me. Brakes now work.

I calibrated them with both ch manager and with windows usb device. Neither worked. I think I uninstalled/reinstalled the driver but i will try again. They worked fine before the update. I mabbed them both to a button press instead of an axis and that works for now, however they are not analog and i dont have left and right brakes. They are all or nothing but its better then nothing. I did open a ticket and will report any updates back here. Thanks for the replies.

Having a similar problem with CH Pro Throttle USB. The game recognizes and can calibrate & set sensitivity for the analog stick axis and throttle axis, but when I bind any of them to a control, they don’t register any input.

Just to clarify, I just installed MS Flight Simulator 2020 yesterday so I don’t know if it’s a new issue or not. Sure seems like a bug though.

Yep - I also have CH rudder pedals which have worked perfectly since release.

After SU5 the toes brakes no longer work (although the axis are correctly assigned and can be seen working under ‘sensitivities’ )

For me, SU5 has to be the worst update so far, so many issues.

I got them to work with CH manager following this thread (you need to make a new profile from scratch in MSFS 2020): Toes brakes not working on CH rudder pedals since SU5 - #10 by MarkRitzman

Same issue here psued0, although I also have the Fighterstick. Got them both after the big graphic improvement update from a few days ago (and they work fine in DCS). Can’t get Fighterstick X axis to bind, neither can I get the Pro Throttle to bind. Both work in the sensitivity menus. Let me know if you stumble across a solution, and I’ll return the favor. Thanks.

Got it fixed…needed to delete prior profile and create a new one.

Watching the 3d pedals in the cockpit I noticed the toe brakes moved initially BEFORE releasing the parking brake but wouldn’t let go once the parking brake was released.

Same here. After the last update, my rudder on the ch pedals is not working anymore. When i move the pedals, the rudder is jumping back and forth. If i look in the sensitivity setting, this behaviour is not shown.

Tried so far: switching usb ports, remove profiles, remove other controllers.

I had similar experience and found that the problem is in the driver that windows auto-installs. Go to Settings->Devices->Bluetooth & other devices->Devices and Printers, right click on the pedals, select “Game Controller Settings” and re-calibrate.

Worked for me, YMMV.

If you can’t see your pedals in “Devices and Printers”, the issue is more likely that Windows is not recognizing the device. Could it be a USB hub?

Just an update on my side…

Made a separate post

After testing with several settings and swapping controllers, I finally made progress in tracing down the issue and it seems to be solved.

Just to clarify. have a Hotas warthog, CH pro yoke (with single throttle lever) and pedals and normally next to it a logitech joystick for drone purpose only.

Now hopefully the solution to the problem I got. My CH yoke is often not working directly in MSFS 2020 when i wanted to fly. In device settings of W10, it is then stated unrecognized. So what I normally do is pull the usb plug and reconnect.

The last time I did this was it not working again and therefore try to remove the warthog and the logitech. When reconnecting the warthog and logitech, I didn’t pay attention enough when MSFS 2020 asked: Do you want the default or current setup. What I remembered now is that I have chosen DEFAULT.

The result of this, both warthog and logitech have default throttle, and display setting etc. So when i reconnected the next time the logitech again the small throttle lever was in mid position and that caused jumping.

I have still to check settings in various profiles but hopefully that solved it…

Hope that can be from benefit for somebody!