Checkerboard textures at Kavik River Camp (RK1) FIXED!

Well, saw this release and jumped on it. Generally speaking, I love the depiction of Sue Aikin’s Kavik River camp from “Life Below Zero”. I am having one issue, however with the ground textures inside the camp itself. Specifically, these checkerboard patterns in the camp area.

I am working with the seller/developer and the cause seems to be a mystery. He sent me an image from his computer and there is no checkerboard. He suggested that there may be a conflict with another (AK) scenery but I don’t experience it anywhere else.

Has anyone had a similar issue? If so, how did you resolve it? Any thoughts on a fix? I really like this scenery but I’d like to love it and can’t right now.

Thanks for any help you might offer.

Remove all other mods except this one and see if it persists.

I was trying to avoid that, if possible. Thx.

Sorry, no way out. This is why loading too many mods is a real Catch-22. Sooner or later, they start stepping on each other, and unless you caught the problem just after adding the latest one, you gotta yank em all and put em back, one painful restart at a time.

To save some time, consider just yanking only the sceneries. If it’s all scenery, well… :v:

There’s a happy thought. I renamed my community folder and created a new one with just the Kavik app and it worked fine. I think this may be a good time to set up MSFS Addons Linker. Should make sorting such things out easier in the future.

1 Like

This tool searches for and automatically renames invalid modelLib.BGL files that cause similar conflicts in scripts. ModelLibChanger • Microsoft Flight Simulator

Couple of things, I’ve seen this before and fixed it.

  1. Are you running enhanced airport graphics by Zinertek? I’d so, make sure you’re running the latest version

  2. if the addon had a materiallib folder, it needs to be renamed and the layout.json updated.

These 2 things have solved all my checkerboard issues.

Also - I absolutely appreciate that many believe addons cause all kinds of problems in MSFS. This can certainly happen, but keeping addons updated and knowing some common issues associated with addon naming, etc, these can be solved. I have 400Gb of addons loaded each time I start msfs across 600 folders. My FPS is just fine.

Well, I tried renaming the MaterialLib folder (to MateriaLib.X and edited Layout.json accordingly but to no avail. I do not have the Zinertek graphics. Maybe I should get them?
I’ll try the “ModelLib changer” app suggested by PavelGapich and see if that fixes it. Thanks for your input.

Cheers!

Hey I’m really sorry, I wasn’t at my PC when I responded. It’s actually the “MyMaterials” folder.

So - you might have something like this:

Community
→ addon-name
—> some other folders
—> MaterialLibs
----------> MyMaterials

It’s MyMaterials that’s the problem.

Change MyMaterials to something like ICAO-MyMaterials, so like RK1-MyMaterials.

Then run the autojsonupdater.exe to create a new layout.json and restart MSFS.

EDIT to add - please reset your MaterialLib folder to its original name.

Well, the materials file was named “RK1_Materials” so I renamed it to "RK1_MyMaterials and edited the JSON manually using search/replace. I don’t have the json autoupdater.

Long story short - Still no love. Open to any other suggestion, otherwise it’s going to be a tedious process to find and remove the offending file.

Thanks again.

Without me loading the sim up and checking, I assume this isnt’ caused by a tick box in the SDK being selected.

I’ve never used the SDK so I have no idea.

Ok it’s unlikely then. I don’t think I have seen that texture before by turning on any clickable’s in the SDK menu’s anyway.

OK, thanks!

Well, I found the conflicting file. It was an old version of ESD Kantishna airport.
I deleted it and and replaced it with the newest file and all is well.
Kavik is a great little bush strip, well modeled with nice details. Well worth the 10 bucks.
Note:If you’re using Bijan’s Trees, you may want to temporarily remove them if you’re flying here, they’re really too tall for the tundra at this location.
Cheers!

Just to be clear, there are no trees in that location in my season mod. It is probably caused by conflict with another tree or airport mod. :slight_smile:

Yes, I found the offending mod and deleted it. A’’'s well now.
Thanks for your help.

1 Like

This is a year old now, but I had this problem today and it was caused by Rex Global Airport Textures. I updated it May 4 2022, but SU10 seems to require them to release another one. I’m not aware they have yet.