Checking for Updates Screen - Stuck

It is actually an issue with windows date/time synch. As soon as I synched the date/time in windows (even when it was already on auto synch) it worked immediately. If you see in the forum post I included, it wasn’t downloading anything at all. Just some bizarre issue. :joy:

Also stuck on updates here, Time sync did not help. Did not have any issues yesterday.

EDIT: Installed latest windows update and not it worked. Don’t know if this really was the cause.

on xbox stuck checking for updates…

Real pain, hit & miss stuck issue. For me a reboot does the job if stuck.

I run a Dimension 4 program that syncs PC clock every hour for my ham radio apps, I was .04 minutes off that hour. Doubt that would affect downloads.

I’ve been regularly seeing this when launching the sim lately.

When I do a manual sync of the time, I see that is always off by a fair amount.

This sitting on the Checking for Updates wasn’t an issue in the past, so what I don’t understand is why this is suddenly a thing. I’m not understanding why my PC has recently developed an inability to maintain/sync time correctly and/or the sim has become significantly more fussy about the time being in sync.

I did not used to have to manually sync the time before launching the sim, so why do I have to do this now? What changed?

3 Likes

Hi @NixonRedgrave,
I’m not sure that time syncronization is the only cause here. I just looked at my settings (Windows Settings | Time & Language | Date & Time) and see that I have not synced since March:

1 Like

Just got it again for about 5 minutes. And for some reason I can’t sync the time. The windows time service is disabled for some reason and I can’t turn it on. Everything is greyed out.

Hi @American3982055,
Are you logged onto your PC with an account that has administrative privileges? Generally, if a setting for one of the services is unavailable, it means the user does not have sufficient rights to change it.

As far as I know. I might have to look into it.

I had one successful flight this morning for about an hour. Then I quit the sim, and came back about an hour later. The next launch I got stuck on the checking for updates screen. I restarted the computer a few minutes later, and relaunched to the same thing.

However, on the third launch it worked as expected. I’ve never had it happen twice like that.

This checking for updates hang and the load bar getting all the way completed and not starting the sim are becoming quite common problems. There’s quite a few of these threads and both happened to me recently.

It’s definitely some issue between gaming services, the XBOX app, and MS store. Whatever you do, don’t jump to re-installing the sim and loosing a day or two for nothing!

Amen to that! It gets quoted often, and I’ve always believed that it would be simpler, and quicker, to delete suspect folders to force them to be downloaded again, rather than delete everything.

I’ve noticed this checking for updates issue as well. If it sticks on this I just ALT+F4 as I have no patience and go back in and it normally works then.

1 Like

My Xbox app/gaming services broke AGAIN today causing the load bar of doom that never launches starting from addon linker. Seems to do that or hangs at checking for updates if launched from the native MSFS icon.

You can tell it’s borked if Xbox app support(under your gamer tag) does not show the repair tool. It just shows a hyperlink that won’t work.

You have to go through add/install programs and remove the Xbox app, Xbox gaming services and Xbox live and reinstall the Xbox app and run repair.

If you only uninstall the Xbox app it won’t let you reinstall without removing the other two. This has happened 5 times now in the last two weeks.

I fully shut down this computer every time I’m not playing. The laptop upstairs doesn’t have issues with the Xbox app. I have all the MSFS windows performance tweaks on the game computer I wonder if something is causing it there

I noticed that there was an Update to the Xbox Identity Provider yesterday on my PC. You might try opening the Windows Store, clicking on the Library icon, then click on Get Updates, and update any apps that have an update available.

Not sure if this will help those stuck to get back on-line, but it is quick to do & cannot hurt to try.