Cirrus SR22 MFD Blank Screen

,

It’s June 18th, 2021. I installed the new update this morning. Now when I fly in the Cirrus SR22 my MFD turns blank after several minutes of flight. The PFD doesn’t seem to be effected at this time. When the MFD turns blank the AP turns off, and I can’t turn it back on.

I wasn’t having this problem prior to today’s update. There is no mention of this problem in the Known Issues. I don’t have any mods installed.

Is anyone else experiencing this problem today?

Might be a thing…

Mmmm, maybe he is also not turning on the generators?

1 Like

The other post referenced - one response indicated someone did not turn on their Generator Switches.

No such switch exists in the SR-22 - either you have the Avionics switch ON or OFF. If OFF, both PFD and MFD will not display anything.

Are you using the Working Title G1000 mod?

What’s the “working titile G1000 mod”? Didn’t understand that question.

Ah, you’re missing one of the best improvements to the stock Navigation Unit. :slight_smile:

Long Story Short: Working Title team was hired by Asobo to improve all three Garmins - G1000, G3000 and G3X.

Get the G1000 mod here and install it. A LOT of improvements are present, and possibly, your blank MFD problem will also be addressed.

https://www.workingtitle.aero/packages/

And the best is yet to come in July - likely via Marketplace:

1 Like

Thank you!! this is great. I’ll install it right away.

1 Like

There are alternator switches (ALT1 and ALT2), without which the battery is going to drain until it dies…

You’d probably see a “LOW VOLTS” warning on the PFD.

Ok, If I taxi around with the PFD, MFD, and lights and pitot heat on, after a few minutes the PFD and MFD both turn off. If I then switch the alternators on, things start sorta working but it’s a bit glitchy trying to run everything at once on a dead battery.

Good, I am also trying this

1 Like

Should add that the generator switch idea was just the easy one. There has been a bug lurking with the panels that can turn them off in flight. I’ve only seen it once a couple of months ago but you may also be able to just cycle avionics power to get them back if it is the same thing. Still a bug but the rare bug with a workaround if this is what is going on.

Do not use GX mod with the 1000G or 3000G mods. It’s gona mess thous up.

Ok good to know. So far it has worked.

1 Like

June 22nd, 2021. Since my original post, I have discovered that the blank screen problem is happening with any plane I select that uses the GARMIN. I have not tried every plane, but I have tried enough to understand that this is a serious problem.

I tried re-installing MSFS, and what a nightmare that was. Although I pay for a download speed of up to 1Gbps, it took me 4 days to install MSFS. That’s how slow the download was. That in itself is a whole other MSFS problem.

After finally getting the simulator installed and trying my plane(s) again, the problem was still there. I decided to try the advice of one of the repliers to my original post, and install a GARMIN update. Well, I’m happy to announce that I just did a test flight from CYTZ to KIAG and my MFD or PFD didn’t go blank. I am yet to try the other planes, but I will.

I’ll update again once I have flown more test flights.

2 Likes

June 23rd, 2021. Tested several planes since I updated the Garmin 1000, and I have had no problems with the MFD or PFD. It’s safe to say the update fixed the blank screen issue.

Thank you all for your quick responses and suggestions. :slight_smile:

I’m having the same problem. I think it is a G1000 issue but I don’t know how to solve it as all generators and batteries ( as suggested before) are on. An help would be appreciated

If you have hardware with a physical magneto/start key (like the Honeycomb Alpha), make sure the key has been turned back to “Both” and is not left on “Start”, the power draw from the starter will kill your battery & avionics will shut down in the plane after a few minutes.

2 Likes

I still have a black screen. I have reset the game, updated G1000,checked battery and generator switches and also checked the key settings where applicable. The only thing left to do I think, is to reinstall the program. That’s a scary road to travel down, My problems occurred after update 1.14.6.0 on 3-26-21. Presently, I can’t fly the aircraft with the G1000. Again, any and all suggestions would be appreciated.

Generally speaking the packages should be good, so don’t blow away your Packages folder (which is the bulk of the program - 100 GB+). Move it somewhere else then uninstall the program. You should only need to pull down 1.6GB for the core files then when the installer asks you where to put the rest, point it to the packages.

Just out of curiosity, does it happen if you do a CTRL-E at cold & dark instead of following the checklist?

Thank you for your help. I tried CTRL-E and the problem is still there. I’m content not flying the G1000 aircraft anymore. I’m not going to reinstall the program as I’m spending more time trying to fix problems than I am flying, Thanks again

If you are using the Thrustmaster TPA, make sure the Eng. switches are turned OFF.