Cockpit stuttering in VR, but good overall performance, what's wrong?

I’ve not been simming much in recent months, barely played since SU6, and I’ve noticed that in my standard plane C-172 (non-G1000), whilst my calibrated settings work really well for overall performance and in particular with no stutters in the passing terrain even at low level, I’m finding the cockpit itself (especially the pillars either side of the windscreen) when moving my head left and right are noticeably jeryky/stuttery.

I tried mucking around with some settings, and got maybe a minor improvement, but it’s quite distracting. I’m not a fan of motion reprojection anyway, but with that turned on, whilst the pillars might be a touch smoother, they’re also blurry as hell and covered in artefacts when I move my head.

I’ll mention my hardware and settings, but as I say, this seems to be something that has gotten worse despite not changing hardware or settings, and also that overall framerates (around 35-40 in VR) and terrain performance are good, so it’s not just a matter of “turn everything down”, it’s specific to the interior of the plane. I’m using a Reverb G2, on a system with 64gb ram, 5900x CPU, and an RTX 3090. The settings I used are a combination of medium (for trees/bushes/buildings) to Ultra (for texture res, and most other stuff) and mid-range LODs.

Any advice on any settings that I can tweak to specifically affect the cockpit smoothness without degrading everything outside?

6 Likes

It’s has been this way forever

1 Like

As has been discussed many times, right from the start this game has had a very poor VR implementation generally.

The VR roadmap doesn’t give me much hope either.

1 Like

This is strange to me, as I thought things had changed. I’m sure previously when I optimised my VR settings for my (admittedly quite powerful) PC, that it was ‘fine’. I never noticed the judderiness in the cockpit … perhaps I just missed it. But I’ve been flying little other than in VR all year, and I thought jumping in for the first time in a while last night, that it had degraded, but perhaps it was always there :thinking:

I initially flew VR using a PSVR as a trial and it was butter smooth in the cockpit, but was too low res to be a long term solution. I now have a G2 and it stutters in the cockpit like you say. It just is what it is.

1 Like

In my trusty HP G2 the head side to side jerking has been around since the start but can be eliminated completely with OpenXR reprojection. This is why I use it exclusively now on all flights. The artifacts you get over the prop also appear much improved but the trick is to not push the graphical settings too high to allow the reprojection to work.

2 Likes

Although it seems strange, I was able to make that defect almost disappear by disabling the ambient occlusion.

I have to say no. The with SU6 newly introduced stutters affect only the cockpit and is fps independent.

Most noticable when you look sideways and come across the fuselage.

Imagery outside run smooth, glass cockpits run smooth but the fuselage jitter and stutter like a lambs tail in the frost.

2 Likes

Right, this is essentially what I thought. I know performance has always been a hot topic, especially in VR, but I thought I had mostly sorted it with settings, and this cockpit judder was new. So if you’re right, then I’m not going mad. It’s exactly as you say, when turning to look out the window and going past (what in a car, I’d call) the A-pillar, it moves past the FoV seemingly at 10 FPS or so, but everything else out the window is still smooth.

With motion reprojection on, I’d always get some artefacts on the prop, and wing strut (C-172) as terrain passed under it. I never liked motion reprojection for these reasons, so I fly with it off. But having tried it out again recently having this issue with the cockpit stutter, suddenly the A-pillar was wobbly as hell due to the artefacting, I’m sure I’d never seen that before with MR on.

I did also kill ambient occlusion as @IDVANDER said, and maybe it made a slight improvement, but nothing dramatic. Hopefully the next update will help, whilst breaking something else that I don’t care about :smiley:

1 Like

Great this saves me posting a separate thread, I have the exact same issue.

3080ti water cooled
10700k 5.2ghz water cooled
32gb ram
whatever the fastest m.2 SSD was at the time of the build.

Terrain/clouds everything outside is buttery smooth but cockpit/pillars are juddering badly.

I have followed every guide on youtube for the Reverb G2, and tested different drivers too,

For now I have once again shelved MSFS 2020 and gone back to my racing cockpit.

1 Like

I set open xr to 70 on !!automatic!! then in game to 80 render scale for vr. So much better and smooth with the g2 and clarity is better than the rift s. Way better.

1 Like

Do you have opened an zendesk ticket? Just to have tried it at least.

Why can we not vote for this thread?

I have noticed the same trend with my G2. I even ordered the new cable from HP hoping this could help. I don’t play in VR that much. I have phases: some are in VR and other times I use my G1000 gears. But yes it wasn’t that way before. I know I am not providing a solution here. Rather just wanted to confirm what you are experiencing is real.

Are you using Windows 11? HP Reverb G2, cockpit shaking since installing windows 11 - Bugs & Issues / Virtual Reality (VR) - Microsoft Flight Simulator Forums

1 Like

No, not upgraded yet, still Win10.

There is nothing unusual about this and it cannot be fixed. Cockpit judders simply because it moves relative to your eyes when you move your head; scenery looks fine because it’s faraway and barely moves within the frame. If you don’t like motion reprojection there’s no way to get rid of this.

1 Like

Same here. Outside everything is fine, but the cockpit is juddering that almost kill any good experience that VR provides.

I hope for a good solution soon.

Edit: Ryzen 3600x
RTX 3070
32gb DDR4 3000mhz
HP REVERB G2

1 Like

Not sure if it is related, but another post mentioned going into WMR settings/environment and clicking on “clear environment” which stabilizes the cockpit. I’ve had uncommanded cockpit movement, and this really helped.

1 Like

I experience a big change in the stability of the cockpit after upgrading to Windows 11.
3080ti ,10700k 5.2ghz , 64gb ram, Reverb G2

Feels like this:

1 Like