Computer Crashed During In-Game Update / Now Stuck On "Checking for Updates" Screen

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

No

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

I was doing the recent SU6 IN-GAME update. It was downloading files just fine! Then I unfortunately lost power (to my house). Grrrr (we’ve had severe weather today). Now, when I launch the game, it is stuck on the “Checking for Updates” screen. It just hangs there. I’ve tried everything I can think of to get the updates to restart. Cleared Community folder. Closing app with Alt+F4. Ending task in Task Manager. Starting in Safe Mode. Nothing really changes. I’m just stuck at that screen. :frowning:

Is there a way to force the update to start over again? Any files I can delete somewhere to have it re-start? Registry changes?

PC specs for those who want to assist (if not entered in your profile)

Dream specs…

Build Version # when you first started experiencing this issue:

SU6. But I think this is more of a “crash during update problem” than a “SU6 problem”.

Are you on the Steam or Microsoft Store version?

MS

Did you submit this to Zendesk? If so, what is your ticket #?

No

the same here … the simulator does not open , it is locked

Delete the file it stuck on and try again. Otherwise you probably have to reinstall from scratch.

Whew. I was able to fix things. I went into the OFFICIAL/ONESTORE folder, and deleted everything that had a file or folder update date of today. When I went back into the game, I had to download 26 GB, but everything worked after that! Problem solved!

5 Likes

Good to hear… although of those just deleting the last timestamped file would have been enough

Thanks. I did notice there was one .part file that clearly didn’t finish downloading. My internet is pretty fast and download speeds haven’t been a problem, so i figured what the heck, and deleted more. It’s crazy to me, though, that a single partially downloaded file could completely hang the game. The update mechanism can’t figure out what to do with it? Kind of poor error-handling (I’ve been a software developer for 20+ years and this is the kind of thing one plans for….).

1 Like

Where is this OFFICIAL/ONESTORE folder you speak of?
Is this only if you installed it via MS Store?

I installed it via Steam

Still stuck on spinning wheel

UPDATE:

Ok, after hours of messing with it… I figured it was one of the free add-ons I installed. I installed like 6-8 packages…
I BOUGHT IT THROUGH STEAM. - THIS MAKES A DIFFERENCE.

Within this folder
Steam version :
AppData\Roaming\Microsoft Flight Simulator\Packages
were 2 additional folder.
Community (was blank)
Packages - I sorted by date and moved all folders created today (since it stopped working)

restarted, it installed a small update 30Mb and started up.

2 Likes

Can confirm your point.

Had a system crash early this morning, and since was stack in the check for update problem.

I tryed to remove the .part file and the last updated folder, with no result.

So I checked and moved out all what was updated around the crash time (up to two minutes from it) and it did the trick :wink:

1 Like

Hi

I was having the same issue and your recommendations worked perfectly. Thank you so much. I was going crazy trying to figure it out👍🏽

1 Like

Worked a treat. Thank you so much