Constant stuttering since Maverick release/ low performance

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No, And does not change anything when in developer mode.

Brief description of the issue:

Screen stutters when panning or moving the plane. FPS decreases as well. Typically starts at start of flight. Occasionally sim starts smooth and gradually decreases to an unplayable stutter. Creating a new bug because this issue started for me after Maverick release not SU9 like other bugs I have seen reported on here.

I have tried everything I can think of from emptying community folder to reinstallation. Tried numerous setting tweaks and none of it has made a difference. Drivers are up to date and other games and systems run smooth.

Open to feedback on my system specs below, but up until last week, this sim ran very smooth for me. I believe I more than meet minimum system requirements.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Start the sim. Select any aircraft. And start flight. As mentioned above. Sim will stutter when panning or during any flight motion that moves view.
Issue started immediately after the Maverick was released. However this issue has remained after removing all mods and reinstalling the sim.

PC specs and/or peripheral set up if relevant:

Processor|Intel(R) Core™ i7-10700K CPU @ 3.80GHz 3.70 GHz
Installed RAM32.0 GB (31.9 GB usable)
NVIDIA GeForce RTX 2060 Super
64-bit operating system, x64-based processor
Windows 11

Build Version # when you first started experiencing this issue:

1.25.9.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I don’t think that it has something to do with the Maverick DLC as I and many many others have the exact same issues (especially panning or FPS loss when moving) since the SU9 update.
Now I am not saying that you are wrong, but I think those issues were there earlier but didn’t affect you for some reason until the DLC got released.

4 Likes

The Top Gun DLC was just a content update. It didn’t change any core sim files or code. That’s why the sim version is still the same as Sim Update 9. Your issue must be explained by something else.

1 Like

Totally fine, just highlighting the starting point with all info I have.

Noticing in dev mode there are intermittent drops in FPS. Not an expert but I assume that would be causing the stuttering when panning?

Just trying to isolate the cause in the chance that this issue is on my end and not the sim.

Perhaps server load increased due to influx of new players since maverick dlc? Perhaps there are api limits or server throttling due to demand - this seems to correlate to poor performance.

This all may be on my end, after all that. Uninstalled malwarebytes and magic improved everything.
But going to keep testing before I sing victory. I have had smooth starts before that yielded eventual stuttering…

Still appreciating everyone’s input

Moved to #self-service:install-performance-graphics which is more appropriate :+1:

1 Like

Same issue. I submitted a report to Asobo with the following description:

I noticed while running the new DLC Maverick and flying the Maverick Activities low altitude missions, whenever I bank/turn the aircraft I have major stuttering and drop in fps. I checked my CPU & GPU during the stutters and what is interesting the GPU utilization goes from 80-90+% down to 18-22% utilization and the CPU is hardly ever over 35% utilization. Given the utilization of the GPU actually goes down during turns, it makes sense why the fps drop and stutters occur; what I don’t understand is why does the GPU utilization go down when turning? I should mention, I do not notice the issue while flying other aircraft in the simulator. However, when flying the FA-18 at any airport and turning rapidly, the same issue occurs which leads me to believe this isn’t necessarily an issue with the new Maverick DLC, but rather the aircraft or simulator itself and I didn’t notice until the new DLC since I don’t normally fly the F/A-18 aircraft. I have seen posts by other users that stuttering started occurring to them after Sim Update 9 (not sure if this is the culprit). If I fly other aircraft, I do not notice the issue but am not normally flying at this rate so low to the ground with other aircraft.

I captured a video of this and tried to attach it to this ticket but my upload kept timing out (I cropped it down to 71MB but still couldn’t upload it here). Even though I used OBS to capture the video as an example, this occurs without running OBS or any video capturing software.

Troubleshooting steps I have taken include:

  1. Removing all content from the Community folder (result: no difference)
  2. Change graphics from High to Low (result: no difference)
  3. Verified up to the latest Nvidia Graphics Drivers (version 512.95)
  4. Cold boot and restart (result: no difference)
  5. Change to 1920x1080 resolution (result: no difference)

My computer specs are as follows:
AMD Ryzen 7 5800X
ASUS TUF 3070 TI (8GB) GPU
Corsair Vengeance RGB Pro 32GB (2x16GB) DDR4 3600
ASUS TUF Gaming X570-PRO Motherboard
Dell Alienware 34" G-Sync Display (running art resolution 3440x1440)
Samsung 980 SSD 1TB
Internal spindle drive 7200RPM (MSFS install location)
EVGA Super Nova 850 PSU Gold Plus

3 Likes

OMG, i thought that i was the only one having this issue. haven’t played FS in a while and with the new release of Top Gun DLC, decided to give it a try and boom, soon as i hop in the F18 and start turning or pulling up, the frame rate drops and multithread graph in dev mode starts dropping along with GPU utilizing. which tells me that GPU is not being utliized. soon as i hop into a different aircraft stutter is gone when i turn. there’s something wrong with the aircraft. tried turning down the graphic settings and nothing changes. where did you submit the ticket, maybe i can give it a boost?

2 Likes

One final update from my end on this topic I started.

The cause of my stuttering issues ended up being my antivirus. Just coincidently started when I installed Maverick and was the only thing I forgot to check before I created this. Not sure why it was interfering with MSFS but the second I turned it off the stuttering stopped.

Thanks again all

1 Like

Antivirus - always in the way. Who gets viruses anymore. I disabled that a long time ago. Windows made it difficult, but I accomplished it.

MS got back to me and asked me to turn off photogrammetry. I did, no improvement. Asked for other suggestions. Will keep you and others posted here!

Cheers and Blue Skies!

well, they’re no help. that’s literately one of the first thing i tried, along with lowering all the other settings and AI settings.

where can we go to submit a ticket, i’ll support you by adding to your thread.

1 Like

So, I’m having this very same issue as above.

Ryzen 9 3900
Nvidia 2070Super OC
32GB 3200mhz ram
Mvme m.2 & ssd
850way gold plus psu

3 days of testing and I’ve found that the new vapour effects are absolutely killing FPS.

CPU @ 14% usage
GPU DROPS to 16% usage

It’s the wing/ g vapours.

As soon as they start to appear in high g turns, the system bombs from 50FPS goodness to 11FPS slideshow.

How do I know it’s specifically the vapours?

On every fast jet I have:

F16
F15
F14
F35
F18

I’ve had to go into the individual model XML files and block the lines of code that include, “ASOBO_FX_WINGVAPOUR” and “ASOBO_FX_PRESSURETRAIL”

After that, the aircraft have all become flyable again.

Hope this information helps!

2 Likes

OMG , for a while, i thought about maybe it’s the vapor but my head kept telling me that it can’t possibly be the vapor. but i think you’re right.

can you shed some light on how to go about disabling the vapor? i tried dev mode but that doesn’t have any option to disable it.

how can we go about escalading this to the devs.

1 Like

i can confirm it is indeed due to vapour.

delete the three vapour fx entries in the visualeffect xml file fixes it. kinda unfortunate that they couldn’t get the FX right.

2 Likes

Yhe way I did it was within the aircraft model file XML here:

Howzz1854 - Its just been suggested to disable HPET on my system because of this issue.

Tested and confirmed!!!

Disable HPET: Run CMD as Administrator and type:

bcdedit /deletevalue useplatformclock

Restart the computer and test and aircraft with the wing vapours etc!! :smiley:

1 Like

i get it. But some of my applications need HPET to function. honestly, if a game is coded right, it shouldn’t require disabling HPET.

making changes to the game seems the least intrusive from a platform perspective.

2 Likes