CPU limited RTX 3090

Hello all, I just updated my gpu to a 3090 from a 2080super. On my 2080super I was GPU limited, but once I started playing with the new gpu I am now CPU (i9-10900k) limited. Gpu stands around 60-70% at (61c). I have almost everything on Ultra on a 1440p 144mhz monitor. Gsync is turned OFF inside the sim settings. Is there anything I can do to get my GPU to fire up a little more? or what can I do so i am not cpu limited?
Sliders: 90-200-200
Specs: i9-10900k,rtx3090,64gb ram.

Dont you mean to fire your CPU up a little more?

Why if I’m already cpu limited?
Sorry I’m not a computer expert.

If you’re CPU limited that means the CPU is the slow point in the system. You need more speeeeeeeeeeeeed in the CPU to get the load back on to the GPU. Although, I suppose that is just another way of doing what you wrote.

Do you have an OC on your CPU at all?

Do you, I have no idea if this would actually work, have the ability to set the render resolution above 1440?
The higher your resolution, the more work is shifted from the CPU to the GPU. I have no clue if this would actually work just from the render resolution slider. For example, I get literally the same FPS at 1080 as I do in 4k because I’m CPU bound in one but GPU bound in the other. Likewise, I get more FPS at 1440 than I do at 1080 for the same, but not as limiting as 4k, reason.

I’m sorry it says “limited by main thread” what does that means?

And as for the resolution I only have a 1440p monitor so I can’t go beyond that. As for the OC(overclocked?) no.

You are running a 3090 on 1440p.If I had that GPU on a 1440p monitor the first thing I would do is increase the rendering scale and shift the bottleneck to the GPU.
Increase to 150 rendering scale as a start which is similar to 4k.

1 Like

Okay I’ll give that a try. How do you bottleneck a GPU?

The easiest way to bottleneck your GPU is to increase your resolution ,also pushing graphics settings to max but your 3090 is already overkill for 1440p.Try the rendering scale to 150 and see what happens.

Okay I’ll change the slider on the rendering scale to 150. As for the resolution I’ll need to buy a 4K monitor because I can’t go higher on the one I have.
Now, is bottlenecking the gpu safe?

Yes of course bottlenecking the GPU is safe. Honestly it is better to bottleneck the GPU than the CPU.CPU bottlenecks are actually worse as you net unstable performance. When I am GPU limited in this sim my fps tends to be higher. GPU bottleneck can also indicate low performance depending on the power of that GPU but its not always the case.
A 4k monitor will certainly put that GPU to work

I’ll give it a shot increasing the rendering scale when I get home and I’ll let you know what happened.
I’m experiencing micro stutters here and there but I think that’s because I’m cpu limited.

1 Like

3900rtx+10900k, some stutters here and there, incredible, thanks for the info, and other people with high end like you… obviously is something bad in the code for the nowadays and some years ago hardware’s, FS2020 is not a next generation Sim still without DX12 and “real” multithread, DLSS and the AMD equivalent, and Raytracing.

The first slider will put your GPU to the max sometimes sure, I you´ll notice more quality in the image too sure, I am in a 2080ti 1440p, and for me less of 140 is “blurry”.

1 Like

I put my rendering scale to 150 and it’s still limited main thread. Idk what’s going on. It looks nice though not going to lie. Stutters only seems to happen when scenery is loading in since I have the cache turned off. I also notice that my ram is 2100-2200 on the speed , I bought 3600mhz ram so I don’t know what’s going on there

You’ll need to go into the BIOS and enable XMP - which will allow your ram to run at its full 3600mhz.

What motherboard do you have? And do you have hyperthreading enabled?

If you get the new HP Reverb G2 headset that’ll probably use up any spare GPU capacity quite easily!

1 Like

I have the asus rog maximus XII hero (Wi-Fi)
Hyperthreading? I don’t think so. What is that?

Your CPU has 10 physical cores, hyperthreading enables each core to run an additional virtual core, which makes 20 effective logical processors.

Hyperthreading SHOULD be enabled by default, just open Task Manager > Performance tab > CPU and check to see how many logical processors it shows. Here’s mine for example:

Hey Camargo, I have the same specs as you. First of all make sure that you enable XMP in your BIOS. I have seen a pretty good performance gain.

As for the “Limited by main thread” thing… Not much to do about it. That’s a beast of a PC, currently the best gaming rig you can have. You can look into overclocking if you have good cooling. I did not see a performance gain worth it though. Love FS but it could perform a lot better than it does. Maybe we’ll see some improvement with DX12 :slight_smile:

The best tip I can give you is turn off the FPS counter and enjoy the game!


You want to lower the refreshing of the Garmin screens, as they take a lot of CPU and you don’t need them running at 60 fps (in real aviation, they run at around 25 fps). I don’t remember the name of the option, but it can help quite a lot. You can also try deactivating hyperthreading in the BIOS. I know some people have had a much better usage of their cores on AMD CPUs in MSFS that way. I don’t know if it works with intel though.

Then again, if you already have 50 fps all the time, stop worrying and enjoy the game.

1 Like

I have pretty much the same rig (10900K+RTX 3090), but with a 3860*1600 monitor.

The issue I’m dealing with is: The GPU usages in challenges and flight trainings are almost 100% and the FPS are OK.

However, in world map flights the GPU usage becomes pretty low. I’m still working on configuration adjustments to find out which setting is actually causing this issue.

First of all, I can confirm that adjusting graphic settings (including render scaling) will not increase the GPU usage at all. I’ve tried the graphic settings from low to ultra and the GPU usage (FPS as well) never changes.

Also when I choose “travel to” the “cruise” phase in world map flights the GPU usage becomes 99-100%.

I will try to find out the setting differences between flight challenges and flight in world map. (and the differences between the cruise phase and other phases) in the next couple of days.

Now I fixed the low GPU usage issue. I found that this issue happened when I entered the world map game and let “procedures” unset. So I entered the game, went to cockpit view, set the flight plan and procedures manually, then the GPU usage increased to what it should be.

Also, I can simply set a departure airport, and let arrival airport unset, then there’s no need to set flight procedures in-game. The GPU usage will be normal.

Finally, I can play this game with ultra graphic settings, over 60 FPS on my monitor. I’ve been investigating this issue for a couple of weeks and never realised that the flight procedures caused it. Hope it helps!