Crash on initial loading screen (Works Offline, but not Online)

I started playing this game in around September/October of 2020. I downloaded the game via steam soon after buying a brand new PC with more then enough to handle the game on high/ultra graphic settings (Details below). And put in a little over 100 hours of gameplay. One day while playing, it randomly crashed to desktop. I read through multiple suggestions on google and a lot of forums and I cant seem to resolve the issue. I’ve even held out for two major updates hoping it would resolve the issue and no dice. I held off on resorting to forums but I really want to play this game more and have no where else to turn. Any help will be greatly appreciated.

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Crashes on loading screen before arriving to main menu.
Provide Screenshot(s)/video(s) of the issue encountered:
Crashes with no errors
Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)
Intel core 9700K @ 3.60 GHz / 32 GB RAM / Nvidia GeForce RTX 2080 Super
Build Version # when you first started experiencing this issue:
Not sure, started playing around October 2020
Are you on the Steam or Microsoft Store version?
Did you submit this to Zendesk? If so, what is your ticket #?

Also, looked at the event viewer and this is what I get:

I had this issue on my old system. I repaired and it uninstalled and reinstalled and it fixed it. Is there anything in the community folder? If so move everything to a new folder and try it.

There hasn’t been anything in my community folder. I haven’t downloaded anything extra outside the game.

please check whether you have the English Language Pack US installed

That is one of the first things I tried. It seemed it was installed as the default on my PC.

I also want to add that I followed a thread on here from a couple months ago about issues with Steam Cloud issues. I followed the steps and still didn’t work. However, one thing I noticed was the game would work if I disconnected the internet. Still stuck :confused:

hmmm… the error combination " 0xc0000409 & ucrtbase.dll " is normaly the missing lang pack “US”. The FAQ recommend a re-install:

But here is a thread where it was seemingly caused by security software like Bull Guard ( which often cause trouble ):

Mine only crashes too at some point prior to being in aircraft
Since the latest update was fine before my PC never crashed on anything

MSFS takes so long to down load I’m against deleting & reinstalling close to boycotting msfs2020 !

I am from the US so that pack is the default. I looked up the FAQ and I tried to remove the US language pack but was greyed out. So I tried installing another language (thinking I had to have at least one installed) and still would not let me remove the US language pack. But I don’t see how this would be an issue when I can play the game in offline mode?. Also I saw that thread on the anti virus, I don’t have any special anti virus like bull guard, so that couldn’t be it. Any other ideas? Those two error codes seem to be common in these threads, but I their resolutions haven’t seemed to help with mine. :confused:

yeah… its not possible in your case. It was for users which not have native installed the lang :slight_smile:

you can try to add MSFS into MS defenders exlusion list (as a try)… Of course can’t be sure, but it can have also somewhat to do with your internet connection. Do you use some kind of VPN ?

An older reported issue was possible the c++ lib, but…

You can also try to disable some multiplayer features ( e.g. generic models to on ) in MSFS and activate it step by step.

Defender already allows Microsoft Flight simulator:

Is there another service that is used that needs allowed?

As for the C++ that was one of the first things I tried. I tried doing it several times and no luck.

And as for my internet, I did a speed test and I’m running around 430 Mbps. I don’t think that speed would be an issue. I am not running a VPN or anything special. Pretty basic setup as far as internet goes.

I meant also exclusion for scanning ( Settings > Update & Security > Windows Security > Virus & threat protection > Virus & threat protection settings > Manage settings > Exclusions ).

I asked about VPN because the idea is about “network relevant issue”. Internet “speed” is not what I have in mind, more a connection lost thing. But as said : a guess which may be completely wrong in your case.

Have no other idea for the moment as to “play a bit” with the game settings… disable some multiplayer features, etc…

There are other issues with these ucrt…dll ( e.g. sound driver ), but I assume its not relevant for you.

I really hope someone can help. I REALLY want to play this again. I even went as far is completely reinstalling windows just to get this to work. I see other topics in here that I have tried, and still nothing.

Do you have Seagate Toolkit installed? Some people have reported issues launching MSFS with that present, for some reason.

That is not a program I use.

strange is just that issue happens only in case you are “online”…

Some users helped to start the game with “-FastLaunch” option. But would have no glue what this should have to do with “online or not”

If we focus on “online” then may be the xbox login should be checked ( does eg. these xbox app works fine ? ). Or you have really an issue with a user setting which cause that. We had a thread about a while ago in special also for steam users “how to remove”. But I thought you tried this already ?

I downloaded from Steam. I don’t do anything with Xbox. Could that still be an issue?

You could try installing the xbox app (Xbox app for Windows 10 | Xbox), signing in with the account you use for MSFS, and checking that the MSFS digital ownership is present, and services are all working ok.

Well I was able to download the Xbox app and had no issues logging in. Did not see any issues. Still CTD.