Crash to desktop without error message

exactly, I always symbol with AI activated, but killing this feature to have the experience goes beyond the limits.

1 Like

Had this as well.
Turned out that I have to uninstall the latest driver and went back to 461.92

Hey
Même problème avec une carte AMD 6 GB
changé pour une GTX 970 4GB et plus de problème même si le GPU tourne à 100%.

I am in the process of redoing the LFPG flight to FACT still with the HP Reberv G2, BUT with the RX 6800 XT.
So at worst, I still had CTDs at the end of the take-off runway, at best after a few minutes, I’m already at 5 heures flight time, and still no CTD …

What do you think I did ???

constant CTD’s i am not even doing anything, just sit at world map trying to check where to go .
4th time in a row today :frowning:

I didn’t have CTD’s prior to 1.14.6.0
only at launch but that was fixed in Patch #2

I’ve Tried everything turned off all AI Traffic, ATC changed to Windows offline, Graphics reduced settings, and I’m still getting CTD it’s a problem with the Sim has to be… people getting Crashes with Nvidia & AMD, Oculus & Reverb G2

My Setup

AMD Ryzen 5600x
RX 6800 XT
32GB Ram
1TB m.2 nvme
800Watt PSU

I’m out of ideas at this stage

It’s hard what I’m going to say, but the best thing to do is wait, don’t try to delve into modifying any software or hardware resources on your machine, just wait, as I’m not even doing it, it’s already true that the problem doesn’t belongs to the user.

this is the only error I found related to FS in the event viewer:

The FlightSimulator.exe program version 1.14.6.0 has stopped interacting with Windows and has been closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 251c
Start Time: 01d723f998a57f45
End Time: 4294967295
Application Path: \? \ Volume {f1cc20c0-215c-0d50-6ce2-66f16e0f254b} \ FlightSimulator.exe
Report ID: f882171a-20af-4d4d-9fe7-456153094e1b
Failed full package name: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
Application ID for the failed package: App
Failed type: Quiesce

I managed to do a 5 hour flight on a flight that was supposed to last 10 hours.
For that, (Google is my friend), I went back to version 1.12.13.0.
I had to leave, I just came back, and I found the display of the image frozen in the helmet, but no CTD.
Ctrl Alt Del being inactive, I had to force shutdown the PC with the shutdown button.

There is no error message or alert.
I’m not sure of anything, but the display may have stuck, when the G2 wanted to go to sleep. I made a change to the registry supposed to prevent going to sleep. I say supposed, because until now it had never worked. After a while, the headset went into standby, and the display switched to the screen.

In any case, I remember that by going back to the first version compatible with VR 1.12.13.0 I managed to fly for at least 5 hours, on the same flight, which with 1.14.5.0 or even 1.14.6.0 , never exceeded a few minutes.

You said it all

conducting an investigation to discover these two problems, the coincidence is that the event of these problems was reported on the day my CTD’s started, I don’t understand that part, if someone can help me, or even see if these errors are in their machines.

“SM bus controller”
“PCI memory controller”

image

if anyone can help me how to repair these errors I will be grateful.

EDIT: I updated my motherboard chipset driver and this errors is gone, i will teste the sim, then i will post my report here.

EDIT 2: same problem, well … I leave this in the hands of Microsoft from now on, if it is the case I request a refund and go to FSX

New issue with CTD. Everything was working fine even after the most recent update and yesterday CTD at landing, then CTD at ‘ready to fly’, then CTD at airport selection, then CTD at game start!!!
gradual deterioration.
No change made in the system for the last month. No more addons, no hardware or software change. Except some updates for x-box which were there.
Something is rotten. If there has been no change in the system what so ever, I cannot understand why it is crashing!!
Tried to log out and log in from x-box. The game load time has increased almost twice!
Any suggestions are much appreciated!

UPDATE:
Did an app reset in Win 10. Reinstalled x-box. No change. CTD with airport select.

1 Like

I have just relaunched the LFPG flight to FACT. But before I deleted the key in the registry that prevented the upgrading of the HP Reberv G2

Now that I have deleted this key from the registry, which is supposed to prevent the HP Reberv G2 from being upgraded. The G2 goes into standby, and the image changes to 2D on the screen. For the moment, the display is not blocked. We’ll see later

We will not see anything at all, the screen of the G2 has just frozen with the PC blocked

Driver Amd 21.2.2 or 21.3.2 same results. The best improvement is the return to 1.12.13.0 from MSFS.

Hi all.
Even after a clean Windows 10 and FS2020 install I was unable to launch the game. CTD always happened during the blue bar, right before the main menu appears. I can confirm that in my situation it is the joystick (MS Sidewinder Force Feedback 2). The game launches normally if I don’t plug it in.

Luckily, I don’t have an MS Sidewinder Force Feedback 2. But someone among you has one, think about throwing it out the window. Seriously, I’m joking, but over and over, it gets annoying. In a while, we will have photogrammetry, BUT we will still have CTDs …

Good day guys, I have a friend who´s experiencing a CTD here is his Event Viewr Dump file:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33 Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33 Exception code: 0xc0000005 Fault offset: 0x00000000018a2714 Faulting process id: 0x2298 Faulting application start time: 0x01d72b4a39bf0487 Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x648wekyb3d8bbwe\FlightSimulator.exe Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x648wekyb3d8bbwe\FlightSimulator.exe Report Id: cccd321f-d630-4feb-af30-ee6decf3f0c7 Faulting package full name: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe

If I can get some help for him please it will be appreciated… @MichaMMA

I just hope that a mod watch this soon, it´s a total lack of respect!

Thank you for the thoughts, I will address them in order;
Power Supply - you might be right, but short of paying someone to replace it there is not much I can do about it, particularly as there is no hard evidence that power supply is the issue. I have undertaken some troubleshooting on the powersupply including isolating the PC on its own circuit. Smarter people than me tell me its ok.
Installed Ram. I have no idea about the memory model, the retailer installed it for me. I dont even know what xmp mode is. But there was no change to CTD before and after addition of extra ram. It was a suggestion from this forum that led me to do it.
Peripherals. Not sure what you mean here. I have/had connected pedals and yoke. I have tried every combination from nothing except keyboard and mouse up to everything connected
Thank you for your interest.

Still more replies to come but it seems to be not the cause by Realtek Audio drivers. I personally think it more than that.

Hope lasted only 2 hours …

Hi @ArisenAutumn59

yes, you have right. There is no guarantee that e.g. the power supply realy cause issues and to bought new one because of a “guess” is a riscy. Same for the memory, in special when retailer installed it. My points are thoughts about possible problems with the system, but it is of course not possible in this way to say that this are definitly problems.

Because Peripherals… some users report issues with wireless devices and also some kind of joystick cause for some users problems. Sometime driver, often USB-Hub, rare more as 10 devices connected, more rare cloud-config-storage becomes invalid. Hence the thoughts about possible problems from this side.