Crash to desktop without error message

After updating to 1-15-8-0 I find that I am unable to enter the Options > General screen. Attempting to do so puts me straight back to my desktop, without any error message.

All other Options, together with Profile and Market Place menus seem to work correctly.

My sim flies normally with, I believe, the Option settings that were in use prior to the 1-15-8-0 update. I also have the 1-15-8-0 Hotfix installed but still the problem of accessing Options > General exists.

Additionally, although Content Manager describes any/all addons from within my Community Folder as ‘Not Installed’, they are, in fact installed and are usable in the sim.

To try and correct the problem with Options > General, I have uninstalled MSFS and re-installed but no change. I have re-installed Windows 10 and again re-installed MSFS but no change.

A Copy of the Application Error is appended below :

Log Name: Application
Source: Application Error
Date: 25/04/2021 12:47:41
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: TONY2021
Description:
Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60783c14
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process ID: 0xdb8
Faulting application start time: 0x01d739c8574299d7
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report ID: 31646ae9-347f-498d-963f-0cc22d405381
Faulting package full name: Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Event Xml:



1000
0
2
100
0
0x80000000000000

875


Application
TONY2021



FlightSimulator.exe
0.0.0.0
60783c14
ucrtbase.dll
10.0.19041.789
2bd748bf
c0000409
000000000007286e
db8
01d739c8574299d7
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\WINDOWS\System32\ucrtbase.dll
31646ae9-347f-498d-963f-0cc22d405381
Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe
App

So, although I can fly the sim I cannot change any of its settings!

still up in the air above france but going through a route mismatch obviously, hahah - but that is probably my own armchair pilots fault, hahah

made it \o/

no crash dumps for asobo from me today, i guess

A database is defined as an organized collection of data - “content.xml” does qualify as a database. (more complex data, more complex systems).

In part this makes sense, though I wish MSFS would take inventory and prune unavailable items. It also could be useful if they’d direct us to include it with Zendesk reports of what we have in our data folders. I can see some versioning or locational conflicts with this “outdated” file.

2 Likes

Please search on the forum for what your error is: “ucrtbase.dll”
Search results for ‘ucrtbase.dll category:200’ - Microsoft Flight Simulator Forums

You will find that this error mostly refers to not having the US English Language Pack installed.

I fixed my CTD by disabling windows paging file.
I used to limit the size of my paging file to 2GB only, as I have 32GB of RAM and should never need paging.
MS will allways try to screw your performance by using page file instead of your RAM even if you have infinite RAM.

Thanks but that Language Pack is installed.

Word not allowed, it happened again!! After couple of hours of flight, CTD without any warnings. First time it was CoherentUIGT.dll file which crashed the sim, this second time it was RenoirCore.WindowsDesktop.dll. Both times I was flying with FBW A32NX in South America. Lesson learned: apparently I have to fly just some short flights, maybe an hour or hour and half at the most. Great stuff indeed…

Try without using the FBW A320. I too had crashes using that plane, but none so far using the CRJ. Also, are you using external liveries? I was advised to delete those too.

I do have ivao_x-csl folder in my community folder. I use it to show other planes when I´m flying on vatsim. I do not own the CRJ…

Had a CTD with Asobo A320.

Interesting, I will try this also.

How many hours of flight did you do an experiment?

Mine was crashing 100% of the time at the end of the loading before the flight.
Now I disabled virtual memory and it seem to be fixed.
To check if this is your issue to, in windows open Event Vier → windows logs → system
If your getting screwd by virtual memory there will be a WARNING like this:

“Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: FlightSimulator.exe (15936) consumed 23888822272 bytes, chrome.exe (2460) consumed 458981376 bytes, and MsMpEng.exe (3240) consumed 400093184 bytes.”

I disabled my virtual memory because I have 32GB of RAM.
If you have less than 32gigs, you should increase your virtual memory, not disable.

To disable virtual memory, it’s no enough to set it to zero in advanced system settings you have to use the cmd command:
fsutil behavior set encryptpagingfile 0

1 Like

I’ll try, it’s the only thing I haven’t tested, with virtual memory.

Make sure to report the crash to desktop to the FBW team as i’m also getting a CTD with CoherentUIGT.dll. It seems to be the FBW A320 causing the crashes. I was doing a flight from Los Angeles to Vancouver and then experienced a crash so I checked my event viewer and sure enough CoherentUIGT.dll file was the cause, this is the second time now today on the same flight with the FBW A320.

Yesterday’s tests:

  1. Tried to launch MSFS, crashed with GPU driver timeout and vcruntime140.dll at the millisecond where the initial loading screens fade to the main menu.

  2. Second attempt, same crash.

  3. Third attempt, managed to reach the main menu, CTD 5 seconds later with the same errors.

  4. Fourth attempt, success. Call me crazy, but I have the feeling that if I click the mouse wildly and move it around while MSFS is ready to transition from the loading screens to main menu, then it usually doesn’t crash. It doesn’t make sense but I’ve seen it happening so many times that I use it as a placebo “workaround”.

So I loaded the JustFlight Piper Arrow and literally let it there parked at the apron for 12 consecutive hours, while I was writing new improved checklists and programming my Bravo with spad-next. I knew that MSFS wouldn’t crash no matter what I did, how many apps I launched or how many times I switched back and forth to Windows.

Then I restarted the flight session, completed a 1-hour flight, returned back to the main menu and… CTD.

  1. Another attempt to load MSFS, worked OK. Loaded Asobo default Diamond DA40 to test some things at a different location, 2 minutes into the session while I was preparing to start up the engine and… CTD.

So it seems that some aircrafts CTD all the time, from default types to CJ4 WT. While with some others I’ve never seen a crash, e.g. default C152/172, Piper Arrow and so on.

I seriously have no idea what’s going on. It can’t be the addons or the community folder or the hardware itself, because I’m not changing anything between these attempts. It’s gotta be the software. Today I’ll try to replicate using the same location for both aircrafts that CTD and those that don’t.

ps: spad-next takes mapping configs to a whole new different level, I’ve managed to map almost every important function of the Piper Arrow via LVARs and it works like a charm. No more mouse clicking left and right.

1 Like

I also suffers from crash to windows without error message.
Happens now from time to time, have no clue on whats going on.

Checked the temperatur and work load of the computer but it feels just great :slight_smile:
Upgraded to 32gb of RAM (from 16) but no diffrens.

Intel I7 with a 2080 so It should work just fine…

What do you mean by “crash to windows without error message.”

Because after each crisis there is usually a message in Windows Event Viewer. This not because there are no messages that appear, when you come back to the desktop, that there are no messages

I CRASH two times after 15 minutes, with the two same error messages… GPU driver timeout and vcruntime140.dll
6800XT, 5800X, 32gb ram,1TO nvme specially for msfs, i m disppointed. is windows10 update last night ?