Crash to desktop without error message

TBH if it started so far back and you’ve tried all the fixes then I suspect it’s your system.

Start by making sure your drives are not too full and are optimised and make sure virtual memory is set Windows managed. Then check in bios that virtualisation is turned off, you may need the mainboard manual to recognise it. In Windows advanced power settings set for high performance.

Since SU5, i’ve reinstalle windows twice and msfs 3 Times, I’ve also tried every fix I’ve found on this forum.
The CTD happens usually After 1h of flight, night/day with/without ai traffic.

Since SU7 the general performance of the game seems better on m’y system, but I’m really running out if Idea…


It can take that long and more for some components to overheat so if you have overclocks tweak them down a notch, especially voltage.

Thanks for your answer, my CPU seems not overclocked,for my gpu i also tried a 3% undervoltage and clocking on MSI afterburner, actually everything IS set to Factory setting.
My setup :
MB : Asus x570plus
CPU : AMD ryzen 5 3600x
Gpu : MSI rtx 2070s 8gb
Ram : 4x8go corsair Vengeance 2133ghz
2 internal SSD : one for the os, the other for msfs
2 harddrive : 1 with a windows 8 partition, the other one for stockage
Thrustmaster tca Airbus hotas + Addo
Power supply, corsair bronze 80, 550w, I’ll Switch to a 750w tomorow, seems short…

NVIDIA control panel : débug mode enabled and FPS limit set to 30 for msfs.
Virtual memory is manually set, 50g on each SSD
Windows IS set on max performance mode, game mode IS also on.
English voice IS installed on windows
Windows 10 IS up to date, AMD chipset and gpu drives were updated yesterday

And other things I see on this topic but I dont remember the exact english words for them.

A Friend will give me another pow er supply tomorow, WE will see !

Good Luck to everyone

1 Like

I think you will be happy with the change. Usually a failing/underpowered PSU will crash Windows too however I suspect yours is right on the border and only starts spiking when it gets hot.

I bought my PC completely new in summer 2020 and it is enough empty space on HD, it is always updated on the newest level, i7 with 16GB RAM, 1 TB SSD + 2 TB HD, RTX2060.
So it is definitely not my PC and before the november 2020 patch I in 3 month never had any CTD.
As I wrote it is better now with sim update 7 but the CTD-issues are not solved completely (especially CTDs coming with live traffic activated but single player mode). Even my community addons are always on the newest patch level. I already found wrong configurations in community liveries that I’ve fixed - so it’s not always the sim but too Asobo can’t always blame the community addons and then sit back and relax and ignore the many people having a lot of CTDs with msfs 2020.

To help finding and fixing the issues I have added a votable suggestion:

(" Debugging and Crash Report Log "


Not yet flown to SU7. CTD by - Fly Now Exception Code: 0xc000001d. I’m not going to get involved in troubleshooting and try anything. Unbelievable what Microsoft and Asobo deliver and that even though it has supposedly been tested. Bye, Bye …


Then there’s not much point reporting it either. You’ll get more out of the forums if you do a little leg work.

Searching for that error code shows many other titles with the issue, and the possible causes quite varied, from out of date GPU drivers, to missing OS files.

You could do worse than update your GPU driver, and run “sfc /scannow” from an elevated command prompt.

It would also be worth reviewing you Community mods for SU7 compatibility. There always seems to be a spike in crash reports shortly after an update is released, where devs. are battling to upgrade their mods.

1 Like

Exactly that. There are almost 5800 posts in this thread alone, not to mention dozens of others across various MSFS forums. Among all these comments, there must be about a hundred different proposed workarounds where the fault was with a gazillion different things (from overclocking, to faulty hardware, to outdated BIOS, to Windows settings, to old VB/.NET framework versions, to GPU/audio/chipset/other drivers, to problematic addons, to MSFS internal settings like ATC, traffic or voices, to God know what else). Or the fault was never find and the CTDs were diminished by some random and crazy change or are still ongoing.

On top of all that, we now have CTDs on Xbox. Maybe not consistent and definitely not for the majority of the user base, but there is still a significant number of CTDs on a frigging gaming console. Which is unheard of (I must have had no more than 5 CTDs in all my years of console gaming from NES and Sega Mega Drive to the latest generation of consoles). And that’s more than a year after MSFS has been released.

In all my gaming and simming years, I have never seen such an unstable title. It’s as simple as that.

At the very least, Asobo should have introduced by now some proper and automated way of creating and sharing crash dumps, rather than asking users to send often unhelpful Windows error reports to Zendesk.


Consoles can get fluffed up, internet can be flaky and storage overfilled too. The fact that thousands of Xbox MSFS users are not on here complaining tells me your problem is probably one of these.

Sure, let’s put the blame on the end user again or his/her console. The fact that no console (or PC) game should ever crash if internet is flaky or storage overfilled can be disregarded. Because there’s no such thing as error handling in software.

1 Like

I just did :sunglasses:

Another update and sim is broken again, mouse and flight control hell - not working as usual. Just another mess which I have to sort out again in the next couple of days.

However, thanks for the Pilatus, but I can’t fly it due to controller issues - the throttle not working, perhaps some sort of control interference with each other.

I’ll probably be the 2,000th person on this thread to post this, but I just got my first post-SU7 CTD. No error message. No OC’ing or tweaking of the PC of any kind. Here is the error message:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001b1a80a
Faulting process id: 0xf18
Faulting application start time: 0x01d7e0a277955a40
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: ba5d6319-f269-4511-b9c9-d503068ffddc
Faulting package full name: Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Any ideas?

So up until a couple days ago I hadn’t gotten any CTDs in SU7. Then I made a change. At this location:

C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe

I right-clicked FlightSimulator.exe and clicked Properties->Compatibility and checked “Disable fullscreen optimizations”. I read somewhere that this was a performance benefit.

Just went back and undid that, flew the same flight that just crashed without problems. So who knows.

My first CTD in over 100 hours of flying (since I turned AI traffic off).
Also my first post-SU7 CTD.
This makes me a bit worried.

C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

For all those who have made their su7 installation via ms store, you should try to start the FS2020 via the xbox platform. I did. After I had clicked through the routines, the fs2020 started normally. I previously got a cdt when I clicked on Start Flight.

ha ha ha!!! this topic has been solved!!! no topic has not be solved. Since SU 6 I have CTD without any reason after 5 - 10 minuts of work, it’s impossible to play. I tried all solution, it’s doesn’t work.

1 Like

Just like everyone else my desktop computer crashes especially when flying the F-18. Furthermore, the flaps, rudder, and other control surfaces no longer work properly. This just started after the “Years Best Game” update about three days ago. MSFS 2020 is now useless and cannot be used. I would have expected better.


Yep. No addons in community folder, everything is updated, clean Windows install, no other programs in my PC. CTD in 30 minutes. Did all suggest troubleshooting steps, CTD in about 50 minutes.