Crash to desktop without error message

Yep! I got a CTD today too. Seems like a server issue as I have done nothing to the game! I hope they fix this issue! They need to know that this is mostly related to their servers and how overloaded the servers have gotten (or how slow they are)! This game is not worth playing with CTDs.

Seems that CTD reports are always on the rise just before a world or sim update.

My theory is they’re changing things on the server side in preparation for the updates or they’re already testing out some of them.

1 Like

Another CTD while taxiing to park in EDDP this time, thankfully towards the end of a 3-hour flight so the crash didn’t matter much. It still fit the pattern of CTDs immediately before/after landing in various airports.

AIG was off as I only had multiplayer, live traffic and VATSIM on. For good measure I removed AIG’s cached data from Community folder after the CTD. Let’s see what happens next time.

Another disappointment was the huge framerate hit as it gradually changed from 60 fps to 40 with lots of stuttering, possibly due to overcast and rain. It doesn’t seem to be directly related to my 6800XT’s performance as loading the airport from scratch with the same weather conditions works a little bit better than 40fps. It’s as if performance is gradually decreasing after X hours of flight.


After Install of 22.1.2 started experiencing CTD in flight only.

Removed 22.1.2 and re-installed 21.12.1. = No CTD.
( 21.11.2 where stable also )

May be specific to my set up, but if your AMD GPU and suddenly experiencing CTD after 22.1.2, suggest you try this 1st.

1 Like

I’ll give it a go. I keep getting CTDs since version 22 of amd drivers but not sure if its the cause.

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001b22bba
Faulting process id: 0x1350
Faulting application start time: 0x01d8187f7b3d1a4f
Faulting application path: D:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: D:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: 595f4f2c-873d-4f92-86f1-11a460ae8faa
Faulting package full name:
Faulting package-relative application ID:

Hi, I keep getting this error, I can’t even get into a flight lol.

Do you have an antivirus program running?

Hey I fixed my issue it has to do with a setting that reset in the options page within the dev mode for the a320nx been running fine since.


After doing some online searching I see this particular CTD without an error since August 2020.
From EventViewer, people have pointed out the Exception code: 0x0000005 which has indicated a whole range of fixes. Re-install Windows, MSFS2020, don’t overclock and the list goes on.

I have only recently been experiencing this CTD and tried re-installing MSFS2020 as a fix. After doing so, the crashes still occurred, happening between 5 and 20mins.

This is the only game I’m getting this CTD error which tells me it’s something Asobo needs to fix, not us!

A temporary workaround I have found that works is to reduce your FPS to 30.
I use MSI Afterburner (Specifically RivaTuner Statistics Server which is also installed with it) to limit my Framerates to 30.
I tried doing this in game by using the V-sync option and 30fps but it didn’t work.

Afterburner (

Once you have MSI Afterburner installed, go to your taskbar right hand side and open up RivaTunerStatisticsServer (Click on the screen with the pink 60)

Once RTSS is open, set your Framerate limit to 30 (See pic below)

Since changing the FPS to 30, I have had MSFS2020 running for 2 hours without a crash.

Note for Nvidia users - I’m using the latest Nvidia drivers (511.65) which along with the previous (511.23) ones caused these CTDs. Others have said using driver 497.29 has helped them resolve this issue.

Hi Ex,

Check out my post below yours. I had exactly the same error message and fixed it by reducing my fps to 30 using MSI Afterburner.
Asobo need to get their act together!

Why blame Asobo when Riva tuner is a known problem? … as are gpu overclocks

1 Like


short note: MSI Afterburner is not necessary if you need this only for limiting FPS. Doing this is possible within nvidia control panel ( foreground and background fps ). Then you can be sure to not run into any other issue caused from RivaTuner.

( I assume ATI have similar setting within the ATI tool. )

U can limit FPS in the Sim.

not exactly … if you have e.g. a 144fps monitor, the possibility of limiting the fps with Vsync-Setting will be “limited” :wink: ( the values match only for a 60fps monitor ).

Good point :slight_smile:

It’s broken. I’ve reinstalled msfs, gfx and audio drivers, and now reinstalled windows, and I have nothing else installed except MSFS on a fresh windows install and it crashes after 10 mins with 511.65. It’s not the drivers though, everything else was and has always been working fine. I’ve literally spent all my spare time this week troubleshooting. In 15 years of PC gaming I’ve not experience any software as unstable as this. Going to try 497.29 as a last ditch effort and if it crashes with that I am swapping to x-plane and will come back to msfs once it actually works.


Will Ctds ever going to be fixed PC and Xbox?

1 Like

I’m not saying you have but this is typical behaviour of overclocks or heat issues. Even factory gpu overclocks are not guaranteed to work for every game or programme.

1 Like

Thanks for the suggestion but definitely not the case, doesn’t consistently crash after 10 minutes, it’s quite random. I also have my fps limited to 30 fps and it crashes independent of processing load (NYC vs middle of desert = no difference). I’ve been troubleshooting for a week now and it’s impossible to pin it down to one variable, but it seems to be something to do with how MSFS is interacting with display and/or possibly audio drivers. Have submitted a ticket.