CTD fix info

For those having any CTD issue/s try the following…

Run the following commands…

Go through each of the following steps one at a time. Copy each line, one at a time , paste it into the Dos window (crtl + V) and press return

and it will then run. Wait until each runs and finishes before you move on to the next one.

When you are completely finished, Restart your computer and then try to see in MS2020 will start and run properly

Dism.exe /online /Cleanup-Image /checkhealth

Dism.exe /online /Cleanup-Image /scanhealth

Dism.exe /online /Cleanup-Image /Restorehealth

sfc /scannow

Dism.exe /Online /Cleanup-Image /AnalyzeComponentStore

Dism.exe /Online /Cleanup-Image /StartComponentCleanup

RESTART your computer as the last step. Then go for a test flight.

If that does not resolve the CTD issue/s then follow…

Thanks for taking the time to put this together. This is good information.

1 Like

No problem. I began having CTD either in the menu or a few mins after beginning a flight. It was flagging the ntdll.dll file in Windows event viewer. I went thru the suggestions I aforementioned and it wasn’t until I did the Windows refresh it resolved the issue. Just finished another 40 min flight with no CTD (Grants Pass, Or. - Crescent City, Ca.)

1 Like

The jury is still out, but there’s every indication (3 days in a row without a CTD) that you’re procedure fixed my MSFS problem after many weeks of the frustration of intermittent random crashes around the ntdll.dll. So, thank you!!!

No problem. I had to run those commands the other day again. It seems Windows corrupts during an update process at any point whether it be Windows update/s or MS Store update/s etc…

So not a one-time thing. Good to know!

no, but I did only run…

sfc /scannow

and it did say it found and repaired corrupted file/s.

Then reboot PC.

Thank you udidwht … that’s also partially solve my many CTD !
I find 3 corrupted files with the line sfc/scannow
Me too from january I have multi CTD every day, 2 … 3 by day,
With your method, now I’m not CTD in Menu !
For my other CTD in the game, …
I see in my config windows ( graphics settings ) an section, “choose an application to set the preferences” / “Microsoft store application” / and find Microsoft Simulator setting on “Hight Performance” !
This apparently makes the simulator completely unstable! I deleted this profile and left windows managed, the game may be a little less efficient but I found all the stability and no more CTD now !!!
I come from 2, 3 CTD by day to 0 CTD now from many day …

I also find a another problem with the file “Content.xml”
( Packages/Microsoft.FlightSimulator_8…/LocalCache )
If you regularly add or remove content from the Community folder, it seems this file does not update correctly ! Simply by deleting this file, MSFS recreates a brand new and correct one the next time the game is launched !
Now, not have any CTD from 1 week … ( Sorry for English )


I do not have MSFS in the “Graphics performance preference” list. If you do, it should be set to ‘Desktop app’ rather than store.

One other thing I do after an update and/or add something in my Community folder…clear the DirectX cache and delete the cache within MSFS and rebuild it.

From yesterday update, that’s again CTD CTD CTD in the first 5 minute after lauch the sim …
Before this update, the method descipt here run well and solve my CTD, but from this world Update 8, that’s starts again !
How do you clear the direct x cache ? ( My comunity folder are empty and no content in the MSFS cache data area )

Thanks @udidwht for the info on doing the in-place Windows update while keeping files and Apps. (Windows Media Creation ISO stored on your PC.)

Just did it on my Win11 PC due to some CTDs after WU8 on FS2020.

Edit: Only took 15 minutes. to update Win11.

To clear the DirectX cache…

Open explorer and right click on C: then click properties. Then click disk cleanup then check mark the directX shader cache box then click ok.

Anytime Windows or MSFS get an update/s I run those commands (minus the Windows refresh)

1 Like

Heya, I jumped in this thread to say a huge ‘thank you’ for the tip of using sfc /scannow (I have Win10)

In the past week I started to have CTDs almost every time I fired up MSFS, after months of playing the sim (since January 2022) with no CTDs

After several trials with no result (switching off XMP in bios, changing the wifi adapter, empty Community folder, etc) I found this thread and, as first try, did sfc/scannow and CTDs seem to have gone

I am back after 2 hours of several flights, Maverik races and stratosphere, bush trip in Italy, free flight over dense cities in aerobatic to stress the sim … no CTD!

Crossing fingers it will continue to work, what surprised me is that sfc /scannow has found and repaired several corrupted files, still I am 100% not to have messed with Win10 … how the hell these files were damaged is beyond my understanding

All the Best


You should do the file check after Windows offers update/s. Often times Windows will gork an update during the download/install process. Does this to me as well.

1 Like

about sfc /scannow i never believe is possible to be exist any corruption files if not lightning hit the pc or emp bomb will explode or whatever it is i believe even if it happens it’s not will ony ctd it’s kill system. but… couple a month ago i use this sfc /scannow and it’s find some… so i use this some time for conservative idiots like me with stone brain only…

Sometimes things dont work well …but what always comes as one of the first :

sfc /scannow …

even if the problem is caused due to a broken power cable … always sfc /scannow.

I never solved any problem with those 3 “supports-first-love” ones … nor had any results when running them…
computer says no.

1 Like