Crash to desktop without error message

I don’t even have an anti virus installed and Windows defender is turned off :smiley: That’s probably not the problem

I have a similar problem.
Whenever I click fly and it loads to about 80%, audio stops and then it crashes to desktop.

I checked my event logs and see this:
Faulting application name: FlightSimulator.exe
Faulting module name: VCRUNTIME140.dll

1 Like

Same error! I have two pcs with identical windows builds. My main one is Ryzen 2700X 48 gigs of ram and 1080 ti. The game crashes everytime on it with eventlog showing the error to be ucrtbase.dll. The second pc is old dell workstation with double 12 core xeons , 24 gigs of ram and R390X. No crashes there. But the gpu is bottlenecking and cannot play at FHD and over cities it stutters. This is the situation ever since 1.16.3 and persists with release build. Done all sort of uninstall install vc libs, sdk even old dx libs to no result. Ran the game as admin still crashes. Even done sfc and dism scans. All are OK. Done selective boot and disabled a lot of stuff and still ctd after FLY button in loading screen. I would be grateful if someone can share a solution or workaround. I sent many Zendesk tickets. They return the same auto response. Thank you in advance.

Yeah, the antivirus is just a wild guess on my part. I get no crashes with live weather and traffic enabled, so that seems to work. Still, in my case, it’s the data streaming that causes the CTD. I’ve submitted a ticket with the crashlog.

What Ram speeds are each machine at?

it keeps crashing for me every fking 30+mins , i run 8700k GTX 1080, XMP enabled to 3600mhz. 32gb , KEEEPS CRASSSHING

Mine at 3200 (no OC)

Ryzen - 2666 mhz - 16 / 17 / 17 / 36 / 60 / 1T
Xeon - 2000 mhz - 9 / 9 / 9 / 24 / 74 / 1T

I can confirm that the ucrtbase.dll error is connected with online data streaming. Tried to do manual cache and the game crashed when zooming out of the map.

2 Likes

“Tried to do manual cache and the game crashed when zooming out of the map”
I see the same behaviour on my machine.

1 Like

I’m currently running tests. I’m trying various flight conditions and just sitting on the same runway for 30 mins. I’ll report back if there is a combo which is contributing. I’ve heard of AI traffic being an issue.

Update: crashed again with AI traffic turned on. It took 10 mins to crash - maybe when AI traffic was spawned in. I will continue to stress test

Hello friend, I have the exact same problem. When I launch the game, it checks for updates, then crashes on the loading screen while showing the Cessna Skyhawk. I have tried everything but cannot fix it. Note: Short before crash the screen flickers and the sound becomes distorted.

Crashing with no crash error. i cannot fly more than 10-15 mins. The sim crashes, been happening from installation till now. PLEASE FIX THE CRASHES, I’M RUINING MY HOLIDAYS

7 Likes

Tried with XMP 3600MHZ and XMP disabled 2133. In both crashing AF

This issue started with beta. Previous alphas I had no issues. No crashes… it was reported since 17 July and developers haven’t replied or corrected any issue.

i9900k
Rtx2080ti
32mb ram
Sod
Win 10 2004
Ms sidewinder stick
Logitech headphones and mouse. ( they mention Logitech hub interference but it’s removal hasn’t made a difference)
Increasing virtual memory size helped this much that crash to d occurs after take off.

I’m also seeing crashes when I press esc

With AI turned on the sim was fine for half an hour sat in a parking zone. Press esc and it crashes to desktop

I’m struggling to find a steady pattern

Its the game, its not your PC, its not Software, its the game, nothing makes a difference, nothing works, so its definitley the game, these fixes are just timewasters.

Every single game under the sun works on my PC except this one.

10 Likes

For me the pattern is all the same.

  • Start - select flight - press fly button - loading - CTD
  • Start - manual cache - zoom out - CTD

This is my current crash patterns. Its always Ucrtbase.dll

4 Likes

I am with you my friend have Game Pass have many games on Steam. Even Star Citizen does not CTD - only server crashes. Feels bad I got the premium deluxe edition. But I will be patient and wait for patches. Hope there to be one soon. But the error for me is since 1.16.3 and the current version is 1.17.4 which means that they fixed other stuff with the 17 major patch.

CTD’s all over the place, when choosing aircraft, when loading airport, when clicking fast through the interface menu. Using Ultra settings.

ASUS ROG STRIX X299-E Gaming II Motherboard
Intel Core I9-10900X 3,7 GHz not overclocked.
NVDIA G-Force RTX 2080 Super.
Corsair DDR4 Vengeance LPX 32 GB