CTD after May update, cant even go beyond logo loading screen

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. Nope

Are you using Developer Mode or made changes in it? Nope

Brief description of the issue: before May 2nd, which was my last time I played everything was fine, then an “optimization” update came by and the game now is dead, cant even load beyond logo screen

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue: lasted

Are you on the Steam or Microsoft Store version? steam

Have a look in your Windows Event Log, under “Applications”. Look for errors there. You should see something like this:


In the lower window, what do you see next to:

Exception code:

Hello! thanks for the reply

The Excepction code i’m gettins is 0xc0000005

And you are certain you have no mods installed? That’s the access violation error, meaning the sim attempted to access memory it shouldn’t.

In my case this was down to an addon, one of two at least, and by removing them both the sim stopped crashing.

Well at the end I did delete the community folder again and still nothing, dunno what really is the case.

I also updated the nvidia drivers and my PC, I could load to the Paris screen but after a few seconds it crashed.

I’ll try reinstalling the game again to see if that fixes everything if not well… guess I will wait for an update, if there ever gonna be one for this problem…

windows just had an update, did you by chance update your pc?.. this is becoming a trend lately.

Please post the crash details. There may be an obvious clue there.

Yes I did, just recently updated my PC and still CTD

This is the Windows Even Log details:

Nombre de la aplicación con errores: FlightSimulator.exe, versión:, marca de tiempo: 0x00000000
Nombre del módulo con errores: FlightSimulator.exe, versión:, marca de tiempo: 0x00000000
Código de excepción: 0xc0000005
Desplazamiento de errores: 0x0000000001c5c3b7
Identificador del proceso con errores: 0x7f8
Hora de inicio de la aplicación con errores: 0x01d74841cfb89d66
Ruta de acceso de la aplicación con errores: E:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Ruta de acceso del módulo con errores: E:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Identificador del informe: 68abebf3-0d2b-4bb2-9b33-ea688db71639
Nombre completo del paquete con errores:
Identificador de aplicación relativa del paquete con errores:

Unfortunately, this is not enough to spot something.

If you are are OK with modifying your registry (very slightly), please add the following two keys:

This will create a crash dump of the MSFS app with additional information.
After it crashes again, you will find the dump at this location:
C:\Users\<your account>\AppData\Local\CrashDumps

After, either you send it to me or you install a debugger to check the information.
The debugger “WinDbg(Preview)” is free on the Microsoft Store. After installing it, you will be able to open the dump and see the cause of it.

no, what i meant was if you just updated windows that could be the cause of your crash. each windows update has been subsequently causing crashes to the sim as of late. not sure why MS and Asobo can’t communicate with each other on these things but one hand seems to break the other frequently. try rolling back your windows update and see what happens

That’s an access violation error, which was the one I got all the time.

What community mods do you have installed? I my case it was having both the 530/750 mods installed on the Arrow. Taking those mods out “fixed” the problem. An update is coming at the end of this month which may fix this problem.

I haven’t had a crash of the sim since April 25th, which was literally impossible before.

I will try this and then send back what I found

Even before the recent update I keep CTD, my crashes are since May 2nd and I just recently updated it yesterday and still, what I will do now is do a clean uninstall and downloading it back to see what happen

I think an airport from Brazil was doing the CTD but I deleted my whole community folder and still CTDs

Just a brief update about the situation.

I tried do a clean uninstall and now I cant even install and download the game, I can download the 700mb launcher from Steam but when I try to download the rest of the game from the game it keeps me CTD before the Paris Screen.

Guess i will wait for an update…

no info :thinking:

You own 16GIG RAM only ?

what does this mean ?.. you mean only updates or also hardware changes ?

With new hardware may be there is now a conflict with the existing settings which cause the ctd. This cases we had sometime in forum.

PC specs are:

CPU: Intel Core i9-9900k
GPU: EVGA Founder’s Edition NVIDIA Geforce GTX 1080/8GB GDDR5x
Memory: DDR4 32GB 3200 Mhz
HDD: Seagate ST3 1TB and Seagate ST3D 3TB
OS: Windows 10 PRO 64-bit
KEYBOARD: Razer Blackwidow Ultimate 2016
MOUSE: Logitech G502 Proteus Spectrum Optical Gaming Mouse
WATER COOLING: Corsair H100i v2

And by updates I mean windows updates, I haven’t changed any hardware recently. I did update my graphics drivers to the most recent ones


hmmm. Then pagefile size seems possible not the issue, but please check the main drive related to free disc space… lot of users run into trouble because there is not enought free space on main drive ?

Not less cases in which allready the download will fail was because of anti-vir tool. Have you tried to disable it for a test ? Otherwise the xbox login should be checked , e.g. within the xbox app.

Hi there :slight_smile: exact same problem. I did post bugreport to asobo minutes ago…
I got ms store version. I started sim after couple of days, and… crash. Last week or two i think there was no problem. Cleared everything, no community, unloged/loged from store/xbox apps, even from this forum :slight_smile:
i7-9700kf, 32GB, RTX3070, Rift s, T.Flight Hotas X…
latest drivers, updates… tried reinstall vc runtimes…
btw i tried to unistall latest win update (KB5003173) but this was not the culprit. But i see one that it cant be uninstalled: “Servicing Stack 10.0.19041.985” - have you guys this installed and have working msfs?