Ctd again

Brief description of the issue: using the sim for a hour and it ctd event viewer says this FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

Any fix for this ?

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

Don’t know if this will help you but for me tuning down Volumetric Clouds to medium solved all my random ctd’s that I was getting

What are your specs ? I dont think that will solve my issue .

32gb ram

Mostly all set on high and ultra except Volumetric Clouds
Getting between 30 - 70 fps

With the Volumetric Clouds
Ultra gave me a CTD at least once an hour
High sometimes causes a CTD when pressing the escape key mid flight to pause the game
Since setting to Medium I haven’t had a ctd for 2 weeks

But hey even if we have different spec it’s a very easy option to try and see if it solves your problem
Just one more thing to tick off your list of possible causes that others have noted!

Regardless, always share your specs, overclocking, mods, and settings used during CTDs.

yup, a buddy of mine solved his CTDs by reducing graphics settings as well.

I have a 1770k .
1080 ti
Memory 32 gb .

My settings are set to high . And clouds on ultra .

Whats your advise ?

Do u have your fps locked in nvidia panel ? Let me know what u did frames ? Is it locked or just using the sim to whatever fps u get . Thanks

My Nvidia panel is mostly set to defaults with Prefer Maximum Performance at least.
No caps or limits forced, especially when using Gsync.

I ran an older version of MSFS on a similar setup with Ultra preset fine so you shouldn’t have issues unless running 4K.
64GB ddr4
GTX 1080 Ti

I can’t really relate on the latest build due to new PC.

Try without overclocking if you are.

for some reason setting up a profile in the nVidia control panel is not applied to the game so I’m only using in-game settings at this stage until I solve that problem

In game I now use vSync at 60fps (my 1080p monitors native frequency)
So with vSync on I get between 30 - 60 fps

60-70 fps is only achievable for me if I’m flying the Cessna 152 (a plane that doesn’t have any Garmin displays) over a low density area; when I hit a high density city that drops to around 45fps

Using a GA plane that has garmin displays costs me around 10-15 fps

I don’t fly airliners so I have no idea what fps I’d get with them

May advice is set your Volumetric Clouds to Medium and try it out; they still look pretty good

Ultra looks sweet but no ctd’s is sweeter LOL

To be fair recently I was getting CTD’s when in the sdk I turned the terrain level of detail slider down and not had another CTD since.

I should mention that I’ve left my LOD set at 200 but I know that It costs me 10-20 fps compared to 100

Using all High

Will turn of fps limiter in nvidia panel and use high for cloud . Let me see if this helps .

Do u have any pc experience with memory in bios ? I got a a asus board . Let me know

Depends, are you intending to overclock or on stock clocks?

If you have been overclocked during the CTDs, I would revert to stock and test. OCs can appear stable in many games yet produce unstable results in others.

XMP profiles apply a predefined OC, XMP I seems to be the most stable of the two options.

Overclocked memory . I will test when i bring it down . Hopefully i fix this issue

1 Like

i have similar specs expect im with i9-9900k but anyway, in-game ultra preset all maxed out and had yesterday 4th CTD in 250h history and it happened when i moved a bit too far in VFR map.
btw im not using recent nvidia drivers

I am
Not sure what to do .

Are you using any 3rd party software at all?, apparantly they are aware that simconnect is currently causing CTD’s and hope to get it fixed by the next update next week