CTD as soon as Microsoft login window appears

Are you starting MSFS as an administrator?

I’m not, I think I tried that yesterday (it was on some thread I was reading) but not every time. I don’t recall it making a difference but I could try it again.

1 Like

I would try that.

AS well, are you on a wired or wireless connection?

Wired ethernet. My laptop is on WiFi and has had no issue thus far interestingly. Almost makes me wonder if I should try wifi on my desktop to rule out my network card?

ah… I thought you had former a different anti-vir tool and only disabled it for the moment. Defender should no longer cause issues, but we can never be sure :rofl:

You think a faulty network card ? … hmmm… hmmmm… I guess more a hidden driver update :rofl: … is it Intel network chipset ?.. They have new drivers… But its bit riscy to change to many things in parallel.

The RAM, may be… users often report issues in case XMP mode… but I understood it worked fine before.

You mention “power outage”… it can leave file issues, but you done sfc /scannow ( and dism ? ) check.

Some users report sometime that re-installing windows from scratch fix here issues. But this points for just the what we guess “a file , a settting , …” cause the issue which we not know.

I did sfc /scannow, no issues though the last time I ran it (about a month ago) it did find and fix some issue. DISM didn’t find any issues.

When I first bought MSFS, right at launch, it installed but would crash after clicking Fly Now 100% of the time. I was only able to solve that by fully reinstalling Windows after around 16 days of troubleshooting with Asobo support. After that it ran mostly problem free until the past month or two when problems started creeping up, culminating in this.

I’m wondering if you have some bad sectors on your hard drive.

1 Like

this I meant… the tool found often issues in this time range. Not sure why…

If a full windows re-install is necessary, something ‘runs wrong’ and it is like a “we not know what the reason is” - thing. I installed windows one time, thats it… It is a OS and we should able to fix all issues without re-install. On other side is a re-install just easier and quicker…

@TheSevenflyer yep… chkdsk is already in todo list :slight_smile:

1 Like

one point ( again one for “to be sure”, and why I asked about google add-ons ) is to check the hosts file. May another tool changed somewhat in it, like the google-maps addon do it.

I checked my hosts file, it’s still the Windows default though.

I also for curiosity’s sake tried switching on wifi and unplugging my ethernet, since my laptop had no issues on wifi (it downloaded the entire sim, so I will be transferring the files later tonight), but alas the sim crashed within a couple minutes of downloading, so the issue is definitely not my internet (wired or not.) The problem feels very likely to be another component or program.

I’m thinking that in 2022-2023 I will set a goal to have a fully dedicated flight sim PC. It’ll have NO other software, just the operating system, the sim, and the addons and a minimal number of them at any one time. On that machine I would set system restore points before making any changes to drivers, etc. Because the computer with all the issues (the one I’m writing from) is the one I use for nearly everything, it’s very hard to keep track of all the tiny little changes from day to day that could be contributing to this problem.

I will probably try a Windows reset/refresh before a full reinstall if possible. That’s what I did last time and it was successful.

Being a flight simmer is a heck of a chore sometimes :expressionless:

That could be possible, though I did run two diagnostic tools (Sandisk’s SMART diagnostic and CrystalDiskMark and both seem to think my drive is healthy. I did update the firmware because there was an update available, but no change.

As of this morning, I do have all of my files transferred from my laptop. The sim loads, but it crashes very frequently even at the menu. It also crashes when downloading other things (world updates, marketplace addons, etc.) Not always, but most of the time the sim just disappears without an error.

In Event Viewer, I am seeing two main errors: FlightSimulator.exe crashing with the typical error code, but I’m also seeing quite a bit of this one, which I never used to get: CoherentGTCore.dll

That gives me a clue at least. Off to do more digging.

1 Like

Oh another weird development: With the recent constant CTDs, the sim will crash MS Edge and Firefox. It’ll crash nearly any other program running in fact. This has never happened to me in the entire time I’ve had the sim (since launch.) I’ve always been able to multi-task. Heck, I used to routinely have Netflix or YouTube pulled up on a second monitor while flying, no problems. Now my whole system becomes unstable when the sim is running.

1 Like

ähmmm… all off these sounds realy strange… I assume, if Edge or Firefox crash, it can points to the GPU , because normaly “Hardware acceleration” is enabled. But of course, can not be sure… It sounds similar as you mentioned former it let creates artifacts while looking videos.

Did you executed “chkdsk” command in meanwhile ?

A link to a post that has some good articles linked in it.

I checked again to be sure but can confirm I’ve done all of that.

1 Like

I ran it on both my C: (system) drive and G: (flight sim installation) drive, same result, no errors:

The type of the file system is NTFS.
Volume label is m.2 lower.

WARNING!  /F parameter not specified.
Running CHKDSK in read-only mode.

Stage 1: Examining basic file system structure ...
  939264 file records processed.
File verification completed.
 Phase duration (File record verification): 3.95 seconds.
  421 large file records processed.
 Phase duration (Orphan file record recovery): 1.41 milliseconds.
  0 bad file records processed.
 Phase duration (Bad file record checking): 1.79 milliseconds.

Stage 2: Examining file name linkage ...
  1476 reparse records processed.
  992308 index entries processed.
Index verification completed.
 Phase duration (Index verification): 7.44 seconds.
  0 unindexed files scanned.
 Phase duration (Orphan reconnection): 420.88 milliseconds.
  0 unindexed files recovered to lost and found.
 Phase duration (Orphan recovery to lost and found): 1.60 milliseconds.
  1476 reparse records processed.
 Phase duration (Reparse point and Object ID verification): 9.64 milliseconds.

Stage 3: Examining security descriptors ...
Security descriptor verification completed.
 Phase duration (Security descriptor verification): 1.68 milliseconds.
  26523 data files processed.
 Phase duration (Data attribute verification): 1.60 milliseconds.
CHKDSK is verifying Usn Journal...
  40289296 USN bytes processed.
Usn Journal verification completed.
 Phase duration (USN journal verification): 146.24 milliseconds.

Windows has scanned the file system and found no problems.
No further action is required.

 976744447 KB total disk space.
 661265872 KB in 327056 files.
     90924 KB in 26524 indexes.
         0 KB in bad sectors.
   1075127 KB in use by the system.
     65536 KB occupied by the log file.
 314312524 KB available on disk.

      4096 bytes in each allocation unit.
 244186111 total allocation units on disk.
  78578131 allocation units available on disk.
Total duration: 11.99 seconds (11990 ms).
1 Like

then we have only these dll… but so far I remember , these stands for strange issues as well :-/

My MSFS experience lately:

2/12/2022 - Fully uninstalled Microsoft Flight Simulator
2/12/2022 - Deleted all Flight Simulator AppData
2/13/2022 - Attempted to reinstall Microsoft Flight Simulator (unsuccessful - CTD, download looping, stuck decompressing)
2/13/2022 - Attempted to install the sim using WiFi instead of ethernet connection (unsuccessful, CTD, download looping, stuch decompressing)
2/13/2022 - Checked Microsoft Store for updates, none found.
2/13/2022 - Logged out of and back into Xbox app.
2/13/2022 - Turned Windows user account into a local account (was logged in with same account used with MSFS)
2/13/2022 - Attempted download. CTD, download looping, stuck decompressing.
2/13/2022 - Downloaded Flight Simulator on another computer and transferred Packages
2/13/2022 - Tried to download Content Manager content such as the World Updates (unsuccessful - CTD, download looping, stuck decompressing)
2/13/2022 - Ran CrystalDiskMark 8 on both system and sim drives, no errors found
2/13/2022 - Updated firmware on sim drive (SanDisk Ultra 3D NVMe) to 211210WD
2/13/2022 - Ran WD/Sandisk S.M.A.R.T. diagnostics on both system and sim drives, no errors found
2/14/2022 - Re-associated Windows user account with Microsoft account (same account used with sim)
2/14/2022 - Synchronized time settings (were already correct and on automatic, but clicked Synchronize anyway)
2/14/2022 - Ran Memtest86, no errors found in 4 passes over 6.5 hours
2/14/2022 - Windows updates checked - no updates available
2/14/2022 - sfc /scannow performed - Windows Resource Protection did not find any integrity violations.
2/14/2022 - DISM.exe /Online /Cleanup-image /Restorehealth performed - no issues found
2/14/2022 6:17:59 PM - CTD while attempting to download Marketplace content. Faulting module name: FlightSimulator.exe
2/14/2022 - Deleted and re-created 8GB rolling cache (on system drive)
2/14/2022 6:33:53 PM - CTD after ~20 seconds in a flight on Medium settings. Faulting module name: WwiseLibPCx64P.dll
2/14/2022 - Ran automated disk cleanup on system and sim drives
2/14/2022 - Ran Speed Test PING ms 29 DOWNLOAD Mbps 115.15 UPLOAD Mbps 8.97
2/14/2022 - Ran the following in an elevated cmd prompt, restarting when prompted
netsh int tcp set global autotuninglevel=disable
netsh int ip reset
netsh advfirewall reset
netsh winsock reset
ipconfig /flushdns
ipconfig /release
ipconfig /renew
2/14/2022 - Launched sim and granted firewall access when prompted
2/14/2022 - Opened Edge while sim was running and tried to access Facebook. Received error “Error code: STATUS_ACCESS_VIOLATION” randomly
2/14/2022 - Note: Sim is running at 60fps in the menu, no performance issue
2/14/2022 - Started downloading World Update II: USA. Speeds of ~20-30 Mbits/s
2/14/2022 - Sim seems to download microsoft-airport-kfhr-friday-harbor-0.1.7.fspackage twice
2/14/2022 - Sim starts downloading Asobo-airport-kdfw-dallas-fort-worth-0.1.16.fspackage.001, .002
2/14/2022 8:08:15PM - CTD right as the prior packages reached 100%, ~1.06GiB downloaded before sim crash. Faulting module name: WwiseLibPCx64P.dll
2/14/2022 - Used DDU in Safe Mode to fully remove all drivers and monitors
2/14/2022 - Performed a Clean Install of nvidia driver 511.79 (without GeForce Experience)
2/14/2022 - Confirmed that no other software was running from the task bar
2/14/2022 - Opened Packages/Official/Steam and removed 1.35GB of incomplete marketplace files:
Asobo-airport-kdfw-dallas-fort-worth-0.1.19.fspatch.001
Asobo-airport-kdfw-dallas-fort-worth-0.1.19.fspatch.002.part
Asobo-airport-kdfw-dallas-fort-worth-0.1.18.fspatch.002
Asobo-airport-kdfw-dallas-fort-worth-0.1.18.fspatch.001
Asobo-airport-kdfw-dallas-fort-worth-0.1.16.fspackage.002
Asobo-airport-kdfw-dallas-fort-worth-0.1.17.fspatch.001
Asobo-airport-kdfw-dallas-fort-worth-0.1.16.fspackage.001
dcscenery-airport-x06-arcadia-1.0.0.fspackage.part
Asobo-airport-kdfw-dallas-fort-worth-0.1.17.fspatch.002
carenado-aircraft-c337-skymaster-1.1.0.fspatch
2/14/2022 - Downloaded 7.32MiB Garmin G1000 NXI from Content Manager - Download and decompression succeeded
2/14/2022 - Downloaded 118.97MiB X06 Arcadia Municipal Airport from Content Manager - Success
2/14/2022 - For World Update II: USA, clicked Delete from the Content Manager to confirm that the temp files were removed
2/14/2022 - Initiated download of 3.46GIB World Update II: USA. Download speed of ~25-31Mbits/s. Total size of download shoes 0B, as before.
2/14/2022 - Opened Edge, immediately went to Error code: STATUS_ACCESS_VIOLATION. This error never shows when MSFS isn’t open, and never appeared prior to this week. At this stage, I am confident MSFS will fail to decompress and CTD at some point during the World Update II download based on this behavior alone.
2/14/2022 - Sim passes last CTD point, dallas-fort-worth and proceeds to download microsoft-usa-point-of-interest packages at ~14-15Mbits/s occasionally spiking to ~30Mbits/s
2/14/2022 - Noting here that Edge still occasionally shows Error code: STATUS_ACCESS_VIOLATION, even if a page is already loaded.
2/14/2022 - The sim noticeably stalls when decompressing microsoft-usa-point-of-interest-0.1.9.fspackage.001. Stalls for ~2 minutes
2/14/2022 9:37:25 PM - CTD while decompresing microsoft-usa-point-of-interest-0.1.9.fspackage.001 - Faulting module name: RenoirCore.WindowsDesktop.dll
2/14/2022 - Opted out of Steam Beta program (for Steam itself, not MSFS)
2/14/2022 9:49:00 PM - Spend about 15 minutes browsing with Edge and Firefox testing various pages. I do not experience any STATUS_ACCESS_VIOLATION errors, as expected, because the sim is closed.
2/14/2022 9:54:00 PM - Confirmed I’m already signed into the Microsoft Store with the same account I use with MSFS
2/14/2022 - Signed out of Xbox and Xbox console companion apps and uninstalled both. Also uninstalled Xbox Live. Rebooted computer.
2/14/2022 - Uninstalled all versions of Microsoft Visual C++ (had about 12 installed) and installed version 14.30.30708 of Microsoft Visual C++ 2015-2022 Redistributible (x64). Rebooted between as prompted.
2/14/2022 - Installed and signed into Xbox app with same account used for MSFS. Xbox app prompted me to reinstall Xbox Live. Did so. Could not launch the sim from the Xbox app as I own it through steam (following support article about reinstalling.)
2/14/2022 11:22:00 PM - Strangely an error is registered at this time but there was no crash. Faulting module name: ntdll.dll. Exception code: 0xc0000409
2/14/2022 11:26 PM - Ran MSFS as administrator. Continued download of World Update II: USA. There was around 650MiB remaining according to the Content Manager. There were no .part files in the Official/Steam folder so I didn’t delete anything, but while it showed a download speed, it didn’t show any percentage or file size. It seems to have skipped decompressing microsoft-usa-point-of-interest-0.1.9.fspackage.001 and 002 which were already in the folder. It moved on to 0.1.10 and then to 1.9.2. It then skipped to other content, leaving the two packages mentioned there without decompressing them.
2/14/2022 11:33 PM - World Update II: USA claims to be complete despite the two packages still being in the folder. Leaving them alone and moving on to World Update III, 5.27 GIB.
2/14/2022 I started the install of World Update III, but instead it started downloading microsoft-usa-point-of-interest-1.9.2 and 0.1.10 again (these were not the two files it was missing, it was missing 0.1.9.fspackage.001 and 002. After a few minutes, a download loop began where it repeatedly installed the same two patches instead of the packages that are missing. Stopped the install and deleted the two fspackage files. Had to restart the sim.
2/14/2022 11:38 PM - Ran MSFS as administrator again. Content Manager now shows 1.71GIB remaning for World Update II. Begin downloading microsoft-usa-point-of-interest-0.1.9.fspackage.001 and 002 again. In the meantime, I confirmed that in Power Options > Advanced Settings, Wireless Adapter Settings Power Saving Mode was set to Maximum Performance and USB settings > USB selective suspend setting is Disabled. Hard Disk > Turn off hard disk after is set to Never.
2/14/2022 11:39:08 PM - Again, an error is logged though the sim didn’t crash. Faulting module name: ntdll.dll. Exception code: 0xc0000409
2/14/2022 11:47 PM - Speed slowly dropped to 1Mbits/s and then sped back up at artound 45% complete. Finished downloading .001 and continued to .002.
2/14/2022 11:52 PM - Another download loop. Now after downloading 0.1.9.fspackage.001 and 002 and decompressing them, it addempted to decompress the patches (which it already decompressed earlier) and immediately starts downloading the fspackages again… it should be downloading the patches if it truly thinks they’re missing, not the packages again! Canceled and deleted entire World Update II: USA through the Content Manager.
2/14/2022 11:54 PM - Started redownloading World Update II: USA.
2/15/2022 12:20:46 AM - CTD while downloading microsoft.airport.katl.atlanta-0.1.5.fspackage.part

1 Like

have you… asus mixer or other asus sound tools installed ?

And I remember in a Beta topic another user reported also these 409 ntdll issue with the “G1000 NXI” mod. But not sure about relation to your issue… in special because of these effects on other running applications like edge.