CTD as soon as Microsoft login window appears

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?
Steam

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
Cannot load the sim. As soon as the option to continue in Safe Mode or Normal Mode appears, upon clicking either option, the Microsoft login window appears for a split second (just the shape of it, no content) and the sim crashes. This happens 100% of the time.

Provide Screenshot(s)/video(s) of the issue encountered:
N/A

Detailed steps to reproduce the issue encountered:
Load the sim
Click either Safe Mode or Normal Mode

PC specs and/or peripheral set up if relevant:
Honeycomb Alpha
Honeycomb Bravo
CH Products pedals
Logitech/Saitek Radio Panel
TrackIR

Build Version # when you first started experiencing this issue:
1.22.2.0


I’ve tried removing all addons, checking for Windows updates (there was one which I installed, no difference even after a restart), and I can’t try Safe Mode because the sim crashes immediately regardless of which one I choose.

Edit: I have now also tried logging out and back into the Xbox app. I have also opened the Microsoft Store and updated everything (including Gaming Services). No change.
Edit 2: I tried resetting the Microsoft Store, no change.
Edit 3: I tried verifying the game files with Steam, no change.
Edit 4: I tried unplugging all peripherals, no change.
Edit 5: I tried opting into the SU8 beta, no change.
Edit 6: I tried ensuring that no other programs were running on my PC at all. No change.
Edit 7: I uninstalled the sim and reinstalled it. It still crashes at the same spot.
Edit 8: I removed my Microsoft account from my Windows login. No change.
Edit 9: I deleted these files, and miraculously, the sim is now running again??

Could that be a remnant from a 3rd party addon maybe?
The overrides.json is also not a normal file I would expect to see in there either.
I don’t have either file, but I am not Steam, I’m MS Store.
Did you look to see what that .json file is for?

1 Like

I had same thinking, but thought the issue is fixed now :rofl:

The overrides.json is not normal… also the ROLLINGCACHE is per default not 3.7Gig ( and existing running.lock points to former crash or msfs is running in background ).

Therefore its allways important if users uninstall the game , as he did in “Edit 7” , also check that this folder is removed manually. It is mentioned within the FAQ, but we find out in a topic that the FAQ is not exact enought because its mentioned only the “packages” folder.

1 Like

Though edit 9 did help me get back into the sim, I had to reinstall the sim because of step 7. I had reinstalled the core files in that step but not the packages. Unfortunately, I have been stuck in download loops and a 20mbit/second download speed that Asobo says “not in their control” for over 18 hours now. I am exhausted with this software.

overrides.json was a file full of strange settings for the core sim, I didn’t quite understand what it was for but it didn’t seem to be related to an addon. Strangely, that whole folder (FlightSimulator) in AppData/Local that contained that overrides file is not even there anymore. Reinstalling the sim didn’t put it back. Maybe that’ll come later (if I ever get the sim to reinstall fully, which is looking unlikely at this point.)

to be sure… google maps add-on was former not installed, or ?

What is happening with the re-install?
Can you describe what the issue there is in a bit more detail?

The main issues with the re-install:

  • Download speed is excruciatingly slow unless I run netsh int tcp set global autotuninglevel=normal first, which increases the speed by about 5x
  • Regardless of whether autotuninglevel is normal or disabled (as some recommend), the install will get stuck decompressing files periodically. I have 300gb free on that drive, so it’s not a space issue. When this happens, I have to force quit the installer and restart it. Sometimes, I delete the .part file it left off on, sometimes I don’t, because either way it seems to just skip that entire file and move onto the next which probably corrupts the install.
  • I get stuck on download/decompress loops where it will download and decompress the same set of files for hours until the installer crashes.
  • When the installer is running, it causes video artifacts on YouTube and frequent “Oh snap” errors and crashes some other programs (for instance I tried to play another game that runs fine otherwise, but it crashes when MSFS is updating)

I followed all of Asobo’s troubleshooting steps including disabling antivirus (I was just running Defender, but I turned off real time scanning, quitting all other programs, making sure drivers were updated, limiting my speed (which I should never have to do, let alone running commands into command prompt). The update has failed ~20 times now and I’ve had to fully restart it about 4 times, aka delete the Packages folder and restart.

At this point, I’m trying to download the entire sim onto my laptop and then transfer the files.

My computer passes stress tests and finds nothing with sfc /scannow. I have problems with 0 other programs or games.

Edit: As we speak it’s stuck decompressing yet again. image

The amount of users with this issue is staggering (it never stops scrolling!) Search results for ‘decompressing’ - Microsoft Flight Simulator Forums

Nope, I’ve never used the Google Maps add-on

yep… and at a lots of it is a “solution marker” present :wink:

don’t do that… nobody start two games at same time… if you see YT artifacts it can point to issues with your connection or just over-stressed hardware ( the installed still use resources ). Just let the pc install the game…

Beside of the Anti-virus Tool… hmmm… the recommendation is to disable “autotuninglevel” , have you tried that too, beside of ‘normal’ setting ?

Perhaps you haven’t looked into what the solution marker is, but it’s always some convoluted BS involving tons of stuff I’ve 1) tried and 2) should NEVER have to do to get an installer to work

Rehashing what I’ve already said and rehashing the same ol’ “solutions” on the forum which mainly involve trying over, and over, and over is not working for me.

I know it’s the habit to blame the user on these forums, but I have been using the sim for over a year without major issues. All of these problems just started. I hadn’t installed anything, updated anything, changed any hardware or peripherals, changed anything with my network or ISP… I did tech support for a living so believe me the insane level of things I’ve tried already are past most peoples breaking points.

ah,… yep… over-read that :relaxed:

Another “to be sure” question: the language pack US you have installed ?

I know a lot of these markers which are more than a retry :laughing: … may be, we can not sure that the issue you had and which let you re-install the game, have a relation to this what now cause the loop issue.

PS::

Nobody want to blame here anyone. We go stepwise to the common things we have in mind and know from former topics.

1 Like

Yeah, US language pack is installed. Interestingly, my laptop hasn’t had any issues downloading the files yet. If it succeeds, that makes me wonder if the issue could potentially be tied to to the nvme drive I’m using for MSFS. It’s nearly new (I got it for the sim, so it’s as old as the sim) but maybe it’s messed up somehow. Of all the stress tests I’ve run, I can’t remember if I ran one that can test m.2 nvme drives. That might have to be my next step.

Thanks for seeing through my frustration. I feel like I’m gonna lose hair over this :laughing:

1 Like

good, this mean your internet connection is fine… bad: it points more to an issue with your main-pc.

I not remember a nvme drive issue report. As long as possible the drives choose reserve-blocks automaticly and if they are realy defect, then absolut nothing will works. But of course… may you can run “chkdsk”.

But what I remember that it was very often a driver, a tool or a setting which cause the loop… sometime also strange issues with files which are left on disc… I hope the reason not let you run again into trouble after copy the files to main pc. … at this moment I think about steam cache clean…

And… which main anti-virus solution you own ? We have case with e.g. AVG where disabling was not sufficent.

no reason… problems like this are frustrating and we know it. For community members, like me, it is frustrating that the first idea was not directly a hit :slight_smile:

1 Like

Another thing you can try, is when the download “hangs up” on a particular file, in this case, flight tutorial A320 landing, is to delete that folder and restart the download.

This sometimes helps it get to the next file, but what it seems to do is jump to the next file, download and decompress it, then go back and get hung up on the same one again. Other times, it triggers a loop. It’s super unpredictable. One thing I can say is that on a normally-operating computer, none of this should probably be happening. Some combination of hardware (and potentially software, though I’ve killed pretty much ever process I can) is causing the installer to struggle. It definitely is in the decompressing stage, it never crashes or fails during downloading from what I’ve seen thus far.

I only have Windows Defender, no third-party antivirus. I did disable Real-Time Scanning per one recommendation from Asobo (in the known installation issues page.) It’s still off, but doesn’t seem to be the culprit. Interestingly, my work laptop which I’m using to download and hopefully transfer the files is running Webroot (which I can’t disable since it’s a work machine) but it hasn’t interfered thus far.

Another thought, and I have no idea if this is what causes the decompression failure: When the decompressing failed last night, I decided to try to extract the file with 7zip, which worked however 7zip showed me 3 files (random PNG files, mostly) that had a CRC Failed error. From my limited understanding, this means those files were somehow corrupt, and didn’t match what should have been in the file. So even though the install hangs on decompressing I’m starting to think it’s definitely because the download itself gets corrupted.

Another thought regarding all of the CTDs I was getting before the sim fully stopped working: Since MSFS is pretty much always streaming data, I am suspecting that the reason it crashed at times could have been for the same reason the installer fails. Somehow my computer is corrupting the download data.

I think after I test transferring the files from my laptop to see if I can at least fly again, I’m going to have to consider a few replacement tests. First, I might try a different hard drive in case this drive is the problem. Second, I might have to run a more comprehensive memory stress test. I have 32GB of relatively new Corsair RAM (1.5 years old) but RAM seems like a potential issue as well if the downloaded files, prior to or during decompression, are stored in-memory. I might also try replacing my network card. I’m not using my motherboard’s onboard Ethernet because it stopped working one day so I bought a PCI network card. Lastly, I’d have to go down the rabbit hole of CPU/GPU/PSU/Mobo (praying I can spare myself that headache!)

Come to think of it… my onboard ethernet stopped working after a power outage. I am starting to wonder if something got fried… that might point me to motherboard in the end. I’ll have to see if Asus has any kind of motherboard diagnostic tools :thinking: