CTD/freezing at Dublin (EIDW)

Very possible, they included some UK & Ireland fixes and this bug has been known to resurface before. Think someone needs to place it on the todo list before every release.

Just one question - have you actually “bought” and installed the free patches from the marketplace?

1 Like

Yes I have the MK Studios EIDW with all updates installed. Regarding World Updates, I only installed the UK updates from the Marketplace a couple of months ago. I haven’t updated the other world updates yet. The actual MSFS update was installed yesterday and no CTD with Fenix A320 or MSFS A310 for the time being.

1 Like

Anyone know a fix to stop ctd at Dublin airport I’ve uninstalled the world updates and the mk studios and the ctd still happens

Install the C++ update on the link above - dated Jan 31st. Should fix the problem.

No that’s not true for me…sometimes I still get CTD.

The problem is not specific to EIDW. I got the same CTD from NZWP. It’s specific to some airport, that’s all. I switched airport and everything was fine.

At first I thought the problem arose from the New Zealand WU. I tried everything: updated C++, connect/disconnect from my account, updated NVidia drivers, turned graphics down, switched plane from a complex to a simple one, tried a FPL without point of interests, tried without FPL, tried with/without ATC, etc…, nothing worked. Every time I got on the taxiway close to one of the entry points of the runway… CTD. If I tried the other entry point it was CTD when I started taking off.

I then switched airport to one in another country and the sim worked fine. Went back to NZ and tried another airport, went fine also. The sim really disliked NZWP. Didn’t try every airport in the sim naturally but my conclusion is this: there is some data in or around some airports that the sim really dislike and doesn’t know what to do with. Asobo has to find out what it is and write some code to check and repair every airport in the sim or modify MSFS so that it is not sensitive to that type of data. That’s all.

The cause of the CTDs IS the C++ update!
I had this CTDs for a very long time. In February in downloaded the C++ update again - still CTDs. I got version 14.32.31332.0. On first of march I did the download again and I got 14.34.31938.0 and this works. I flew to EIDW again and again, I guess 20 times and no CTD.

So I checked my wife’s computer, she flys MSFS, too. Download - got 14.32.31332.0, the old version. Downloaded again and again and then I got the new version . Also checked with my notebook, same thing. It looks like Microsoft has a little bit of a mess on their internal mirrors.

So watch out to get at least version 14.34.31938.0!

Sorry, only saw your question now, I have not had this problem lately, not sure if it’s fixed or just pure luck. I use Navigraph Data Centre and found that using the out dated AIRAC cycles caused CTD’s. Since keeping it up to date, I have had no issues, among other suggestions widely floated are reducing traffic volume.

Hi, I’ve have been having freezes and crashes (CTDs) at EIDW Dublin occasionally and in the last 48 hours 2 CTDs on final to 28L plus 4 attempts at loading to gate have resulted in crashes. This seems to be such a common event for large numbers of people who all have ad-hoc and anecdotal solutions. The CTD issue at EIDW seems to consistently return.

The most consistent solution I’ve seen is to ensure that all Microsoft Visual C++ are installed, updated and/or repaired. Even the older versions. Best source is Microsoft itself. Latest supported Visual C++ Redistributable downloads | Microsoft Learn

Its time for someone in the know and understands the ins and outs of MSFS and the issues of CTDs at EIDW to post an authoritative FAQ on the issue.


1 Like

Not sure about occasionally but mine was flat out CTDing every time. I followed this post from upthread twice now and both times it has solved the issue. I had the issue about nine months ago and this fixed it until I mucked up my community folder the other night. Came straight back here to find this post and it fixed it again