CTD fresh install (Steam) CTD , HP Reverb, WMR, d3d11.dll, nvidia

hmmm… yes, sometime… but not noticed since a while that this happens.

You can ( or should I better say ‘should’ ? ) also disable the windows-quick-start.

in my opinion a normal user, … no, better absolutly no user should need to change this value.
I thought this is a very old issue and may be it happens under very high load only. It is simple a protection that the ‘system’ try to detect that something not respond in time and then the system restart these “service”. So in theory your system stay usable. Possible there are real issue which cause that ‘not responding’ ( here >2seconds) or there are some other side-effects which cause that…

Important
These registry keys should not be manipulated by end users, or by applications outside of targeted testing or debugging during driver development.

:slight_smile:

( I also thought that e.g. HAGS made the situation better related to this issue, but seems not )

@MichaMMA

That Tdrdelay registry thing made no difference whatsoever, so I have now deleted it.

The situation remains the same. CTD CTD CTD

A full week of trouble-shooting every suggestion on the www all to no avail. :frowning: Thanks anyway for your input. I’m done for now.

Maybe wait till Sim Update 4 See if that helps

1 Like

:frowning:

in meanwhile there are some poeple which report ctd with VR gaming.

Unfortunately most do that in wrong categories ( and mix VR and none-VR together ) and so it is realy hard to find out possible “Similarities”, but what I seen for VR is mainly the vcruntime…dll and often HP… some users can play >4hours and run then into ctd, other can play only 20minutes.

For generally solutions I run in meanwhile out of ideas, but as said I not own VR glass. The d3d11.dll is a bit special, what I know about, but may be there is realy an issue and get fix in next update.

Other users tried a lot of different nvidia driver versions, but may be that this is also only waste of time ( but nvidia is still also far away from the old ‘quality’ ).

Very important is to not forget to create a ZenDesk Ticket and put all bug ‘logs’ on it.

1 Like

@MichaMMA

Not sure if coincidence, or a solid solution, but I just managed to complete a flight in a 172SH from KPWK to KOSH in VR all the way without a CTD.

This time I set the CPU affinity, deselected Cores 0 and 1, leaving the sim running on 2 through 7.

Everything ran smooth as silk. Let’s hope this wasn’t a fluke! :slight_smile:

1 Like

nice to read and I think @AmbitiousPilots ( he wrote a script ) will also be happy about…

I still not know how it can works and why is it necessary for you ( I own 8700k ) , but the result is what count :slight_smile: … note: in this way you dont use the core0/1 which are the both with the highest turbo-speed.

Let us stay updated whether this fix your issue finally , might be big help for others.

2 Likes

So, sadly even after setting cpu affinity, I just suffered another CTD on final approach at then of an hour long flight. :frowning:

This is what I feared :frowning:

What I read in meanwhile about VR issues, sounds for me that there is a issue with some kind of VR glasses ( or its platform ) and the game. But we need more discussions with VR users.
If you have bit time, can you possible made some test-flights without VR ? Then we can be more sure about .

In VR I can’t help here so much, except to eliminate the possible reasons which users in “2D” have ( overcloacking, memory xmp mode, overheading (open pc case :slight_smile: ) , virtual memory, drivers, some network related in-game settings ( its a online/multiplayer game), all that stuff ).

A question… is it still the “d2d11.dll” error or is then another “Faulting **” mentioned in Log ?

@MichaMMA

Here’s something odd:

I noticed that my last crash whilst flying, happened at exactly one hour into a flight. Today I loaded up the sim and just left it running in the desktop (windowed) on the main menu page. At exactly 1 hour, it crashed. That’s without me touching anything, I just left the PC sitting in the background with the menu running, doing other things with the flight sim music in the background. I noticed the music fell silent, noted the clock, exactly 1 hour had passed since I started the sim.

So why on earth would the sim just close at an hour???

:flushed: :thinking: :confused: :crazy_face: no idea…

I would expect a thermo issue is more random…

EDIT: but… I forgot… now you are not in VR… there are some rare users which mention if they let the app alone in main-menue, it crashs sometime. Hmmm…

@MichaMMA

Definitely not a temps issue. Both my GPU and CPU are under water.

1 Like

@MichaMMa

@MichaMMA

There are more than 100 Errors listed under Administrative Events, all logged at exactly the same time, the time of my most recent CTD, the one where all that the Sim was doing was sitting untouched at the main Home/Menu Screen in a window. Not exactly pushing any massive load on anything, like actually running the simulation!

They all refer to nvlddmkm and seem to repeat the same 2 or 3 things over and over:

  1. Faulting application name: FlightSimulator.exe, version: 1.14.6.0, time stamp: 0x60420b1c
    Faulting module name: d3d11.dll, version: 10.0.19041.746, time stamp: 0xfc177b9d
    Exception code: 0xc0000005
    Fault offset: 0x000000000012e980
    Faulting process id: 0xbf4
    Faulting application start time: 0x01d72c7541a97197
    Faulting application path: D:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\d3d11.dll
    Report Id: 40e92425-7407-4199-9881-8ede78971b87
    Faulting package full name:
    Faulting package-relative application ID:

  2. \Device\000000aa
    Graphics Exception: ESR 0x52efb0=0x60009 0x52efb4=0x4 0x52efa8=0x7c12b72 0x52efac=0x104

  3. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 5, SM 1): Multiple Warp Errors

  4. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 5, SM 1): Illegal Instruction Encoding

  5. \Device\000000aa
    Graphics Exception: ESR 0x52ef30=0x30009 0x52ef34=0x4 0x52ef28=0x7c12b72 0x52ef2c=0x104

  6. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 5, SM 0): Multiple Warp Errors

  7. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 5, SM 0): Illegal Instruction Encoding

  8. \Device\000000aa
    Graphics Exception: ESR 0x52e7b0=0x20009 0x52e7b4=0x4 0x52e7a8=0x7c12b72 0x52e7ac=0x104

  9. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 4, SM 1): Multiple Warp Errors

  10. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 4, SM 1): Illegal Instruction Encoding

  11. \Device\000000aa
    Graphics Exception: ESR 0x52e730=0x60009 0x52e734=0x4 0x52e728=0x7c12b72 0x52e72c=0x104

  12. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 4, SM 0): Multiple Warp Errors

  13. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 4, SM 0): Illegal Instruction Encoding

  14. \Device\000000aa
    Graphics Exception: ESR 0x52dfb0=0x20009 0x52dfb4=0x4 0x52dfa8=0x7c12b72 0x52dfac=0x104

  15. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 3, SM 1): Multiple Warp Errors

  16. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 3, SM 1): Illegal Instruction Encoding

  17. \Device\000000aa
    Graphics Exception: ESR 0x52df30=0x20009 0x52df34=0x4 0x52df28=0x7c12b72 0x52df2c=0x104

  18. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 3, SM 0): Multiple Warp Errors

  19. \Device\000000aa
    Graphics SM Warp Exception on (GPC 5, TPC 3, SM 0): Illegal Instruction Encoding

  20. \Device\000000aa
    Graphics Exception: ESR 0x52d7b0=0x30009 0x52d7b4=0x4 0x52d7a8=0x7c12b72 0x52d7ac=0x104

  21. \Device\000000aa
    Graphics SM Global Exception on (GPC 5, TPC 2, SM 1): Multiple Warp Errors

ah… it is still that chain:

nvlddmkm - d3d11.dll - version: 10.0.19041.746

the hard cases in the forum :frowning:

Have you already tried a normal sfc /scannow … or dism … check ?

Can you try to execute dxdiag ( simple enter in windows menu ) ?

Which kind of Power Supply you own ( have you the exact model name ? ) ?
( have you at least 700W ? )

@MichaMMA

My power supply a Corsair 1000 Watts RM1000X 80 Plus Gold Gaming Power Supply - Triple SLI Ready

I have run sfc scannow and DISM without issue.

I have also been running through many various NV Drivers, old versions, not so old versions and the latest. Always cleaning them out with DDU in safe mode and reinstalling without networking.

This sim sucks.

thats a good one… so, one possible issue less…

I not understand what’s different in your case, compared to my system. These are both very similar…

Win10 20H2 (19042.906) / i7-8700k / 64GIG RAM(2666) / 2080TI ( ASUS Strix… ) / corsair ax760 / nvidia 465.89 / dxdiag 10.00.19041.0546 / HAGS off

Why does it run fine in my case :thinking:

Have you any other addiational software running ?.. e.g. is somewhat auto-started related to the VR software ?

EDIT:
and an update. My friend let run the PC in main-menu for around 1.5hours without a CTD.

@MichaMMA

I think we have done all we can in trying to diagnose and fix my machine without resorting to a full windows reinstall and I thank you for your help.

Now it’s time to wipe the C drive I think and start with a fresh windows. I’m right out of ideas and have tried every suggestion listed on this forum and others without a sign of success.

So funny that Flight Sim worked fine before the last update!

yes… same for me, running out of ideas.

If the completly reset will also not be helpfull ( I fear so ), I have only one idea about a possible faulty graphicscard :-/ … it’s a computer, deterministic - same driver on same card should cause same behavoir.

Keep us informed about the result :slight_smile: ( all thumps pressed )

Hi,

now, you find the issue ?

It’s good to hear. We get a lot of attacks from users if we tell that hardware can be faulty, in special if some error messages points to it ( vcr…dll, d3…dll ).

@MichaMMA

I have to admit that with replacement hardware, the sim is running flawlessly. The trouble is it’s difficult to know 100% if it was my GPU, or the PSU, as I changed them both at the same time.

What I can say is that both those items did not fail when running other games/sims, I’m just happy to finally be able to enjoy MSFS2020 in all its glory. I just wish I could have obtained the 3090 for the original MSRP and not the inflated price I had to pay. That said, the performance of the 3090 is staggering. :+1:

1 Like

100% agree… my post 15d ago was my last idea I had in mind, in special because your system was like my. About why exactly MSFS bring hardware issues so on top I’am not 100% sure… idea is that it realy bring current hardware at the limits.

But I hope you can use now VR etc. as you want and happy flying :slight_smile:
( I’am sure the devs work allways at optimizations )

1 Like